3 Replies Latest reply: May 26, 2010 7:48 AM by R C-R
mattchiro Level 1 Level 1 (0 points)
Hello,
This message keeps coming up when I start up.

“/Library/StartupItems/ADSLAutoConfig” has not been started because it does not have the proper security settings."

Anyone have any idea what it means and what I can do about it?
Thanks
Matt

imac, Mac OS X (10.6.3)
  • Barney-15E Level 8 Level 8 (40,330 points)
    It means it doesn't have the correct permissions. Try repairing permissions.
    It also means that whatever program uses that needs an update as StartupItems is on the way out in favor of launchd.
  • Mike. Aubert Level 1 Level 1 (5 points)
    Im getting similar messages from about 3-4 different things when I start up.. I have run repair permissions a few times and also tried to change the permissions manually, but I still get the same thing.. the main problem is that I dont know what the permissions are supposed to be(!)
    Its annoying, but I dont know how to get rid of it...
  • R C-R Level 6 Level 6 (14,920 points)
    It more likely means the item wasn't installed correctly, has the quarantine attribute set, & a Permissions Repair will have no effect. By default, /Library/StartupItems/ is empty, so ADSLAutoConfig is a third party startup item, probably supplied by an ISP to support an ADSL Internet connection. Unless that item was installed with Apple's Installer.app or a similar installer that leaves a receipt for it in /Library/Receipts/, the Permissions Repair utility will ignore it.

    I suggest reviewing any application or utility the OP has downloaded or installed from an ISP package that has anything to do with ADSL-based Internet access to make sure it was installed correctly & that install method is compatible with Snow Leopard.