4 Replies Latest reply: Aug 21, 2010 8:32 AM by George Machen
George Machen Level 1 Level 1 (20 points)
OK, first of all, I'm not talking about quoted text (f=f or format=flowed), at least I don't "think* I am.

I keep encountering strange, unpredictable extra line breaks - or at other times the lack thereof - when composing email. I can't see a pattern to it, very frustrating, so I think the problem only occurs when I reply to or forward someone else's email, not starting fresh.

When I reply to an email - and even if I Select All text and remove all quoting (Option-Command-' as many times as necessary), I often see linespacing too tall between some lines. Even if I concatenate the two sentences and enter my own carriage return, there still is too much space between the lines. Then after I send the email and look at the message from my Sent box, there is no line break whatsoever where I thought I forced one. Or other times there are multiple linebreaks. Aaarrgghh!

So my workaround has been to copy & paste my bodytext into Apple TextEdit, then turn right around and copy it from there and paste it into a brand new email message. (If I delete all the text from my original email reply and paste it there, sometimes the weird line breaks still occur.)

It doesn't seem to matter whether I change my offending email reply or forward message from Rich Text to Plain Text; the problem still occurs.

Is there some Mail preference setting I can change to avoid this convoluted and infuriating procedure?

"June 2009" 17" MacBook Pro (5,2), Mac OS X (10.5.8)
  • KevinSmith Level 1 Level 1 (20 points)
    A subpar fix is to hit the shift key as you hit the return key.
    I believe this is known as a "hard break" instead of just a "line break."

    I had this problem. I fixed it for good, but I can't remember what the magic was.
    I am trying to figure it out for my friend, so when I remember (IF I remember...) I'll try to post the solution.
  • KevinSmith Level 1 Level 1 (20 points)
    Well, it appears that I have a lot of terminology totally wrong, so it might be best to disregard my comments.

    I think I addressed this problem on my system a long time ago. I remember being able to remap the return key—but I can't find any evidence that my memory is good or reliable (very sadlly). I didn't get any extra soft/freeware. I didn't download anything.

    It also occurs to me that in other applications (word processors), I have asked them to stop adding the extra space after paragraphs, but I don't find any way of translating that idea.
  • George Machen Level 1 Level 1 (20 points)

    Are these phantom extra line breaks and vanishing line breaks not occurring to anyone else?

    In Mail Preferences > Composing > Responding > Quote the text of the original message

    ...I tried disabling (unchecking) it, but it doesn't make much difference. Again, the problems occur in the body of a

    Message > Reply

    ...not a newly-created message. I've even pasted the body text into TextWrangler and done a "Zap Gremlins" and "Remove Line Breaks," but after I paste it back into Mail and reset my line breaks like I want, I still get extra and/or removed line endings when I review my sent message.
  • George Machen Level 1 Level 1 (20 points)

    If this problem of spurious, unwanted, extra and/or disappearing line breaks in replied email body text were occurring for anyone else than me, I guess everyone would be all over this thread. I'm truly "the loneliest man in town"!