9 Replies Latest reply: Jul 2, 2010 6:15 AM by Calum Morrison
Tixie Level 1 Level 1 (0 points)
I ca no longer use my video on Skype, or iChat, it says my camera is in use by another application. Although I can't think what it is nor how to find it. I've tried doing a reset of the SMC but the problem still persists. Can anyone please help?
Thanks

iMac 5.1, Mac OS X (10.4.11)
  • EZ Jim Level 7 Level 7 (21,785 points)
    Tixie wrote:
    I ca no longer use my video on Skype, or iChat, it says my camera is in use by another application. Although I can't think what it is nor how to find it. I've tried doing a reset of the SMC but the problem still persists. Can anyone please help?
    Thanks


    Welcome to Discussions, Tixie

    If merely restarting your Mac does not correct the problem, try all relevant suggestions from:

    http://support.apple.com/kb/HT2090

    If your iSight problem occurs in more than one app and more than one user account, the reset suggested there often restores proper function of inbuilt iSight.



    However, if after carefully following all the suggestions in the "How to Troubleshoot iSight" article, your built-in iSight still does not work, and if it does not show as a USB device in your Mac's System Profiler, yours is most likely a hardware problem. In that case, contact Apple or an Apple-Authorized Service Provider for service.

    EZ Jim



    Mac Pro Quad Core (Early 2009) 2.93Ghz w/Mac OS X (10.6.3)  MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.3)

    LED Cinema Display  G4 PowerBook  1.67GHz (10.4.11)  iBookSE 366MHz (10.3.9)  External iSight
  • Tixie Level 1 Level 1 (0 points)
    Thanks for your advice EZ Jim, however I did try all of these trouble shooting tips before I posted my question. I only have one user account on the Mac so that's not the problem. I've tried to use the camera in various apps (PhotoBooth, iChat and Skype) but get the same error message; "camera is in use by another application". I tried the SMC reset as well but nothing works. The camera is being detected in the System Profiler. Does this still mean that it's a hardware problem?
    Thanks
  • R C-R Level 6 Level 6 (16,690 points)
    Try this:

    1. Create a new, temporary user account just for testing purposes. (System Preferences > Accounts.)

    2. Log out of your normal account. (Apple Menu > Log Out)

    3. Log into the temporary account & see if you still get the same 'camera in use' notification when you try to use PhotoBooth (for example).

    4a. If not, this means something in your regular account's home folder is at fault.

    4b. If the notification still occurs then the problem is somewhere in the OS itself.

    5. Let us know what happens. You can delete the test account once the test is done.
  • Tixie Level 1 Level 1 (0 points)
    Hi RC-R,
    Yep I already tried that one. It didn't work either and was giving the same error message: "Camera in use with another application". I don't know if it's related, but I also have problems with my HP Photosmart all-in-1 printer. The Mac recognizes that there's a printer connected, but if I try to print from Photoshop for example, it goes through the motion and then says printer not working. I know the printer does work because it scans and copies fine. If I delete the printer from the printer list, re-boot the Mac then add the printer again, it works, however, this fix seems to be only temporary, before long I have to go through the whole process again. Are these problems with my OS? I'm running Tiger 10.4.11. Should I upgrade to Leopard or Snow Leopard? The Camera and Printer used to work perfectly.
  • R C-R Level 6 Level 6 (16,690 points)
    OK, I'm guessing you have already done this too, but to cover all the bases, have you installed the iMac EFI Firmware Update 1.2 on your iMac?

    I think upgrading to Snow Leopard is a good thing to do, but it should not be necessary to do that to resolve your problem, & should you decide you want to use Snow Leopard, check the lists at Mac OS X v10.6: Printer and scanner software to make sure your HP printer/scanner is supported (in both modes) or you might be disappointed.

    Because you get the same results with a test account, the problem has to be in the system domain. Assuming you have not added any software around the time the printer & iSight problems started appearing, the simplest solution might be to reinstall the OS. Otherwise, you will need to hunt down whatever is causing it, which could be a damaged system file, a corrupted system level preference or font, etc.

    My guess is that the camera is not really in use by another app; the message appears instead because of an OS error. If I'm wrong about this, scanning Activity Monitor for a process that could be using the camera might help.
  • Tixie Level 1 Level 1 (0 points)
    I've just tried to download and install the EFI Firmware update, but my Mac wouldn't let me install it. It kept sending an alert saying "This computer does not need this update". So that's another dead end, I'm afraid.

    If I reinstall the OS will I lose all of my data which is currently stored on the computer? For example, all of my photos and images? What about the software that I've added, Photoshop, Illustrator etc, will they all be wiped off too?

    I'm a bit of a dummy when it comes to the technical stuff!
  • elmac Level 5 Level 5 (4,230 points)
    Hi, I would invest in an External Hard Drive (at least as large or not larger than your Main HD..
    I would then suggest you format it for Mac & look into purchasing SuperDuper..
    Then you can have all you info/files etc. backed up & a bootable EHD..
    You can then do a clean Erase & Install.. Ensure you Repair Permissions after Install & Updates..The investment will always bee there for later Macs when you upgrade..L
  • iSafaQ8 Level 1 Level 1 (0 points)
    Hello all

    This is what solved my problem


    1- Close Skype
    2- go to/Library/QuickTime/
    3- DELETE this file: CamCamX5.component
    4- Open and login skype

    http://superuser.com/questions/77295/problem-with-skype-in-snow-leopard
  • Calum Morrison Level 1 Level 1 (0 points)
    I would try removing all non essential USB peripherals first.

    I encountered the same problem, and in order to get the iSight to work I had to remove a USB device from the slots on the rear of my iMac. I assume that some peripherals are causing enough current drain on the USB bus to effect the iSight's operation. My problem USB device was a Miglia TV Tuner.