Previous 1 2 3 4 5 6 7 Next 95 Replies Latest reply: Dec 29, 2014 4:33 AM by dansantner Go to original post
  • w.j.m. Level 1 Level 1 (0 points)
    Had the exact same jumping cursor (really not ideal when working in FCP) problem with my Magic Mouse on my 27" imac i7. Sure enough, I wrapped some foil around the mini display - DVI adaptor running behind my imac, poof! . . . problem disappeared! A total fix. Now if Mac could come up with a real fix so my workstation doesn't look like a grade seven science project I'd appreciate it.

    Thanks for posting the picture furrytoes, otherwise I'd have had no idea what I was doing.
  • Turbomac Level 1 Level 1 (10 points)
    Well this has got to be one of the strangest fixes I have seen. Got my 27" iMac 2 weeks ago and the jumping Magic Mouse cursor and the delayed Magic Trackpad has been driving me crazy. But sure enough, turned on the second monitor and everything goes away. I even tested a couple of times because I couldn't believe my eyes.


    I'm using a 3rd party Mini DisplayPort to DVI adapter. Is anyone seeing this with an Apple adapter or are all of these issues with 3rd party ones?
  • Paul195 Level 1 Level 1 (0 points)
    I have been having this issue too. I am using the second screen for

    A) Secondary display for iMac
    B) Display for PC

    I am currently alternating between the two functions above using the input selector button on the external display.

    In my case the erratic mouse problem exists:

    If the screen is off
    If the screen is on input from PC

    The problem disapears when I select the input from the iMac, or I disconnect the MDP adapter totally. The MDP adapter is a third party product.

    A fix? Or some acknowledement of this issue would be nice...from Apple or anybody.

    Paul195
  • Aneusomy Level 1 Level 1 (5 points)
    Same thing here--

    iMac 27" 2010 i7; erratic/jumpy Magic mouse and trackpad when the external monitor is connected (and OFF); problem resolves if external monitor disconnected from port, or turned ON.

    I have two of the same MDP adapters, both Apple brand, and they both have the same problem. I will try the tin foil...
  • david crooke Level 1 Level 1 (15 points)
    i just tried a suggestion made in this thread which was to turn off wi-fi my mouse immediately started performing as it should.
    I am fortunate I have a desktop computer next to it (which incidentally doesn't have this problem) which i could turn on internet sharing and use ethernet for my internet.
    This proves that the problem is definitely an issue related to conflict between bt and wifi. APPLE YOU NEED TO FIX THE PROBLEM AND HOW TO **** DO YOU LET A BUG OCCUR WITH USING TOTALLY YOUR OWN PRODUCTS ON AN EXTREMELY BASIC FUNDAMENTAL SUCH AS MOUSE MOVEMENT. NOT GOOD ENOUGH. FIX THIS IMMEDIATELY.
  • padcreative Level 1 Level 1 (0 points)
    Just wanted to confirm that the foil around the second monitor's DVI cable has dramatically improved the jumping mouse problem. It has gone from about 4-5 jumps an hour to maybe a couple of times a day. I could probably improve that if I move the cables around a bit, but I can live with it now. Thanks to those who came up with the solution.

    BTW, I didn't have have an DVI-MiniDVI block adapter, it was an all-in-one cable.
  • RotelTHX Level 1 Level 1 (0 points)
    The solution that worked for me (HD 5770, Mac Pro) was to connect the second monitor via an ACTIVE single link MDP to DVI adapter. Tried before with a passive one and had my mouse pointer jumping. You can get AMD certified adapters for Eyefinity (http://support.amd.com/us/eyefinity/Pages/eyefinity-dongles.aspx) - those are all active ones. The dongles sold by Apple are passive adapters except for the really expensive dual link adapter.

    Just buy a 3rd party ACTIVE adapter (e.g. the Accell B087B-006B) and everything will go back to normal.

    Now my mouse is smooth again with dual display setup!
  • Gemini_74 Level 1 Level 1 (0 points)

    The fix for me was to unplug all of the USB connections and magically the cursor stopped jumping around.  I tried to change the batteries also but it didn't help.  I also tried to restart several times but it didn't help.  As soon as I unplugged the USB cords it stopped.

  • Dr Sin Level 1 Level 1 (0 points)

    My first post on support forums!

     

    I experienced the same problem as many of you with my magic mouse behaving erratic.

     

    After som browsing I found a tip and changed the chanel on my WiFi-router and since I haven't experienced any problems with my bluetooth magic mouse! *Knock on wood*

     

    Hope this helps!

  • Christiaan Level 3 Level 3 (525 points)

    Gemini_74 wrote:

     

    The fix for me was to unplug all of the USB connections and magically the cursor stopped jumping around.  I tried to change the batteries also but it didn't help.  I also tried to restart several times but it didn't help.  As soon as I unplugged the USB cords it stopped.

    That is strange. It works for me too!!?

     

    Which is a problem because my keyboard is USB!

  • Chris Cline1 Level 1 Level 1 (0 points)

    I began having this problem after turning on the bluetooth adapter under VMWare Fusion. I have reset my PRAM and the problem seems to have stopped and I am currently running another monitor using 3rd party DVI to MDP on a 15" 2.8Ghz i7 Macbook Pro.

  • fatclockman Level 1 Level 1 (0 points)

    Hi

    I also turned off my wifi and the problem has completey gone.  Track pad works flawlessly.  I do not need the wireless as the macpro is connected to my home network, but this does seem a little lame

  • Michal Hobot1 Level 1 Level 1 (5 points)

    I have a big jumping problem when I have WiFi (AirPort) turned on in the office, but no such problem at home.

    Maybe the problem depends on the WiFi channel used? I don't know how to check the channel number in the office - MacOS doesn't seem to provide such an information in network parameters.

  • Chael Sonnen Level 1 Level 1 (0 points)

    Thank you so much!!!!!!!!!!!

     

    I bought the Accell B087B-006B and 6 ft DVI-D Single Link LCD Flat Panel Monitor Cable - M/M for about $35. I figued it was worth a shot after reading your post. After months of trying other stuff that was recommended, I finally am back to a dual monitor setup without the Mouse freezing and jumping all over the place! I was about to buy a replacement monitor to see if it would solve the problem. I'm glad I was able to solve this cheaply.  I can finally work with 2 monitors again, I can never go back to a single monitor!! Thanks!!

     

    FYI, before I was using the passive cable here: (6Ft Mini DisplayPort to DVI Male Adapter Cable for Apple Macbook, Macbook Pro, iMac, Macbook Air, Mac Mini Laptop)  http://www.amazon.com/DisplayPort-Adapter-Cable-Macbook-Laptop/dp/B003OBXHPC

     

    BTW, I also use streermouse because I can never get the default mouse driver in OSX to behave the way I want.

  • davidfromtas Level 1 Level 1 (0 points)

    my mouse is attached by a wire, but it still jumps. i mean huge jumps, depending on how far i've moved it since it froze.  just directing it to a field is very tricky.  disconnecting and reconnecting will get it moving again when it freezes for such a long time i fear it is not gonna come back...

    anyway, maybe its a new topic, all reports seem to be wireless mouse related..