3 Replies Latest reply: Aug 1, 2010 7:15 PM by Jay Francis
Mari Hutten Level 1 Level 1 (0 points)
So I got a new HDD and I'm adding all my music to it and putting it on my laptop's itunes. So I have a few m4a files that used to play on itunes but for some reason they don't play, nor open, on itunes anymore. Does anybody knows how to fix this and why this is happening? I tried downloading several programs but they are all video converters and say that this file is not valid (because although m4a is for video it's an audio file only).

Macbook Pro, Mac OS X (10.6.3)
  • 1. Re: itunes can't play m4a files
    danitaz Level 1 Level 1 (0 points)
    I just came here to report the same thing. It's happened to me three times now. m4a files (and m4b files too!) suddenly won't open. Sometimes they will show no album art, and if I try to edit them and add the album art back, either the artwork tab will be greyed out, or it looks empty, and no matter how many times I attempt to paste the artwork back, nothing happens (in fact, the artwork is what first alerted me to the problem in an audiobook, and then I started noticing problems with the m4a files).

    So far, each time it happens, I must simply restart my Macbook and everything is fine again. But it is perplexing!
  • 2. Re: itunes can't play m4a files
    Airwolf 2005 Level 1 Level 1 (0 points)
    Hi there ..
    had exactly the same problem as described above. All of a sudden, iTunes stopped playing payed m4a any longer.
    Then I tried to play the same m4a-files using Quicktime instead. But - also in Quicktime, none of the music files could be played!! Finally I repaired the file access rights. Did not help either.

    After all , I did a complete reboot of my Computer. That "resolved" the problem. Once in while this happens - and I must admit - I am not happy with this work around - as I always want to know why something doesn't work - but ... that's all I can contribute so far

    Bye
    Urs
  • 3. Re: itunes can't play m4a files
    Jay Francis Level 1 Level 1 (10 points)
    I'm having similar problems.

    Just curious - try creating a playlist with a couple of the problem songs and attempt to burn them to a CD. I'm getting authorization errors on tracks from CDs that I imported. How about you folks?

    --Jay