13 Replies Latest reply: Jun 28, 2010 5:45 AM by UtterlyFrustrated
Deli95 Level 1 Level 1 (0 points)
I've been able to select and Join CD tracks for years and suddenly the "join CD tracks" menu option in the advance menu is not available for use. It is gray and will not allow me to select it so I can't join tracks. Any ideas? Thanks, MJ

macBook Pro, Mac OS X (10.5.8)
  • Diane Wordsmith Level 5 Level 5 (5,995 points)
    Are you attempting to join before or after importing the tracks? The option is only available prior to importing.
  • Jolly Giant Level 7 Level 7 (25,440 points)
    in addition to what Diane said, there's _*http://dougscripts.com/itunes/itinfo/jointogether.php*_.

    or this _*http://dougscripts.com/itunes/scripts/searchTheScripts.php*_.

    JGG



    edited by the Jolly Green Giant (where Green stands for environmentally friendly)
  • Chris CA Level 9 Level 9 (76,960 points)
    suddenly the "join CD tracks" menu option in the advance menu is not available for use. It is gray and will not allow me to select it so I can't join tracks

    The tracks you want to join must be consecutive and selected before you can select *Join CD tracks*.
    Sort on the very first colunm header with the numbers then select the tracks you want to join.
  • Keith Barrand Level 1 Level 1 (5 points)
    I've got the same problem. I know how to join tracks but the option is grayed out. I have 2 other computers with iTunes (1 pc and 1 mac) and it works on both of them. Just not on the iMac
  • NotEntirelyDim Level 1 Level 1 (0 points)
    Same problem here. Have tried older iTunes versions in attempts to work around possible "improvements" Apple added to newer versions, but same results. Yes, tracks must be joined during initial import, and have been doing so for years. Now "Joins CD Tracks" is grayed out. Any ideas?
  • Chris CA Level 9 Level 9 (76,960 points)
    Have you tried all suggestions in this thread?
    The tracks you want to join must be consecutive and selected before you can select *Join CD tracks*.
    Sort on the very first colunm header with the numbers then select the consecutive tracks you want to join.
  • NotEntirelyDim Level 1 Level 1 (0 points)
    Thanks Chris CA!! Sorting the first column seems to have fixed the problem. Wish I'd checked out this thread before importing a dozen novels with 1,000+ tracks each. Thanks again!
  • UtterlyFrustrated Level 1 Level 1 (0 points)
    Like others I have being loading audio books where each track is joined to form one but in the last few days this problem arose.

    What puzzled me was that having brought 4 books home from the library I was able to properly open the first book and process it as usual. This now sits in the system correctly identified and joined up. When I attempted to load the 2nd book it was possible to load the first 2 cds but on attempting to process the 3rd. the join tracks was greyed out. No matter what I tried it was not possible to load that cd or any subsequent ones. Books 3 and four suffered the same fate.

    Today I returned the books and collected a further 2 in an attempt to see if it was a problem with the original cds. This time the first book would automatically import the first track despite the preferences being set as Show CD. Again the option to join tracks was greyed out.

    Strangely enough the 2nd book when it was opened it immediately displayed all the tracks being joined and gave the full details of the book and I was able to immediately load this OK

    What worked properly before does not do so now.

    Can anyone offer a solution to the problem?
  • Chris CA Level 9 Level 9 (76,960 points)
    Can anyone offer a solution to the problem?

    Yes.
    In fact, there are several good suggestions above.
  • UtterlyFrustrated Level 1 Level 1 (0 points)
    Many thanks for your reply Chris CA.

    I agree that they are very good suggestions but they don't work. I always join every track using the methods described but when the function is greyed out and everything that you try does not work then a solution is needed.

    I am seeking a resolution that will let me fully download a complete book but nothing that you refer to provides it.

    Why can I insert a CD into the system and find that without any assistance from me that all the tracks on 6 CDs are joined up properly and can be easily downloaded whilst another CD will not permit the joining of tracks at any price.

    There is no explanation in any of the replies that cover what is happening. Why when the preference is set to show CD does it automatically install. Perhaps if this could be clarified I might be able to join tracks.

    Further assistance will be appreciated
  • cypherism Level 1 Level 1 (80 points)
    It is available before you import, it will not join after
  • Also Frustrated Level 1 Level 1 (0 points)
    I, too, am baffled by this problem. I know how to join tracks, and what the limitations are (before importing, selected, etc), but I've joined tracks today from the first five CDs of an audiobook, while on the sixth CD the Join CD Tracks option remains stubbornly greyed out. Yes, I tried clicking/reclicking on the first column; yes, I reloaded the CD; yes, I rebooted iTunes. And yes, I'm very frustrated. I've done lots of track-joins so I know the problem is not inexperience. The problem lies somewhere in iTunes software.
  • UtterlyFrustrated Level 1 Level 1 (0 points)
    Like you I feel that it is an iTunes software problem. No doubt those greater brains at Apple are too busy flogging their latest iPhone to be bothered with problems with iTunes. Although with the posts on varying sites seem to confirm that they don't have their troubles to seek there either.

    It is looking very much like they don't care about selling faulty products as long as the cash comes in. Their moto should be flog it first and worry about fixing it later.

    It would appear that our only resort is if we know any good prayers to start saying them.

    Yours in Utter Frustration