10 Replies Latest reply: Jan 17, 2011 8:29 AM by AlexisCW
TasaDasa Level 1 (0 points)
I cannot add files to the "file sharing" section in iTunes.

It is not listing exported keynote or pages files, or allowing me to add any files to it (drag-drop or add). It fails silently, not even a message in console appears.

I have tried to restore iPad, installed keynote and pages again, and same thing happens. Any hints would be much appreciated.


Message was edited by: TasaDasa

32GB + 3G
  • red555 Level 4 (2,550 points)
    When you have apps that include file sharing capability, the apps will be listed at the bottom of the apps page/tab in itunes when your ipad is highlighted under devices.

    _At the bottom of the itunes tabbed page for apps_, Click on the app you wish to add the shared file to. You will see to the right of that at the bottom, any files currently being shared. If there are none, you can drag and drop them onto that spot and they should carry over to the ipad after you click Apply/Sync.

    Hope this helps.
  • Dragon76 Level 1 (105 points)
    I'm having the same problem. Does not work for any app supporting file sharing.
  • TasaDasa Level 1 (0 points)
    I have isolated this problem to iTunes. If I plug my iPad into another mac, everything works as expected. I have also tried to reinstall itunes (just the app) but the problem remained. I have also tried creating a new user acc on the same box, and the problem is still there.

    I will now try to completely remove iTunes (setting and all) and see what will happen. Will keep you posted.
  • TasaDasa Level 1 (0 points)
    Just to keep you posted. Reinstalling iTunes (completely with all the files, settings and libraries) was not helpful. My MacBook still stubbornly refuses to interact with a File Sharing section. Other macs are happily swapping files with my iPad.
  • TasaDasa Level 1 (0 points)
    The problem was in Xcode. I am registered iPhone dev, and had been working with os4 beta. I had pre 18/5 release of Xcode and SDK. Upgraded to the latest version, and everything is working as expected.
  • buysellpay84 Level 1 (0 points)
    How??? I had the 3.2 beta 2 with the same problem. I update to the 3.2 FINAL RELEASE but iPad still not work with file sharing!
  • SiPIg Level 1 (0 points)
    I too am having a similar problem, though intermittently. If I try to add files immediately after connecting my iPad, everything works. If I think sync and go back to add more files, I am experiencing the same problem as the OP. I can't add files (with a silent failure) and files that I have already synced to my iPad are not appearing. The only way round this that I have found to date is to disconnect my iPad and reconnect then select the files.

    Have only just come across this. Will raise wityh Apple when I am back from my holidays (about to leave now and am busy trying to get stuff transferred to my iPad). I hope that Apple fixes this soon...
  • Peter Hardy Level 1 (45 points)
    I get the same as you Si, most infuriating. I get like half a minute or whatever after the ipad shows up in itunes to add stuff, like just now I need to add things to pages, vlc player and comic zeal, I only has time to add the documents to pages because by the time I got round to adding avi it had stopped working.
  • mmedicine Level 1 (0 points)
    Does anyone have a solution to this yet? I'm using Itunes 10 with IPAD. I have access to share files under the apps section for a brief period of time. It only shows the documents that associated with the file sharing app for a short time (approx 30 seconds) then the list is blank. I can no longer add/delete/transfer anything via usb file sharing.
  • AlexisCW Level 1 (0 points)
    Does anyone have a recommended app for viewing JPG or WinRar Files?

    I've downloaded several apps and none of them seem to work with the file sharing part of iTunes. I'm still not sure if it's because the app doesn't support the file or if it's iTunes. If the app doesn't support the file should I be able to see it anyways? Thank you.