Skip navigation

Problems after moving iPhoto library to new computer

5894 Views 14 Replies Latest reply: Jan 3, 2012 12:57 AM by Terence Devlin RSS
CWainright@me Calculating status...
Currently Being Moderated
Jun 3, 2010 5:03 PM
I bought a new MacBook and copied the iPhoto library from my old to the new. Maybe not the best way to do it, but it seemed to work perfectly at first. I can view pictures without any problem, but I get some errors when I try to import new photos from my iPhone.

Error1:
Connection failed
The server "NameOfMyOldMac" may not exist or is unavailable.... blah blah blah

Error2:
The volume for "NameOfNewPhoto(s)TryingToBeImported" cannot be found.
Insert the disk or connect to the server volume and wait for... blah blah blah
Cancel - Find Photo - or OK

After taking a while to eventually time out, I can click OK or cancel to the errors and the photos import with no problem. It's obviously looking for something on my old mac. It sounds like it thinks the iPhoto Library is still there, but I can't seem to find the file(s) that reference the old name.

For kicks, I renamed my new mac to my old mac's name and just got a different error.
MacBookPro6,2, Mac OS X (10.6.3)
  • LarryHN Level 9 Level 9 (54,870 points)
    is the original library on your old Mac a managed library (the advanced iPhoto preference to "copy imported items to the iPhoto library" is in its default checked state) - or a referenced library (that preference has been unchecked)?

    How did you "copy the iPhoto Library"? - the correct way is to drag it over intact as a single entity from the old system to the new system

    LN
    3.33 GHz Intel Core 2 Duo 27" iMac, Mac OS X (10.6.2), iPhoto 8.0.2, 750 GB OWC EHD, Sony DSC-W150 camera, ATP PhotoFinder Mini GPS
  • LarryHN Level 9 Level 9 (54,870 points)
    that is correct - I would just do it again - maybe something weird happened

    LN
    3.33 GHz Intel Core 2 Duo 27" iMac, Mac OS X (10.6.2), iPhoto 8.0.2, 750 GB OWC EHD, Sony DSC-W150 camera, ATP PhotoFinder Mini GPS
  • Ian Rob Calculating status...
    Have had similar problems. Copied iphoto folder from latest Snow leopard macbookpro to mini 2.26 at same level of op system. When I try to open with iphoto on the mini I this get message that newer version of iphoto has updated the library and quit is the only option?
    Mini 2.26 Intel, Mac OS X (10.6.4), also macbookpro
  • JesseZlatsin Calculating status...
    I have the exact same problem. My original iPhoto was on an old MacBook Pro. I just purchased a new Mac Mini and copied both the iPhoto library as well as my "Albums" directory where I stored all the photos. On the MacBook Pro I had the "Copy items to the iPhoto library" unchecked. Now all the photos I try to access from iPhoto on the Mac Mini give an error that it is trying to connect to the MacBook Pro, but cannot find the old "Albums" directory. Thankfully, I backed everything up before I started so I can redo it again, but I've tried twice without success (once just copying the directory, and once using migration assistant.)

    So, how can I successfully move iPhoto from my MacBook Pro to the Mac Mini while preserving the unchecked state of "Copy items to the iPhoto library?"

    Thank you!
    Jesse
    Mac Mini (new unibody), Mac OS X (10.6.4)
  • crna Calculating status...
    YUP! Same problem -- moved from a 10.5.8 iMac 24" to a new 10.6.3 iMac 27" and iPhoto library is missing 3000 plus photos plus all of my albums. When I copied the Picture library over I got an error message that I needed to "Transfer the iPhoto Library from a backup disk. I have all my files on a Time Machine drive -- but the New Computer doesn't recognize the files in that either. Apple is starting to remind me more and more of Microsoft -- get a new computer -- get more problems.
    iMac 27", Mac OS X (10.6.3)
  • Terence Devlin Level 10 Level 10 (121,660 points)
    Currently Being Moderated
    Sep 15, 2010 2:54 PM (in response to crna)
    If you want assistance you really need to give us more information than

    moved from a 10.5.8 iMac 24" to a new 10.6.3 iMac 27" and iPhoto library is missing 3000 plus photos plus all of my albums.


    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • crna Level 1 Level 1 (10 points)
    I guess the only information I can offer is what the people wrote in the posts ahead of me. I did check into the PhotoLibraryManager Software and I can get a free trial copy of that. I guess I agree with the person above -- it's aggravating to have to go find software to do something Apple should do with it's own software.
    Thanks for your response, though. If you have any suggestions for moving an iPhoto library, I am sure it may help others -- not just me.
    iMac 27", Mac OS X (10.6.3)
  • Terence Devlin Level 10 Level 10 (121,660 points)
    Currently Being Moderated
    Sep 16, 2010 10:32 AM (in response to crna)
    Well here's how to move a Library from one Mac to another:

    Link the two Macs together: there are several ways to do this: Wireless Network, Firewire Target Disk Mode, Ethernet, or even just copy the Library to an external HD and then on to the new machine...

    But however you do choose to link the two machines...

    Simply copy the iPhoto Library from the Pictures Folder on the old Machine to the Pictures Folder on the new Machine.

    Then launch iPhoto. That's it.

    This moves photos, events, albums, books, keywords, slideshows and everything else.

    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • crna Level 1 Level 1 (10 points)
    Tried all that. Tried to transfer from my CCClone (FW), my Time Machine backup (USB), directly from another computer by FW-- finally gave up and bought PhotoLibraryManager -- as someone suggested above -- and it opened my Library, set up all the old albums and all was well. Too bad Apple can't include a program in the system that will do that.
    Go figure. So get PhotoLibraryManager -- it works!
    iMac 24", Mac OS X (10.5.8)
  • Keith Misson Calculating status...
    Currently Being Moderated
    Jan 2, 2012 12:11 PM (in response to crna)

    Same problem. A new Mac Mini, and old Mac Book Pro running 10.5.5 and iPhot 6 or something similar.

     

    Followed the instructions to the letter and iPhoto 11 seemed to import fine. A cursory check seemed everything to be OK. However, I had previously had the photo library located on a NetGear ReadyNAS box and later on when that drive wasn't on, I had trouble locating some photos. No pattern, just that trying to load some pictures causes the spinning ball to appear then "Device ReadyNAS is not available" and then the dreaded "Do You Want to Try and Locate this Photo?"

     

    Turning the NAS box back on again removes the problem, so it looks like for some reason some of the pictures still think they are located there. I've tried all the iPhoto library repair options, but no luck. I have deleted old 'rolls' then reimported the images from the Mac Mini drive which of course cures the problem, but I have no way of knowing which of the 8000+ images are causing issues until I double click the thumbnail.

     

    Most oddly, even when I have gone through the 'find photo' process and located the image on the new drive, it won't disply it. It still requies me to find the full old pathname.

     

    Is there anyway of searching the library for broken links so that I can assess the scale of the issue? Other than downloading 3rd party software?

  • Terence Devlin Level 10 Level 10 (121,660 points)

    The problem arises because you had the Library stored on an inappropriate disk - this NAS. No there is no software that will search for broken links.

     

    Regards

     

     

    TD

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.