Previous 1 2 3 Next 105 Replies Latest reply: Jun 28, 2015 6:55 AM by mangufromsan francisco
Kristopherk07 Level 1 Level 1 (0 points)
Able to see/authenticate and connect to network at work which is using WPA-PSK. iPad shows connected/steady connection and has been assigned IP address. However, unable to connect to Internet, acts like not actually connected to internet. Tried my iPhone and it exhibits the same issue.

Saw a few like issues posted here, but indicated fixes did not work, i.e., reboot router and iPad.

Thanks

Kris

Lenovo Idea Pad, Windows 7
  • Doug Eldred Level 4 Level 4 (3,270 points)
    What DOES work okay on your workplace Wi-Fi network? I'm sure my company's setup is different, but we have Wi-Fi, but only so our PCs can connect to the company VPN without an Ethernet cable. Just getting connected to Wi-Fi gets you nowhere in that environment.

    Might you need a certificate or VPN also?
  • Kristopherk07 Level 1 Level 1 (0 points)
    Sorry, I should have mentioned that my Windows Mobile 6.5 Smartphone does connect and have internet access, so appears something with iPad and iPhone.

    As we are a small firm, trying to figure out before calling our Network Consultant.
  • virtualgeo Level 2 Level 2 (245 points)
    What is the router address that shows up under DHCP? If it starts with 169, you're not connected.
  • Tammy H Level 1 Level 1 (0 points)
    Help!! New iPad can't connect to the internet with my wifi @ home.
  • Kristopherk07 Level 1 Level 1 (0 points)
    Had our Network consultant come out again and looks like was issue with configuration of router with DNS pointed/setup wrong. Once he adjusted that connection is fine.

    Thanks
  • Father Karras Level 1 Level 1 (0 points)
    I have this same issue at the office but here's the kick in the teeth, my iPhone works just fine. So ultimately my question is what is different about the WiFi connection on the iPad & the iPhone (I have a 3GS w/ iOS4).

    Technically our IT team doesn't support iProducts so they're not likely to spend much time trying to find a fix, their response is simply it's the iPad or it's Apple. Given that it works just fine @ home and @ a buddie's place though it certainly seems to be something about the WiFi connection at the office. As far as I could tell, all the DHCP details were essentially the same, nothing obviously pointing to a problem. I know that they have all non essential ports turned off (which is not the case with most personal/home WiFi connections) as I wasn't able to send or receive from my gmail or hotmail until I told them which ports needed to be opened.

    Anybody out there have a similar experience or is tech savy enough to have an idea of what the issue might be so I could point them in the right direction ?

    Thx
  • Vermonter84 Level 1 Level 1 (0 points)
    I'm having the exact same problem! Wifi works fine at home/coffee shops, but dose not work when I'm working at the hospital, which has a large network.

    I tried the work around proposed by the Princeton University IT Dept involving turning off Push notifications and mail retreival, but nothing has helped. This is very frustrating and Apple has not helped out in any way. Any ideas??

    It seems to potentially be a problem with the DHCP renewing the IP address too often, but I'm not sure.

    Thanks to anyone with ideas.
  • JimHdk Level 7 Level 7 (28,060 points)
    Vermonter84 wrote:
    I'm having the exact same problem! Wifi works fine at home/coffee shops, but dose not work when I'm working at the hospital, which has a large network.

    I tried the work around proposed by the Princeton University IT Dept involving turning off Push notifications and mail retreival, but nothing has helped. This is very frustrating and Apple has not helped out in any way. Any ideas??

    It seems to potentially be a problem with the DHCP renewing the IP address too often, but I'm not sure.

    Thanks to anyone with ideas.


    Most likely your problem has nothing to do with the Princeton University problem (this is actually ancient history at this point).

    Presumably you have updated your iPad to the latest OS software which is now at 3.2.2?

    You aren't very specific as to what your problem is but if your problem is that you simply cannot connect to the hospital network and that network requires credentials (e.g., user-id/password) requested via Safari then turning off Autofill in Safari may help. Go to Settings > Safari > Autofill and turn this OFF.
  • bpatel8579 Level 1 Level 1 (0 points)
    Hello,
    I bought Ipad in april and had no problems until yesterday. Unable to use WiFi to connect to internet. It shows that WiFi is connected but Safari cannot open any webpages - says "Safari cannot open webpage as it is not connected to internet". Other computers are connecting fine. WiFi connected but no internet access. I have already done basic troubleshooting - updated software to 3.2.2, rebooted multiple times, network reset multiple times, renew lease multiple times, forget this network, increased brightness, autofill OFF in Safari etc. and no resolution.

    PLEASE HELP. without internet connection Ipad is useless.

    Thanks
  • Vermonter84 Level 1 Level 1 (0 points)
    Thanks for your reply.

    Yes, I have updated to 3.2.2. I checked the autofill settings in Safari and it was already turned off. The network I'm having problems with is a hidden network with no security settings. iPad will connect with full signal, but allow no internet access via safari or any other app. I tried resetting the network settings and performed a full restore (twice) with no luck. Computer, iPod touch and cell phone work fine on this network. I even called the hospital IT help desk, but they, of course, had no clue what was going on.

    Any ideas? Thanks so much!
  • JimHdk Level 7 Level 7 (28,060 points)
    Vermonter84 wrote:
    Thanks for your reply.

    Yes, I have updated to 3.2.2. I checked the autofill settings in Safari and it was already turned off. The network I'm having problems with is a hidden network with no security settings. iPad will connect with full signal, but allow no internet access via safari or any other app. I tried resetting the network settings and performed a full restore (twice) with no luck. Computer, iPod touch and cell phone work fine on this network. I even called the hospital IT help desk, but they, of course, had no clue what was going on.

    Any ideas? Thanks so much!


    You probably were not assigned an IP address by the router. If you go to Settings > Wifi > +your network+ and touch the ">" you will see the details of your connection. If the IP address starts with 169 you are not really connected. If this is the case you may have to consult again with your support group. They should be able to look at router logs to see what is happening.
  • Vermonter84 Level 1 Level 1 (0 points)
    Thanks again for your help!

    I brought up the network info on both my iPad and Ipod touch when connected to the same hospital network and the info only differed in the last three digits of the IP address (both started with 172). Again, the iPod worked fine and the iPad could not access Internet. Occasionally the iPad will begin to load a page and the stop working.

    Any other ideas?

    Thanks.
  • Hynes Level 1 Level 1 (0 points)

    To fix the "wi-fi connected, but no internet access" try the following:

    [Mac Only - "internet sharing configuration"] that is sharing via iMac Airport.

     

    Stage-1.Fix mixed up ip configurations (internet sharing must be turned on)

     

    Check your current Airport ip address if it starts with 192.... or 168... by going to:

    System Preferences> Network> AirPort,

     

    a) if it starts with 168... the Status report should say: "Airport has a self-assigned IP address and may not be able to connect to the internet."

    b) click on the "Advanced..." button (lower right coner)

    c) click TCP/IP

    d) change "Configure IPv4" to "Manually"

    e) set "IPv4 Address" to 192.168.1...... ( please check your ethernet IP before punching in the values)

    f) Subnet Mask: "255.255.255.0" and click "OK"

    g) click "Apply"

     

    After applying, AirPort should have a "green" dot by it and the Status should say: "AirPort is connected to AirPort Network and has the IP address 192.168.1.4." Now we've fixed the IP Problem.

     

    • Now try connecting to your wifi, if all went well you should be able to surf the net.... if not, check your iDevice's "DHCP Values"
    • If you are getting values starting with 168... jump to Stage-2 please.

    Stage-2 Fixing "Firewall settings"..Check to see if your firewall is blocking any incoming connections.MANUAL TESTa) enter your iDevice Wi-Fi setup and choose "Static"[ Settings> General > Wi-Fi > b) under Choose a Network..." select your wifi name and touch the blue "arrow" to change the "IP Address" manually.c) select "Static" and in put the values used in your Wi-Fi setup. eg:

    • IP Address 192.168.1.4 - last value should be something different from the ethernet vlaue to avoid confliction.
    • Subnet Mask 255.255.255.0

    no try browsing the internet, if still it does not work, get back into the wi-fi setting and tap the DHCP tab and let the iDevice automatically generate values, if the IP Address still start with 168... and the Subnet Mask 255.255.0.0, we can be sure that our firewall is blocking incoming connections.

    Now we are sure that the firewall is blocking incoming connections, lets jump to stage-2.b

     

    Stage-2.b Fixing "Firewall settings"..

     

    1) Open "Finder" and hold "cmd"+"shift"+"G" to open the "Go to the folder:" dialogue and type in the following strings or copy paste:  /private/var/log/appfirewall.log

    2) click "go"

    3) right click the "appfirewall.log file and "open with" your defalut text editor. (leave open)

    4) now open "System Preferences" > "Security" > (if your firewall is locked, click the padlock to permit changes and enter password if prompted to do so). "Advanced..." (this should bring up a dialogue in which we will allow our blocked wi-fi settings.)

    5) In the text editor scroll down to the current time and date event value.

    6) quickly jump to your "Network" settings pane in the system preference and click on AirPort in the left pane(make sure your Status reads ""AirPort is connected to AirPort Network and has the IP address 192.168.1.4.".

    7) go to your iDevice and connect to the internet through your wi-fi and monitor the "text editor" to see if there are any changes to the file as in "requesting a file update or reload" just allow it.

    7b) if there are no changes, turn "AirPort off" and after 10 sec, turn "AirPort on" the "appfirewall.log" file should have an update or reload request.

    8.a DEBUGING

    save the file and check which value is being blocked based on turning AirPort on and off. once you have determined that, (in my case the line was: May  1 20:16:19 iMac-Hynes Firewall[143]: Deny named data in from 10.0.2.4:58458 to port 53 proto=17)

    and the value being blocked was: May  1 20:16:19 iMac-Hynes Firewall[143]: Deny 'named' data in from 10.0.2.4:58458 to port 53 proto=17)

    "named"

    8.b. after determining the blocked value of the AirPort incoming connections...

    9. go back to the "Firewall" settings,("System Preferences" > "Security" > (if your firewall is locked, click the padlock to permit changes and enter password if prompted to do so). "Advanced..." (this should bring up a dialogue in which we will allow our blocked wi-fi settings.)

    10. search for the value you discovered being blocked(eg: "named"... or waht ever yours is...) and check if there is a "Block incoming connections" if there is...good. Just click on the arrows at the end and change the values to: "Allow incoming connections".

    11. be sure to uncheck "Block all incoming connections" if checked at the top of the dialogue before clicking ok.

    12. after clicking ok, click the padlock to prevent further changes and close the systems preference

     

    Turn AirPort on if it was off and connect your iDevice and voala!!! you are surfing the net...! Hope it works for you all


     

  • celomb Level 1 Level 1 (0 points)

    Thank you SO MUCH. I have been searching for a solution to this problem for almost a week (haven't called anyone or gone to Apple though because I'm out of the country). However, I owe you my sanity. This should be the response to every single inquiry about this problem in relation to the 169. IP issue.

     

    Thank you!

Previous 1 2 3 Next