Previous 1 2 3 Next 344 Replies Latest reply: Jul 17, 2013 4:42 PM by ImaEarth Angel
Scott Campbell5 Level 1 (60 points)
After installing, Safari 5 wouldn't load anything without hanging. I cleared the cache and it is a lot better. Still, about one out of every four pages hangs so long that I get a timed out message. What's going on?

I have no plug-ins, add-ons, or other extras except for ClickToFlash for blocking Flash content. Any ideas?

By the way, I do think the new Reader function is impressive. That, at least, is looking good.

MacBook, Mac OS X (10.5.8)
  • Hawaiian_Starman Level 7 (21,405 points)
    Try disabling ClickToFlash and see if that stops the hangs. Settings are found via the Safari Menu.
  • Scott Campbell5 Level 1 (60 points)
    I've uninstalled ClickToFlash and have seen little if any improvement. Indeed, just coming back to this site led to this:

    Safari can’t open the page “” because Safari can’t find the server “”.

    Not only is it having trouble loading pages with any complexity (ads, video, etc.), it also hangs ALL tabs while that one page fails to load. In other words, I cannot open a new tab and browse. Everything grinds to a halt.
  • Scott Campbell5 Level 1 (60 points)
    Is no one else getting this awful hanging? I have to stop loading sites and then re-load. Often they load just fine on re-load. Safari had this issue a long time ago, but here it is again. Why should I have to load pages numerous times?

    I'll try a different router and report back when I do, but, for now, I'm going back to Firefox.
  • nwriko2 Level 1 (5 points)
    i've got very similar issues.. tried to re-install but to no avail.
  • llmac Level 1 (0 points)
    same here...every tab i open gives me that message...even apple, wikipedia, even yahoo. i loved safari 5 for all of ten minutes. unless apple fixes this I'm switching to firefox because it's kinda ridiculous. if anyone finds out please post! it would save me some pain
  • Enkidu Jones Level 1 (0 points)
    Since upgrading to Safari 5 I find that my ADSL2+ modem gets messed up (it seems to lose its connection periodically). I reset the modem and wait a couple of minutes and all is fine, or I just use Camino or Chrome and all is fine. I don't know if this is in any way related to the problems others are having, but it is weird (and very inconvenient)...
  • Hawaiian_Starman Level 7 (21,405 points)
    Hi Scott

    After installing S5, I see ClickToFlash is compatible. Only problem has been with CosmoPod.

    As you suspect, it might be a router issue. Which router are you using? Have you unplugged/waited/plugged in the router, then restarted the computer/Safari? If not, try that and see if the loading sequence returns to normal speed.

    I'm using a dual band Airport Extreme. My load times are very fast - faster than Safari 4.0.5. In case you are using an Airport Extreme, have a read of this this recent MacWorld article.
  • Richard Wessels Level 2 (240 points)
    I have been using S5 on both Mac and Windows and I have not seen this issue. However, it sounds like a DNS issue. Remember that S5 does DNS prefetching. If you are doing something odd with your DNS at your router or on your system, this might the the cause of your issues.

    I would start there and see if this is the reason for your difficulty.
  • Hawaiian_Starman Level 7 (21,405 points)
    it sounds like a DNS issue. Remember that S5 does DNS prefetching. If you are doing something odd with your DNS at your router or on your system, this might the the cause of your issues.

    Forgot to add I'm using OpenDNS codes, entered on the Airport Extreme with no load problem. Yet, this might be a different experience on a non-Apple router.
  • andyBall_uk Level 7 (20,490 points)
    good idea

    worth entering dns values in System prefs - network - advanced - DNS too

    use google's public dns, opendns, or & for example.

    I'd check in a new user account too, just in case it proves to be limited to one account.
  • Beren Level 1 (0 points)
    Count me as another one who is having problems with the "beach ball" ever since I upgraded to Safari 5.0. I have emptied the Safari cache--in fact, I have emptied every cache Yalu will allow me to empty. I have run disk permissions. But nothing seems to stop the beach ball. I haven't figured out precisely what triggers it. It doesn't appear to be any particular website. My computer just hangs. I can't even get to the left corner Apple in order to reboot--I have to unplug the machine and then boot up.

    Very frustrating!
  • Elzlaik Level 1 (0 points)
    I am also having issues with pages not loading, loading half-way or loading without the embedded videos. I have reset Safari, repaired disk permissions, deleted every non-apple plug-in from /library and ~/library but it isn't having any effect. If anyone has any other recommendations I would be happy to hear them. Oh ... and I'm not doing anything funny with DNS in my router, which is an Apple Time Capsule.
  • GKP2004 Level 1 (125 points)
    I am having the same issues. The blue bar stops mid way and if I have any other tabs open, everything just fails to load. However, I had an interesting thing happen...I was on and I clicked on a link from that page, it was just stuck there, so I thought, well I will click on another link, right when I did that, the page turned white as it was trying to go to my original link. I replicated this a few times too.
    Has anyone else noticed that?
  • Robert Barnett Level 1 (30 points)
    Count me as one who is definitely getting incomplete page loads with S5. I run no plugins, no extensions, no changes since installing S5 on Tuesday. My broadband speed test is 20.36 mbps. But you would think I was using dial-up.
    Very frustrating. Heck, it took 3 tries to get logged in to the discussion board.
Previous 1 2 3 Next