1 2 3 4 5 6 7 Previous Next 97 Replies Latest reply: Mar 17, 2012 1:49 AM by Kevin Quattro Go to original post
  • 45. Re: Safari 5 breaks embedded Quicktime player
    Krag Level 2 Level 2 (215 points)
    Kalle, I get the same with Safari on your website, but Camino/Firefox works fine.

    I see you use iWeb and that the mp3 code requires Quicktime. (type="video/quicktime)

    Also consider a Mac/PC friendly format so Windows users do not have to download/install Quicktime.
  • 46. Re: Safari 5 breaks embedded Quicktime player
    Matt (Guitar) Roberts Level 1 Level 1 (0 points)
    Hi. I have an embedded quicktime video on my web page (created in GoLive CS1). Ever since updating to Safari 5 the video image is chopped to half it's actual size (only part of each frame is visible). Firefox no problem. url is
    http://www.truearts.net/

    P.S. The page actually loaded once correctly in Safari 5 just now, but several attempts later all failed.
  • 47. Re: Safari 5 breaks embedded Quicktime player
    Kalle Koerner/Slice-Production Level 1 Level 1 (0 points)
    Hy Matt,
    first I love your music! I watched it on iPad.
    I have no problems on my MacBookPro with OSX 10.6 (not updated)
    But on the actual system OSX 10.6.4 and Safari 5 it don´t work with
    Quicktime! Can Apple hear us? And solve this problem? I hope so!!!
    Maybe it can load the pages once, if you have it in your Cache, but
    like you said several attempts later all failed. I can´t understand the behavior from apple,
    waiting and waiting and not reacting........But never the less, I like your musik, little bit
    like Average White Band, i love it! Greatings from Germany/Hamburg/Kisdorf
    Kalle!
    www.slice-production.com
  • 48. Re: Safari 5 breaks embedded Quicktime player
    gbissett Level 1 Level 1 (0 points)
    Link - I can't get embeds to work, but I also can no longer get Safari 5 to play the MP3 files when I go directly to the file URL. That is, I paste the URL to the file (ending in MP3) directly in the bar. The player loads, but it doesn't play.


    I'm seeing the same thing here, for some mp3s on amazon cloudfront. Safari 5.0.1 on 10.6.4.

    This mp3 won't play (quicktime player loads as described above, then nothing happens):
    http://channel1.soundfolder.com/system/tracks/279/original/LOOP003.mp3

    This one works:
    http://channel1.soundfolder.com/system/tracks/12/original/riding_spaces.mp3

    Here are the headers:
    ~ $ curl -I http://channel1.soundfolder.com/system/tracks/279/original/LOOP003.mp3
    HTTP/1.0 200 OK
    x-amz-id-2: RrfDkG2TzW5vmjv6DIG/sfTkHwrq/rh8rk+QzlrIBZK1Sjrpn6uLpAEOFHPPctP7
    x-amz-request-id: 07DB0CEC235B97EF
    Date: Sun, 08 Aug 2010 07:38:42 GMT
    x-amz-meta-gid: 1002
    x-amz-meta-mode: 33188
    x-amz-meta-mtime: 1269146685
    x-amz-meta-uid: 1002
    Last-Modified: Sun, 21 Mar 2010 04:45:02 GMT
    ETag: "1d5e67667259237bcaa01c44fdc12d68"
    Content-Type: audio/mpeg
    Content-Length: 4213027
    Server: AmazonS3
    Age: 910
    X-Cache: Hit from cloudfront
    X-Amz-Cf-Id: ce1aff4a1a385d6897f03ce7387ab0a1992db88a41aa5ee78b1d3c8aec2a8f41f50a1adb42b7101 f,16ce5a9d7e32194c7dc8bee19371ffc48fc7aec1e0f85e3e6ba5b8393d64a9fbbc747aa8bf5ce4 e0
    Via: 1.0 3385d16e8aeaf70ee27cd12b252c5d04.cloudfront.net:11180 (CloudFront), 1.0 d696dc7332d6144b808920e479cc1b6e.cloudfront.net:11180 (CloudFront)
    Connection: close

    ~ $ curl -I http://channel1.soundfolder.com/system/tracks/12/original/riding_spaces.mp3
    HTTP/1.0 200 OK
    x-amz-id-2: Hg5feeUQpWhuPbeFSmtu8KJYafSppwRgtwLhVxPxKiEIn0YwjHPWMA75Q2pw4M
    x-amz-request-id: 32D140E91499DB26
    Date: Sat, 14 Aug 2010 10:20:29 GMT
    x-amz-meta-gid: 1000
    x-amz-meta-mode: 33188
    x-amz-meta-mtime: 1268103890
    x-amz-meta-uid: 1000
    Last-Modified: Tue, 09 Mar 2010 03:05:09 GMT
    ETag: "c6590329b2741ad4b9eebe1d7746297e"
    Content-Type: audio/mpeg
    Content-Length: 4885003
    Server: AmazonS3
    Age: 777
    X-Cache: Hit from cloudfront
    X-Amz-Cf-Id: f1ef7164893f998845c204d50983436b03e8b0860839056973687db2e1d1209d2d06cd7b6ae532d e,fbb39c7e03eef2af7c0e7c97ca034505dbfa0157d796fcc55703dc0f9d8964d8e9e550af9ef362 ce
    Via: 1.0 3271e339a6be51e6856e421ae66d02d8.cloudfront.net:11180 (CloudFront), 1.0 d696dc7332d6144b808920e479cc1b6e.cloudfront.net:11180 (CloudFront)
    Connection: close
  • 49. Re: Safari 5 breaks embedded Quicktime player
    andyBall_uk Level 7 Level 7 (20,320 points)
    confimed - i see that the non-playing one has no title & artist data, which has been noted before with 'problem' mp3's.
    Seems the ok one was an itunes save ? & the other used lame 3.98.

    I'm sure it's the ID3 info or data layout within the mp3 container causing this, albeit that QT/Safari should not be so picky about it.
  • 50. Re: Safari 5 breaks embedded Quicktime player
    Singproinc Level 1 Level 1 (25 points)
    Andy-

    I don't think the ID3 tags are the problem. Mine have ID3 tags, and they don't work. I tried it both ways initially without tags, then with tags; and it didn't matter.
  • 51. Re: Safari 5 breaks embedded Quicktime player
    andyBall_uk Level 7 Level 7 (20,320 points)
    I think you're right; looking at the raw file data it seems more likely the way/order that it's presented & would imagine that saving in another app/changing ID3 version might get the file processed correctly.

    Another thread with similar .mov file problems had files which worked as a direct URL, yet not as an embed. The same file behaved normally using an iframe calling it directly - that's not the case with gbissett's mp3.
  • 52. Re: Safari 5 breaks embedded Quicktime player
    Singproinc Level 1 Level 1 (25 points)
    Andy-

    Mine are also direct URLs, not imbedded in a page. They don't work. I was hoping there might be an imbed code that would get them to work.

    I created my mp3's in Compressor, then I tagged them using MP3 ID3X.
  • 53. Re: Safari 5 breaks embedded Quicktime player
    Kalle Koerner/Slice-Production Level 1 Level 1 (0 points)
    Hy Apple,
    do something to solve this Problem.
    I can't believe that everybody in the world
    has to have problems to playback
    mp3 files on internet sites on Safari build also with
    iweb from Apple. It's unbelievebal!!!
    Kalle Koerner
    www.slice-production.de
  • 54. Re: Safari 5 breaks embedded Quicktime player
    andyBall_uk Level 7 Level 7 (20,320 points)
    Hi

    playing with gbisset's mp3 - I seem to be able to get it playing consistently, even after removing the QT cache, by using

    <object data="http://channel1.soundfolder.com/system/tracks/279/original/LOOP003.mp3" />

    Someone else like to check that? - the file was previously a non-player whether embedded, iframed, audiod, videod or accessed directly.
  • 55. Re: Safari 5 breaks embedded Quicktime player
    Bluey1980 Level 1 Level 1 (15 points)
    I have the same problem, embedded .mpg in my site. Safari 5 QT plugin will not play it just sits there with the quicktime logo showing. Works fine in Safari 4 and Fire Fox.

    Can someone in Apple please acknowledge problem or tell us there's a fix on the way?!
  • 56. Re: Safari 5 breaks embedded Quicktime player
    Richard Schletty Level 1 Level 1 (10 points)
    At the risk of producing flagellating tongues of rapid oxidation, I must say that I am very disappointed that a representative of Apple has not commented on either of the two major threads at Apple Support relating to this very serious issue. Does Apple really want to have their QuickTime-Safari combo perceived as broken?

    Even after a fresh install of Windows Server 2003 on a new box, with configuration of my sites in IIS from scratch, I am still getting the upside down Q-mark at http://www.hungryforheaven.com . Movement 3 does play, however. Looks like I will have to check my MP3 ID tags. Please note (as I wrote earlier) that the simple process of recreating an MP3 from a WORKING MP3 at the same 192 kbps setting (w/o changing ANY tags) renders that MP3 inaccessible in Safari (as long as I had not first listened to it in Firefox). Has anyone looked into my suggestion that Firefox is "hijacking" the MP3 player preference and in the process messing up Safari's MIME type association? Please check back and read what I wrote about that. Let's get this resolved! I am truly embarrassed for my beloved Apple.

    "How long can this keep going on?" Name that tune and band!
  • 57. Re: Safari 5 breaks embedded Quicktime player
    Bluey1980 Level 1 Level 1 (15 points)
    I've tried to access my .mov on My work mac and it plays fine. Safari 5.0 so it seems like 5.0.1 is the issue.... for what it's worth.
  • 58. Re: Safari 5 breaks embedded Quicktime player
    Kalle Koerner/Slice-Production Level 1 Level 1 (0 points)
    *I´ve sent the bug report to Apple Support and I hope*
    *they solve the problem!*
    *Kalle Koerner*
    www.slice-production.de
  • 59. Re: Safari 5 breaks embedded Quicktime player
    Kalle Koerner/Slice-Production Level 1 Level 1 (0 points)
    NO REACTION TIL NOW FROM APPLE SUPPORT!
    I CAN´T UNDERSTAND THAT!
    PLEASE APPLE-TEAM WAKE UP!
    Kalle Koerner