Previous 1 2 3 4 Next 87 Replies Latest reply: Jul 30, 2012 10:15 PM by Aljamali Go to original post
  • donna9802 Level 1 Level 1 (0 points)
    I got the answer!!!
    After many, many, many hours...finally a simple solution.

    Go to your applications folder and open the utilities folder.
    Open Java Preferences and click on the 2 Restore Defaults buttons.

    If for some reason, your java preferences mysteriously disappears from your dock, reinstall Java for Mac OS X 10.6 Update 2 at http://support.apple.com/downloads/

    Then go back and open Java Preferences and restore defaults.

    Ta-Da!! Hope this helps you guys~
  • boilerme Level 1 Level 1 (0 points)
    Reinstalling Java 10.6 Update 2 did the trick for me. Thank you very much.
  • Axl Kun Level 1 Level 1 (0 points)
    This worked for me, thanks a lot!

    However, it seems odd that restoring Java values has anything to do with other plugins. Anyway...
  • bruno.piscaglia Level 1 Level 1 (0 points)
    same for me... even after enabling extensions on Safari 5, it does not work. It was just after Mac OS update+install of S5.
    "missing plugin" still shown in Mail.app :-((
    So any info/idea ?
  • bruno.piscaglia Level 1 Level 1 (0 points)
    oups.. I just read your "java" trick.. and indeed it works... thanks a million !
  • diedoggie Level 1 Level 1 (0 points)
    This just happened to me too on upgrade to mail, when upgrading Mac OS X to 10.6.4

    Not sure if it was the Safari 5 upgrade or the OS upgrade but to fix.

    a) shutdown mac mail
    b) Open Safari
    c) In Preferences > Advance, check the 'Show Develop menu in the menu bar'
    d) In Develop ensure 'Enable Extensions' is checked
    e) open mac mail

    now mail attachements are correctly showing up
  • Fish1973 Level 1 Level 1 (0 points)
    I did all of this to no avail - still not working! I can see everything if I use the quick look function though. I find this very strange! Anybody else having this problem?
  • iyengar22 Level 1 Level 1 (20 points)
    Thanks a bunch, I clicked on restore Java defaults and the "missing plugins" message which displayed instead of the Mail attachment, disappeared and the icon (doc pdf etc) for the attachment returned.
    Thanks
  • smartdrink Level 1 Level 1 (0 points)
    This was my problem! Thanks!!! Great info!
  • Ricksp Level 1 Level 1 (0 points)
    I saw this problem when I uploaded a cell phone jpeg and noted it said the image was 32 bit.

    Solved the problem by going to Applications > Mail and selecting Get Info. Clicked the box "Open in 32-bit mode"

    All is working now.
  • Robert-J.L. Level 1 Level 1 (0 points)
    Thanks for this solution !!!

    Saves me the rest of even more of a whole lot of time figuring this crazy solution out...

    Very Strange that Java preferences would influence any settings in Apple Mail.

    You'ld think that Apple would have developed its own Mail application without any co-dependency on external software.....

    Crazy to think of this, there must be something wrong in your head too to figure out any illogical solution like this, BUT It WORKS !!

    So I Bow and Salute you in deep respect!!
  • theoxygenthief Level 1 Level 1 (0 points)
    I've had the same problem. Since 10.6.1. It happens with PDFs & JPGs in my case. Rebooting mail normally solves it in the short run, or do the reset Java thing if that doesn't work. What upsets me is that I submitted a bug report for this a week after Snow Leopard was released and it's STILL not fixed.
  • Bottino Level 1 Level 1 (0 points)
    Thanks the Java trick works perfectly.
  • Mujii Level 1 Level 1 (0 points)
    Thanks for that diedoggie,

    did a general Mac OS update this morning and all of my mail attachments disappeared with the "missing plug-in" message appearing in their place. What is the connection between Mail and Safari that causes this? I would just like to know (for curiosity sake)
  • regarp Level 1 Level 1 (0 points)
    RE: Open Java Preferences and click on the 2 Restore Defaults buttons.

    This worked for me, so far. Hard to tell as the problem is only intermittent for me. In case it re-occurs, I'll go the next step and reinstall the Java for Mac update. Btw, what's the Java version number it updates to? Just wondering if I'm running that already.
Previous 1 2 3 4 Next