Skip navigation

Missing Plug-in?

156802 Views 87 Replies Latest reply: Jul 30, 2012 10:15 PM by Aljamali RSS
  • Mujii Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2010 10:57 AM (in response to diedoggie)
    hey there,

    Followed your advice and it worked (once), so far the only one of the suggestions on this thread which has made any difference in my case.

    When I logged in today, we are back to the same story again; I went in to Safari to repeat the process and it is still as I left it yesterday, with 'enable extensions' on etc. Any ideas?
    iMac aluminium, Mac OS X (10.6.4)
  • shaunrainbow Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 28, 2010 4:40 PM (in response to neom1985)
    I had this problem myself today and, after a little head scratching, reinstalling Java etc discovered that I had left a Java app which runs in a browser open. Quitting the Java app, then quitting mail, solved the problem - hope this helps someone!
    27" Imac, Mac OS X (10.6.4), Apple Lover!
  • Biebies Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2010 5:33 AM (in response to donna9802)
    Yes,...... this one worked for me also!
    Great thanks a lot.
  • Bruce Zake Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 4, 2010 10:07 AM (in response to neom1985)
    Nothing, Nada. All of these solutions have not worked for me.

    10.6.4 - Tried the Safari suggestions, the Java suggestion, the 64 bit to 32 bit suggestion. I am stuck. Repaired disk and permissions. Next up - using Disk Warrior. What do I have to lose?

    Bruce
    MBPro 3.06ghz, Macbook 2.16ghz, iMac 2.4ghz, PowerMac G5, Mac OS X (10.6.4)
  • Ed State Level 2 Level 2 (445 points)
    Currently Being Moderated
    Aug 5, 2010 12:52 PM (in response to neom1985)
    Same here...

    But the java "trick" worked. Somehow.
    3.2GHz 8-Core MacPro, Mac OS X (10.6.4), 22G RAM
  • HenryS Level 2 Level 2 (295 points)
    Currently Being Moderated
    Aug 7, 2010 8:02 PM (in response to donna9802)
    donna9802 wrote:
    I got the answer!!!

    If for some reason, your java preferences mysteriously disappears from your dock, reinstall Java for Mac OS X 10.6 Update 2 at http://support.apple.com/downloads/


    Yep. The other suggestions (Safari settings, Java Defaults) did not help. Only totally reinstalling the Mac OS X 10.6 Update for Java 2 update does it for my machine in Mail!! Now my attached pics show up, instead of shown with blank square, and the moniker "Missing Plug-in".

    How or why this occurs, I leave to others.

    Henry
    MacPro1,1 2.66GHz. 4 Core, MBP 15" ( i5 6,2) 2.53GHz, MB2008 2.0GHz, Mac Mini (10.5.8), Mac OS X (10.6.4), iPhone 3GS OS4, AEBS 802.11n v7.4.2
  • Sean Keogh Calculating status...
    Currently Being Moderated
    Aug 27, 2010 2:55 AM (in response to donna9802)
    This worked for me as well, instantly. Many thanks.
    Is it not possible to mark the post as "solved"?
    MB Pro 2010, Mac OS X (10.6.4)
  • jtpc07 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2010 4:40 PM (in response to Sean Keogh)
    I restored java settings and even reinstalled java and still get the missing plug-in message in safari when trying to view apple's videos about the new iphone.
    Mac, Mac OS X (10.5.8)
  • beatleboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2010 4:59 PM (in response to diedoggie)
    I followed your instructions, but there is one correction. "Enable Extensions" is in "Debug". That, in itself, didn't work. I also checked "Log JavaScript Extensions To System Console". That worked...once. Then it went back to showing the missing plugin message.
    Mac Pro, Mac OS X (10.6.4)
  • beatleboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2010 5:01 PM (in response to beatleboy)
    Oh, and, by the way, the problem only occurs with forwards or replies.
    Mac Pro, Mac OS X (10.6.4)
  • beatleboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2010 5:11 PM (in response to beatleboy)
    Aha! I found the fix! In Safari, open the Develop dropdown and check Disable JavaScript. Close out Mail and reopen it. Attachments will now work. i went back to Safari to uncheck Disable JavaScript then closed and opened Mail again. It still worked!
    Mac Pro, Mac OS X (10.6.4)
  • OrganicApple Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2010 4:07 AM (in response to beatleboy)
    This worked for me also. Thanks!
    MacBook Pro 13", Mac OS X (10.6.4)
  • pascalboyer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2010 11:19 AM (in response to neom1985)
    I had the same "missing plug-in" problem. The Java Preferences Restore did nothing.
    However, on that same Java Prefrence window pane, I clicked
    Run Applets In their own process
    [and not "In the browser process" which s the default).

    Now Mail works, and displays pics and pdfs fine...
    iMac, Mac OS X (10.6.4), iMac
  • gmmort3 Calculating status...
    Currently Being Moderated
    Sep 11, 2010 8:07 PM (in response to neom1985)
    Restoring the defaults in Java preferences will not make the most important change.
    Check to make sure select radio button "in their own process" for Run applets option.

    You should be good and make sure to close and re-open mail after you make the changes.
    Mac OS X (10.6.4)
  • Guuz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2010 6:52 AM (in response to gmmort3)
    That worked for me, thanks!
    iMac 2.33 GHz Intel Core 2 Duo, Mac OS X (10.6.1), 4GB 667 MHz SDRAM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.