Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Jul 30, 2012 10:15 PM by Aljamali Go to original post
  • Mujii Level 1 Level 1 (0 points)
    hey there,

    Followed your advice and it worked (once), so far the only one of the suggestions on this thread which has made any difference in my case.

    When I logged in today, we are back to the same story again; I went in to Safari to repeat the process and it is still as I left it yesterday, with 'enable extensions' on etc. Any ideas?
  • shaunrainbow Level 1 Level 1 (0 points)
    I had this problem myself today and, after a little head scratching, reinstalling Java etc discovered that I had left a Java app which runs in a browser open. Quitting the Java app, then quitting mail, solved the problem - hope this helps someone!
  • Biebies Level 1 Level 1 (0 points)
    Yes,...... this one worked for me also!
    Great thanks a lot.
  • Bruce Zake Level 1 Level 1 (10 points)
    Nothing, Nada. All of these solutions have not worked for me.

    10.6.4 - Tried the Safari suggestions, the Java suggestion, the 64 bit to 32 bit suggestion. I am stuck. Repaired disk and permissions. Next up - using Disk Warrior. What do I have to lose?

  • Ed State Level 2 Level 2 (445 points)
    Same here...

    But the java "trick" worked. Somehow.
  • HenryS Level 2 Level 2 (295 points)
    donna9802 wrote:
    I got the answer!!!

    If for some reason, your java preferences mysteriously disappears from your dock, reinstall Java for Mac OS X 10.6 Update 2 at

    Yep. The other suggestions (Safari settings, Java Defaults) did not help. Only totally reinstalling the Mac OS X 10.6 Update for Java 2 update does it for my machine in Mail!! Now my attached pics show up, instead of shown with blank square, and the moniker "Missing Plug-in".

    How or why this occurs, I leave to others.

  • Sean Keogh Level 1 Level 1 (15 points)
    This worked for me as well, instantly. Many thanks.
    Is it not possible to mark the post as "solved"?
  • jtpc07 Level 1 Level 1 (0 points)
    I restored java settings and even reinstalled java and still get the missing plug-in message in safari when trying to view apple's videos about the new iphone.
  • beatleboy Level 1 Level 1 (0 points)
    I followed your instructions, but there is one correction. "Enable Extensions" is in "Debug". That, in itself, didn't work. I also checked "Log JavaScript Extensions To System Console". That worked...once. Then it went back to showing the missing plugin message.
  • beatleboy Level 1 Level 1 (0 points)
    Oh, and, by the way, the problem only occurs with forwards or replies.
  • beatleboy Level 1 Level 1 (0 points)
    Aha! I found the fix! In Safari, open the Develop dropdown and check Disable JavaScript. Close out Mail and reopen it. Attachments will now work. i went back to Safari to uncheck Disable JavaScript then closed and opened Mail again. It still worked!
  • OrganicApple Level 1 Level 1 (0 points)
    This worked for me also. Thanks!
  • pascalboyer Level 1 Level 1 (0 points)
    I had the same "missing plug-in" problem. The Java Preferences Restore did nothing.
    However, on that same Java Prefrence window pane, I clicked
    Run Applets In their own process
    [and not "In the browser process" which s the default).

    Now Mail works, and displays pics and pdfs fine...
  • gmmort3 Level 1 Level 1 (5 points)
    Restoring the defaults in Java preferences will not make the most important change.
    Check to make sure select radio button "in their own process" for Run applets option.

    You should be good and make sure to close and re-open mail after you make the changes.
  • Guuz Level 1 Level 1 (0 points)
    That worked for me, thanks!