Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Jul 30, 2012 10:15 PM by Aljamali Go to original post
  • plumcreative Level 1 Level 1 (15 points)
    I am still on 10.5.8 and the Java fix did not work.

    I tried to do the Safari fix someone suggested also but there is no choice for Enable Extensions under Develop tab.

    I tried the Get Info Mail fix-- but there is no option to click "Open in 32-bit mode.

    And I tried the idea about Java Preferences "Run Applets in their own process" but that didn't work.

    Does anyone have any other ideas to try?

    Thanks
  • drdanaviv Level 1 Level 1 (0 points)
    I turned off extensions altogether and the problem in mail.app is GONE.
  • cygnetswan Level 1 Level 1 (0 points)
    I just started having this problem today. None of the Java Preferences solutions worked.

    A friend sent me a .eps file attachment, and it shows up as a "missing plug-in" in my Mail App. I can get the attachment if I log into MobileMe on the web, though needless to say that is rather annoying. She just resent the file zipped, and I got that through the Mail App.

    So -- why does the eps file alone show up as a missing plug-in??
  • bandit Level 3 Level 3 (875 points)
    Thanks donna9802.

    Tonight I got the missing plug-in. Tried your suggestion and BAM! the picture appeared. Nice of you to share........
  • erbel47 Level 1 Level 1 (0 points)
    I had the same problem with pdf files.

    Just reset Safari, click Safari --> Reset Safari... and wait for Safari to reset. For me, everything was back to normal after this.

    erbel47
  • Martin Kimeldorf Level 1 Level 1 (0 points)
    IN my Develop menu there is no Enable Extensions, rather a series of menu commands that start with the word Disable. Can you clarify how to set the Enable Extensions after turning on the Develop menu.
  • Alex McKnight1 Level 1 Level 1 (0 points)
    I also did the Java preferences Restore Defaults fix and it worked! Thanks Donna....wonder why this discussion is not marked as solved
  • 8thsession Level 1 Level 1 (0 points)
    The Java-trick didn't work for me, but I think I have come to a permanent solution to this:

    1. Close Mail.
    2. Backup the file "com.apple.Mail.plist" from the /username/Library/Preferences/ folder to a another location on your hard disk (or an external hard disk), and give it a new name, e.g. "com.apple.Mail.old"
    3. Delete the original file from the /username/Library/Preferences/ folder and make sure to empty your Trash.
    4. Start Mail. Now you will see that all your accounts and other setup is gone, but do not worry.
    5. Close Mail.
    6. Delete the newly generated com.apple.Mail.plist in the Preference folder mentioned above, and move back the file you backed up in step 2. Make sure to rename it from .old to .plist
    7. Start Mail, and voilà.

    This solved the problem permanently for me (running OS X 10.6.6 and Mail 4.4).
  • o_alemão Level 1 Level 1 (0 points)
    Nothing of the above mentioned solutions worked for me
    MacBook Air, OSX 10.6.6, Mail 4.4
  • Dr Hook Level 1 Level 1 (0 points)
    If anyone is still looking for a solution to this problem, I have just resolved mine (plug-in messages appearing while browsing) by simply downloading the latest Adobe plug in :

    http://get.adobe.com/flashplayer/

    I now no longer have the message in either Safari of Firefox and have images instead. This is on a week-old new MacBook with 10.6.6

    Strange that you should have to do this with a new machine,m but I suspect it is a glitch from the latest OS update.

    Hope this helps.
  • Dr Hook Level 1 Level 1 (0 points)
    I meant to add, it's obviously not a Safari issue. When I looked at the same page in Firefox and got the same "plug-in missing" message I realised it had to be an OS fault. By chance the Adobe plug-in was the first I tried, and it worked. I would have downloaded my way through a bunch of different updates for different products if it hadn't.

    I did try the Java default, the Java update and the "enable connections" route before checking my Firefox connection. None of them worked for my particular case, but the Adobe update did.

    Message was edited by: Dr Hook
  • splurben Level 1 Level 1 (90 points)
    I reset /Applications/Utilities/Java Preferences defaults and Apple Mail is displaying PDF images correctly now.

    Cheers!
  • HairyMcLeary Level 1 Level 1 (0 points)
    Resetting Java does work... for a few days! Then I have to repeat the process.
    This is getting a little tiresome, has anyone come up with a permanent solution?
  • tahlenius Level 1 Level 1 (25 points)

    Thanks, this solved this for me.

  • Pirate71 Level 1 Level 1 (0 points)

    I have been looking months for a solution to the "missing plugin" and missing attachments (replaced by blue square and question mark). Yes, I have "display remote images" checked. Yes, I have clicked on "default" for Java preferences. There is only one set of preferences and one "Default" button in my Java Pref folder. I have downloaded and reinstalled Java, which didn't change anything. I have deleted Apple.Mail.plist. This didn't fix it. I have repaired disk permissions. This didn't fix it either. I have tried everything but reinstalling Mail. Can anyone provide a permanent fix for this problem?

     

    Also, Mail keeps asking for my passwords for all accounts!

     

    This is my second iMac (27" i5) and it has not been a good experience - very strange behavior. HD is very noisy, won't stay asleep, can't wake up when it is asleep - have to restart and magic mouse won't stay connected.