Skip navigation

Missing Plug-in?

156891 Views 87 Replies Latest reply: Jul 30, 2012 10:15 PM by Aljamali RSS
  • John the Greek Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2011 9:27 AM (in response to Dimitar Ratchev)

    Why should this involve Safari? It's a mail-related issue isn't it? I have the problem and I only use Firefox as my browser!!

     

    Found some suggestions here: http://hints.macworld.com/ , but I couldn't understand them!!

  • bertfromhaarlem Calculating status...
    Currently Being Moderated
    Jun 16, 2011 6:19 AM (in response to neom1985)

    In Applicatie Folder GOTO JAVA Help applicatiions and do a Standard, everything will be okay.
    It happens me once a month. Probably a new JAVA version.

  • theChuckster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 20, 2011 10:37 AM (in response to neom1985)

    Here's how I solved mine:

     

    In the "Applications/Utilities" folder, you'll see "Java Preferences."   Open it, click "Restore Defaults", then quit the Java Preferences application.  You'll need to quit and restart Mail and any web browsers you may have open for the change to take effect.

  • mcg- Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jul 19, 2011 12:39 AM (in response to neom1985)

    I just updated a MacPro(1.1) 10.4.11 to 10.6.8 with a fresh install.

     

    Mail.app had the 'missing plugin' message for attachments (though the quick viewer worked)

     

    I followed the Safari advice.

     

    >Advanced

    >Checked the option 'Show the Develop bar in menu'

    Clicked the newly appeared 'Extensions' tab and made sure extensions were on, but with no extensions in the list.

     

    Restarted mail.app and pdf's now show in the body of emails.

     

    I haven't read all through this thread so I'm not sure if this fix will stick, I hope so.

  • kirky123 Calculating status...
    Currently Being Moderated
    Jul 24, 2011 3:43 AM (in response to neom1985)

    Hi all i had the same problem missing plug-in? try d the Java thing but did,t work, so took it in to apple to see a genies i don't know exactly what he done but he opened a new account on my mac and it all worked fine! he went back in to me own account and started to delete some files (i don't know what ones) but he said the files that got deleted will automatically replace themselves and are needed to play the video clips? he said it could of just been a corrupt file whilst installing os x lion?

     

    sorry for my lack on computer speak but im sure someone on here will be able to work out what the genies done and translate it in to computer lingo!

  • MacManTN Calculating status...
    Currently Being Moderated
    Jul 26, 2011 5:03 AM (in response to donna9802)

    Perfect.  That seems to be it. FYI, I am running Java prefs 13.5.0 with Mail 4.5 and OSX 10.6.8.

  • jlodgeconnely Calculating status...
    Currently Being Moderated
    Aug 3, 2011 8:46 PM (in response to neom1985)

    I am first getting this problem after I tried to watch old shockwave/flash files from enhanced CD made cir. 2003 on my 17" MacBook Pro.When asked if I accepted the install I noticed they were Macromedia files, which I think are in the way of Safari's original plug-ins to read flash content in the files now missing a plug-in to view Adobe Reader files (PDFs) in Safari

  • cyberboyce Calculating status...
    Currently Being Moderated
    Aug 7, 2011 10:33 AM (in response to neom1985)

    Same thing here. "Missing plugin" I went to Adobe and downloaded beta for Lion 10.7. About two minutes. Restarted...All is now fine.

  • Burkey Level 2 Level 2 (205 points)
    Currently Being Moderated
    Aug 8, 2011 2:32 PM (in response to donna9802)

    Worked perfectly! Thank you! I reinstalled Java for 10.6 Leopard and all "missing plugin" messages are gone!

    There is a new Java also for Lion. I haven't upgraded to Lion yet so I did the Leopard one.

  • Brachson Calculating status...
    Currently Being Moderated
    Aug 15, 2011 12:41 PM (in response to neom1985)

    OS X: 10.6.8

    Mail: 4.5

    Java: Newest Java update 5

     

    And it just does not work! I have tried all your tips and I can not find the way to make it running. Do you have any ultimate solution?

     

    What versions you have and how you fix it?

  • CableShark Calculating status...
    Currently Being Moderated
    Sep 1, 2011 6:11 PM (in response to neom1985)

    I think, its Adobe CS4 or CS5, when you install it through piratebay or any torrent,  and you block the updated through terminal.

  • CableShark Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 1, 2011 6:58 PM (in response to kirky123)

    I just tested that,, for me that was the case...   Adobe CS4 crack which blocked updater through the terminal windows was doing it.

     

    Just remove Adobe CS4 and re-install the operating system, and problem fixed.

     

    Thanks

  • esmie Calculating status...
    Currently Being Moderated
    Sep 28, 2011 9:58 PM (in response to donna9802)

    Thanks, just encountered this issue this morning! Sure saved me a lot of time figuring out. It could have been due to my updating to Safari 5 as others have commented.

     

    Once again, THANK YOU.

    It was annoying & frustrating to see the error message repeatedly rather than the attachments!!

  • willieb3 Calculating status...
    Currently Being Moderated
    Nov 7, 2011 5:49 PM (in response to neom1985)

    One of the best things about owning an iMac is the smart people who post to this website. Thanks for the tip on the missing plug-in.

  • paganscientist Calculating status...
    Currently Being Moderated
    Nov 11, 2011 8:40 PM (in response to neom1985)

    OK brand new Lion installed on MacBook Pro.  Go to apple site to watch the Icloud video and the video just says 'missing plug in' and the wheel goes round and round.   Wierd.  This is the apple site on a macBook Pro with Lion.

    And their own videos wont play.

    ???

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.