Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Jul 30, 2012 10:15 PM by Aljamali Go to original post
  • musiclover1919 Level 1 Level 1 (0 points)

    i tried all of these options and none of them helped. my  main internet browser was safari. I tried downloading chrome and all my pdf's opened. THANK GOODNESS.

     

    if the other options don't work for you, try downloading google chrome.

  • flason Level 1 Level 1 (5 points)

    Just worked for me.  Give it a try

     

    I got the answer!!!
    After many, many, many hours...finally a simple solution.

     

    Go to your applications folder and open the utilities folder.
    Open Java Preferences and click on the 2 Restore Defaults buttons.

     

    If for some reason, your java preferences mysteriously disappears from your dock, reinstall Java for Mac OS X 10.6 Update 2 athttp://support.apple.com/downloads/

     

    Then go back and open Java Preferences and restore defaults.

     

    Ta-Da!! Hope this helps you guys~

     

  • flason Level 1 Level 1 (5 points)

    Problem re-occurred after installing Microsoft Office 2011 Mac update 14.1.4

    Fix worked just as before (Go>Utilities>Java Preferences then restore defaults on both items there)

  • jwsk8s Level 1 Level 1 (0 points)

    I am unable to open pdfs in Blackboard (get the missing plug-in message) on my Macbook (OSX version 10.7), although I have downloaded Adobe and can open them elsewhere.  I am a graduate student and this is a HUGE problem and enough to make me give up on Apple for good.  I have tried the above suggestions to no avail. 

     

    Any solutions would be most welcome, because I am on the verge of going back to a PC over this issue - just ridiculous on the part of Apple.

  • Pirate71 Level 1 Level 1 (0 points)

    This problem is not unique to Macs! Hope this helps:

     

    Some students and Mac users in particular will report from time to time that they are unable to open a PDF file that has been posted to Blackboard. There are a couple of simple fixes:

    1. Rename the PDF and file and repost.
      In some cases, PDF files can become corrupted either during the Adobe file writing process or when it is posted. Students then receive an error when they try to open the file. Renaming the file to a new name and re-posting to Blackboard usually fixes this issue.
    2. I did this, but the file will not open for Mac users. What else can I try?
      If students are using their own personal Mac computer they can change the default program that opens a PDF file from Preview to Acrobat. This may allow them to open the file when downloading it from Blackboard. Please contact the help desk for assistance in changing your preferences.

    Also from another Website:

    Known Issue: Students using Safari and Firefox on a Mac

    Users are not able to view .pdf files in Content Areas added using the Build Content > File option. They receive a plugin missing message. Workaround: Instructors should use the Build Content > Item button to add .pdf files to Blackboard content areas. Files added in this way will open in an external program such as Preview or Adobe Acrobat Reader.

     

    This is actually an issue unrelated to the one in this discussion.

  • Porac Level 1 Level 1 (10 points)

    Flason

     

    Thank you for the fix!!  I just encountered this issue, after attaching a picture and then in the copy I sent myself, finding the missing plug-in situation.  Restore defaults worked like a charm......

     

    I think my issue was caused by the Microsoft Office update I just installed yesterday.

     

    Again, THANK YOU!!!

  • honey5 Level 1 Level 1 (0 points)

    I solved this problem by switching browsers. I downloaded Google Chrome and the problem went away!

  • k.bobrowski Level 1 Level 1 (0 points)

    I tried many of the above solutions - no succes so far.

    Restoring Java did not help.

     

    When I open message from iPhoto in browser via iCloud it works perfectly - I can see all type of messages.

    In Mail app however I only see messages sent in classic style - all others only "missing plugin", although I can see it via quicklook.

    It is really frustrating now. I found number of such treads on Apple Support Communities and many solutions - none of them actually helps. Maybe it's time Apple would look at this problem?

  • Jeffrey Vento Level 1 Level 1 (0 points)

    thanks Donna - this worked for me immediately - jeff

  • dpickens Level 1 Level 1 (0 points)

    This started happening to me recently. I just did the latest update on 10.7 and suddenly "missing plug-in" for PDFs, JPGs, and PNGs in Apple Mail.

     

    Tried all the solutions here and none of them worked. I am going to open a support ticket with Apple to see if I can get some sort of resolution.

  • arepo1 Level 1 Level 1 (0 points)

    Clicking the 2 restore default butons worked for me.  I restarted mail and Java afterwards.   No problems so far.   Thank you!

  • horanel Level 1 Level 1 (0 points)

    After reading about the Flashback viruses this week, I disabled Java, as recommended Afterwards I got Missing Plug-in message. On earlier posts here, someone suggested safari -advanced- check box - develop menus, (check it)

     

    I also restored/ re-enable Java by restoring defaults.

    Mail picture attachments returned as visible. I am assuming this is Java related. So restoring Java defaults seems to be the answer for missing plug in message.

  • Aljamali Level 1 Level 1 (0 points)

    Thank you so much that was helpfull.

Previous 1 2 3 4 5 6 Next