14 Replies Latest reply: Sep 26, 2010 11:02 PM by baltwo
Belmakor Level 1 Level 1 (10 points)
I'm trying to do a clean install of Snow Leopard on a 24" iMac 7,1. It originally shipped with Tiger, and I upgraded to Leopard when that came out and then Snow Leopard. So, it's currently running 10.6.3.

If I put the Snow Leopard install DVD in the drive, it mounts fine. If I then restart and boot off the DVD (either via holding down C or selecting the DVD as the startup disk in preferences) it sounds like it starts to read the DVD, then it ejects it.

I tried exactly the same with a 2nd retail install DVD, and had the same thing.

The iMac does not eject either the original install DVD (Tiger) or the Leopard install DVD.

Also, neither of the Snow Leopard install DVDs will boot up on my 27" iMac, either - they just hang right at the beginning of the bootup.

Is it possible that both DVDs have problems? (I find that highly unlikely - the one I did the OS upgrade with originally, the other I just pulled out of its shrinkwrap for this exercise). Or are the SL install DVDs not supposed to be bootable?

iMac11,1 i7 8GB, Mac OS X (10.6.3)
  • varjak paw Level 10 Level 10 (169,820 points)
    Just to confirm before things proceed, these are retail copies of Snow Leopard (white-label disks), not the system disks from another system (grey label), correct? I presume from the way you describe things that they are retail disks, but just to make sure.

    Regards.
  • Belmakor Level 1 Level 1 (10 points)
    Yep, retail disks. White dvds.

    Wondering if the reason they didn't work on my 27" iMac is because they are 10.6.0 and the iMac probably came with a later version.

    But that doesn't explain why the 24" iMac would eject them. Especially since one of them I used to do the upgrade to SL originally and it worked fine.
  • varjak paw Level 10 Level 10 (169,820 points)
    Definitely the case with the 27" iMac. It requires Mac OS X 10.6.2 build 10C2234 or later and will not boot from 10.6.0.

    I'm not sure why that same disk won't boot your 24" iMac, though. It could be a dirty or marginal disk, or a problem with the drive in the iMac. If two disks fail, I'd suspect first a drive problem. Do you have the original disks that came with the iMac? If so, can you try those and see if those work?
  • Belmakor Level 1 Level 1 (10 points)
    Hi Dave,

    In the original post I stated that the original install DVD and Leopard install DVDs both work in the 24" iMac. In fact, since then I successfully installed Leopard this way on it. The Snow Leopard install DVD will mount if the computer is fully booted up, but still eject if you try to boot from it.

    I tried the Snow Leopard DVDs on a couple of year old MacBook Pro and they booted fine there. So, to summarise:

    24" iMac: will boot with Tiger or Leopard install DVDs. Ejects Snow Leopard DVD if you try to boot with those. Will mount the Snow Leopard DVD if you insert after booted into the OS.
    MacBookPro: boots fine off the Snow Leopard install DVD.

    So, my workaround is to install Leopard first, then install Snow Leopard on top.
  • Isaac Bardin Level 2 Level 2 (175 points)
    The DVDs have problems. Contact Apple for replacements. Hope this helps!
  • Richard Birkenhead Level 1 Level 1 (25 points)
    Very similar problem: My Core i7 17" MacBook Pro will not boot from a retail Snow Leopard DVD (I've tried with two of them). Holding down C key gets me to the logo splash screen and no further. Holding down option key shows the Snow Leopard DVD as a bootable volume, but if I select it, I get to the logo splash screen and no further. I hope this isn't going to be yet another problem that Apple does not acknowledge the existence of, despite the large number of users having the same issues.
  • Allan Eckert Level 8 Level 8 (47,455 points)
    The odds are your Mac is so new it is not capable of booting from the retail Snow Leopard DVD. Why don't you use the DVD that came with it. That has the correct version of Snow Leopard for that Mac.


    Allan
    tiger
  • Richard Birkenhead Level 1 Level 1 (25 points)
    I am temporarily separated geographically fron the DVDs that came with it, unfortunately, and need to repair my HD today. Both my MacBook Pro and the retail Snow Leopard disk I bought today are version 10.6.3. I have never known a Mac to be too new to boot from a disk with the same operating system (and I've owned many a Mac over the last twenty-plus years).
  • Richard Birkenhead Level 1 Level 1 (25 points)
    PS - Upon my returning the first disk I bought, an employee at the Apple Store tried to boot one of their demo MBPs with it and it hung up just like mine. He then said that was probably because "the demo computers are locked" (whatever that means). There's obviously something about the Core i5 and i7 Macs and retail copies of OS 10.6.3 (and perhaps earlier builds of 10.6).
    Anyway, thanks for trying to help.
  • Allan Eckert Level 8 Level 8 (47,455 points)
    It sounds like you caught yourself a real dud at the Apple Store there.

    The I5 and I7 hardware were just released hence it needs the newest OS to get the drivers needed for the hardware.

    Your DVD are your only salvation unless you are able to find someone with the exact same hardware and use there DVD.

    I had a similar problem with my MBP when it was new. I spoke to the someone at the Apple Store where I was travel and he used the store's portable hard drive and had me fixed up in minutes.

    After that when I travel I make sure to throw the DVD in the bag before leaving now.


    Allan
    tiger

    Message was edited by: Allan Eckert
  • drichards21 Level 1 Level 1 (0 points)
    I am working on a "27 iMac i5 and found it was having the same issue with the factory Install DVD that came with it. Since we have a couple I tried on the other and it worked. So I started digging around and found that the one having issues has a Mac OS Extended Partition and not (Journaled). I have no idea why that is the case but without being able to boot to the disc I don't want to blow away what is on it if it won't boot the DVD.

    I guess for now I will back up the whole drive and go from there. I just thought I would throw that out there.
  • Fotobyme.com Level 1 Level 1 (0 points)
    Sorry for digging up this old post, but a google search regarding the same exact problem ked me to this thread. Have you found a solution? I called apple to send me a replacement restore DVD. None of my 10.6.3 DVDs work. Just hangs there at the grey apple logo screen. I have tried loading them up through a USB drive with zero luck. Its pretty frustrating. If the restore DVD doesnt work then i'll have to make a trip to the apple store.
  • Alan Smith1 Level 1 Level 1 (15 points)
    Having just bought a new 10.6.3 retail disk last Friday - I can confirm that I am getting the same issue on both my MBP (new early April) and on some new 21.5" iMacs that are a couple of weeks old.

    I took it to our local Apple service center and confirmed that it wouldn't boot a MBP that was running 10.6.3 either - that machine had a build date of Week 16 2020.

    I am wanting to build images off these machines so am not wanting to use the model-specific restore disks.

    This is extremely frustrating.
  • baltwo Level 9 Level 9 (62,010 points)
    Build your image on the latest machine you have, using it's restore software. That image should be able to boot any earlier machine. That was Bombich's advice when he was developing NetRestore.