10 Replies Latest reply: Jun 28, 2010 9:50 AM by milominderbinder
milominderbinder Level 1 Level 1 (0 points)
I seem to be having the same problem as many users, where my G5 shuts down by itself at random times. My problem started with the G5 shutting down at night. Prior to that, I had come home on several occasions and the G5's fan was in 747 mode. I had to force shut down the G5, which was unresponsive. Then it would go for days without a problem. Eventually the shut downs came more frequently and now it shuts down during startup every time. Consequently, I can't even start up the G5 to check logs or run DiskWarrior, etc. Since every post on this issue seems to have gone unanswered, I am beginning to think my only option is to buy a new iMac. That said, I'd rather not spend the money in this troubled economy and would like to find a fix. Here's what I was able to do so far:

- Reinstalled OS 10.5.8 combo updater
- Reset PRAM
- Replaced PRAM battery, reset PRAM
- Reset NVRAM
- Repaired permissions
- Unplug G5 and plug in after 30 sec
- Attempted boot from TTP5 DVD (still shut down)

If I back up or clone my system HD, would I be able to retrieve log information from it (attached to another Mac, I assume)?

Is anyone aware of this problem being solved for any other user?

Has anybody recently taken up this issue with Apple? How did they handle it?

Thanks for any help.

Power Mac G5, Mac OS X (10.5.8), 3.5GB RAM, 2nd HD, firewire card, USB card
  • 1. Re: G5 Dual shuts down unexpectedly
    BDAqua Level 10 Level 10 (116,475 points)
    Hello milominderbinder, and a warm welcome to the forums!

    Has anybody recently taken up this issue with Apple? How did they handle it? Several have fixed, several haven't, many just thought the fix was too expensive, but too many things it could be.



    If I back up or clone my system HD, would I be able to retrieve log information from it (attached to another Mac, I assume)?

    Yes, many ways you might to get to the info on the HD. See if it boots into FW Target Mode…

    http://docs.info.apple.com/article.html?artnum=58583

    If not you'll need to pull the HD out.
  • 2. Re: G5 Dual shuts down unexpectedly
    old comm guy Level 4 Level 4 (2,230 points)
    Does the machine "Safe Boot"? (Hold down shift key when booting.) If it does, then you may be into my "Puzzling Boot Problem" world.

    Also, how long does it go in the boot process before you shut back down? You might get a little hint by booting up in verbose mode, i.e., hold down command and V keys on the keyboard as you boot. You will at least see how much of the boot process is completing before the thing dies on you.

    I have gotten my machine to relatively behave by powering down for a period of time (now down to an hour and a half) before powering up again. That time could be even less, though I didn't have much luck with 20 minutes the one time I tried that. Thirty seconds is not enough time to allow capacitors to fully discharge and things to "cool down" to a cold iron start.

    As my main thread notes, this is a puzzle, to say the least.

    You could be in a real Catch-22 situation here.

    Message was edited by: old comm guy
  • 3. Re: G5 Dual shuts down unexpectedly
    Mister Rollover Level 1 Level 1 (5 points)
    Could be a power supply option. I had this same puzzling random off thing coupla years back.
    Tried EVERYTHING, then someone suggested taking the whole machine apart, getting to the power unit right at the bottom and cleaning this out. Basically years worth of dust had accumulated at the bottom, which periodically was stopping the fans turning enough, so the power unit kept overheating and shutting the machine down.....

    Yes, it's a strange suggestion and takes a while (do a search for taking mac apart), but it did work for us.
  • 4. Re: G5 Dual shuts down unexpectedly
    milominderbinder Level 1 Level 1 (0 points)
    Thank you both for your advice. Here's what I've done in response to your suggestions:

    Left PMG5 off for 2 days.

    Did a normal boot. Boot was almost complete (desktop picture appeared but desktop files and folders did not) when PMG5 shut down (after about 1 min. 45 s).

    Did a safe boot - very slow, took about 6 min. to boot up. During boot up, the fan got really loud for a few seconds, then quieted down again. Didn't shut down until forced shutdown (see below).

    Something new: after booting in safe boot mode, many of my apps stopped working. Specifically, each of them hung and had to be forced quit. Apps include Safari, TechTool Pro 5, AppZapper, Console, Digi Core Audio Manager, Activity Monitor, Native Instruments Absynth. At one point I couldn't even get Force Quit to work. At that point I had to force shut down because the entire machine had become non-responsive.

    This morning I tried a normal boot again and the machine shut down at the blue screen before the desktop appears.

    I plan to get inside the machine and clean out some of the dust in the hope that it's just a fan/heat problem.

    Any other suggestions based on the above?
  • 5. Re: G5 Dual shuts down unexpectedly
    milominderbinder Level 1 Level 1 (0 points)
    I cleaned out the dust (it was surprisingly clean in there). Reset the PRAM again and rebooted. This time the machine started up ok and ran no problem until I tried to open iTunes. Force quit would not load up. I had to force shut down. I was then able to do a normal startup and it ran fine again until I tried to open Entourage. It hung again and I had to force shut down. So it appears that the mysterious shut down problem has gone away, but I now can't run certain programs without crashing the whole machine. Is this a logic board problem after all?
  • 6. Re: G5 Dual shuts down unexpectedly
    masterwookie Level 1 Level 1 (0 points)
    I had this same problem. Even though it has all the appearances of a hardware problem with your motherboard/RAM, it's more likely to be a harddrive problem. This was the only fix that worked for me:


    1.) Using Disk Utility, fix ALL your internal harddrives using the "Repair Disk" button until you get a green message on all drives that says "*No repairs were necessary.*" If Disk Utility is unable to repair all drives, then you have to get Disk Warrior. Fix all your internal harddrives with Disk Warrior. Once you purchase DW from the Alsoft.com website, you can immediately download a copy of DW that will do the job instantly rather than wait for the DVD to arrive in your mailbox.

    Disk Warrior will likely be able to fix all your harddrive problems even if Disk Utility cannot, but this still may NOT resolve your unexpected shutdown problem. Proceed to STEP 2 if the shutdowns continue.

    2.) Boot in SAFE MODE (hold down SHIFT KEY during boot-up). This will actually re-build a broken HD that DiskWarrior and Disk Utility already says was fixed! Once the computer boots in SAFE MODE, you can shut down manually and do a regular start-up and the unexpected shutdown problem should be fixed.
  • 7. Re: G5 Dual shuts down unexpectedly
    BDAqua Level 10 Level 10 (116,475 points)
    Hi masterwookie, and a warm welcome to the forums!

    Great additional info, thanks for posting!
  • 8. Re: G5 Dual shuts down unexpectedly
    milominderbinder Level 1 Level 1 (0 points)
    You wouldn't believe what's happening now. I tried all the suggestions given me:

    -reset PRAM

    -reset NVRAM

    -replaced PRAM battery

    -unplug 30 sec. and then reboot

    -cleaned out dust on fans

    -repaired permissions

    -ran TechTool Pro 5 (all the tests and repairs - directories, defrag files, etc.) successfully. It performed all the repairs and defragmented the disk.

    -Successfully ran DiskWarrior 4.2. By the way, DW4 found a lot of fragments and directory issues on a hard drive that TTP5 said were completely defragmented and repaired.

    Anyway, after doing all that I was able to boot the G5 and use Firefox (Safari 4 and 5 don't run on the G5 - they hang on startup - but that's a problem for another day), Word, Entourage, Disk Utility and Keychain Access. The G5 stayed on for several days until today. Once I felt confident that the problem was solved, I shut down, reattached all of my peripherals, and booted up successfully. However, when I went to open an app, the first time I clicked on it the G5 shut down again. Now when I reboot the first thing I see is an OS9 style folder with a question mark on it. A second later the little OS9 folder has the old blue Mac face. From there it seems to boot up normally except that during the boot process the screen goes completely white and stays that way for 5-10 min. before completing startup.

    I'm almost at my wits' end on this one. I really like my G5 and would rather keep it than get that new iMac I've been drooling over but can't afford. This thing is getting out of control. I need to check each peripheral to figure out which is the offending one, but assuming that isn't the problem, it's starting to feel like I need a new logic board or something. At this point, does anybody think this is fixable?
  • 9. Re: G5 Dual shuts down unexpectedly
    BDAqua Level 10 Level 10 (116,475 points)
    You're just going to have to try one peripheral at a time to find out I guess.
  • 10. Re: G5 Dual shuts down unexpectedly
    milominderbinder Level 1 Level 1 (0 points)
    Thank you masterwookie. I think your advice worked. I ended up running DiskWarrior (for whatever reason, booting with the DW disk there were no shutdowns). DW seems to have fixed it, as I can run with my peripherals plugged in and there have been no shutdowns in several days. Hopefully it'll stay that way. Thanks again.