Previous 1 2 3 Next 101 Replies Latest reply: Nov 18, 2010 7:57 AM by Dave Dunaway
XyritZz Level 1 Level 1 (0 points)
Hello,

I updated my iPhone 3G recently to the golden master version of iOS4, and I noticed a reproducable problem: When going to Settings > General the Settings app crashes and I am returned to the springboard.

I think this problem might be caused by having an iPhone OS3 compatible .mobileconfig loaded.

Is there anyone who experienced this problem and found a way to fix it or is there any way to remove the .mobileconfig when I can't reach General Settings?

iMac, Mac OS X (10.6.3)
  • Julian Wright Level 7 Level 7 (34,860 points)
    The GM of iOS 4 is only available to registered developers, so as you must be one, you should know that you need to post your question in the Developer forums:

    http://devforums.apple.com
  • Tamara Level 6 Level 6 (13,730 points)
    I assume that you are a registered developer and know about the devforums. As a registered developer you should also know how to support a bug report in the developer area.
  • IpSo Level 1 Level 1 (0 points)
    I upgraded my iPhone 3GS to iOS4 today and I'm seeing the same issue, settings crashes 90% of the time I try to go into it.

    If I restart the phone sometimes it lets me in, sometimes not, but even if I do get in, 100% of the time I cannot change my auto-lock to 5 minutes without it crashing or hanging and reverting back to 1 minute. I also can't enable a passcode lock, it asks me to enter the new passcode, but after I do that it just goes back to the settings and its disabled again.
  • Jacob Weber Level 1 Level 1 (15 points)
    Me too. Haven't been able to get to that panel at all; it crashes every time.
  • androidvim Level 1 Level 1 (0 points)
    Have you tried to reset it whilst having the phone plugged into itunes. Home button plus on off button for so many seconds untill apple comes on?
  • Evilcalvin Level 1 Level 1 (0 points)
    Same here. I have an iPhone 3G and did the OS4 upgrade today. Took over an hour. Phone no longer requires a password to unlock and the settings app crashes every time, even after a phone reboot. Ideas??
  • Dr Sam S Level 1 Level 1 (15 points)
    I just completed the change to OS4.0 and don't have a problem getting into General Settings as all. I must be lucky
  • RWU Level 1 Level 1 (0 points)
    I have just updated from 3.1.3 to iOS 4 and my iPhone is Auto-Locking after 1 minute, which is greyed out and I cannot turn off the Passcode Lock it is greyed out as well.
  • Jacob Weber Level 1 Level 1 (15 points)
    Also crashing when I go to Settings > Mail/Contacts/Calendars, and select certain accounts. Other accounts work fine. (It's a POP account and a GMail Calendars account that crash; the GMail mail account works.)
  • MacFrankyMacFr Level 1 Level 1 (0 points)
    Settings-->General crash after iOS4 update on OTB iPhone 3GS.
    Also after restore.

    Anyone found a solution yet?
  • jmb186 Level 1 Level 1 (0 points)
    I am having a similar problem. I have a IPhone 3GS and just upgraded to OS4. I have a Google Exchange sync account set up, but my Mail and Calendar apps are not updating correctly. I am not getting a log in error however, just not updating.

    Also, when I go into Settings -> Mail, Contacts, Calendar, I crash out to the home screen.

    I have tried closing all multitasking apps from the menu, resetting via home and off button, and resetting all network settings. I am about to restore now.
  • PePaHa Level 1 Level 1 (0 points)
    I have an iPhone 3G with 3.1.3. and upgraded it to iOS 4.0 but i can't come into settings. When i hit the settingsicon I come in but inside I can't get to general and/or I can not go to the seperated emailsettings under mail, contacts, agenda. When i hit general i am returning to the springboard. I have also do several resets but that wouldn't work.
  • iBoo Level 1 Level 1 (0 points)
    Same problem here, don't seem to be having any other issues though, but don't want to take my phone out if I can't even have a lock code!!!
  • Gladman Level 1 Level 1 (0 points)
    Same problem. Settings general freezes then crashes to springboard on my 3G. Same happened with settings wireless, but a reset fixed that.
Previous 1 2 3 Next