Previous 1 2 3 4 Next 57 Replies Latest reply: May 20, 2012 4:50 PM by nickfromathens
iRuney Level 2 (185 points)
The nitty gritty:

My i5 with 4GB of memory is using more memory to perform the same tasks as my Core Duo. They are the same clock speed.

In general, my laptop is constantly setting at nearly zero free memory, in spite of no major memory consuming applications running.

My wired and active memory add up to more than the real memory being used according to Activity Monitor! I just added up all the real memory usage and got about 1800MB, but Activity Monitor reports 2480MB as wired or active.

3.67GB of 4GB is currently used.

I know that OS X and other Unix systems always have a lot of inactive memory, but my old Core Duo did not do this.

Now, there's all the numbers, and here's the rest:

My laptop feels SLOW. In spite of low CPU usage, it is grinding way too much, and I think it's from having to free memory constantly, because I never have any free memory.

The i5 feels slower than my Core Duo, and that's insane because it benches nearly 20% faster.

I've ran all sorts of hardware tests, repairs and maintenance tools.. to no effect. Have also done SMC/PMU and RPAM resets.

Is anyone else experiencing this?

MacbookPro6,2, Mac OS X (10.6.3), HR Glossy Display
  • iRuney Level 2 (185 points)

    I booted up my computer less than 2 minutes ago, only opened TextEdit and Safari and I'm already using almost half my memory as wired or active >.<
  • G Higham Level 1 (0 points)
    Im having the same problem have just had the machine in for repair as they thought it was a mouse connection problem, it wasnt, and its still annoyingly sluggish, have you fixed this prob by any chance before i go and send it back again?

  • amescreative Level 1 (0 points)
    Same problem, brand new i5 2.4GH 4GB ram. Strange, the apps seem sluggish and the spinning color wheel or short freezes of a half second before it responds are common. I'm going to take it in to the apple store to check it out.
  • appereira Level 1 (0 points)
    I'm also having real problems with mine. The screen monitor many times become all scrambled for no reason. The color spinning wheel sometimes spins for minutes! It takes sometimes over 20 sec for an application to open, especially iPhoto. Does this need to be replaced? Please help!
  • Guga Oliveira Level 1 (0 points)
    Same problem here, a brand new macbook pro with 4GB and Core i5 fews slower than my iMac core 2 duo from 2 years ago with 2GB
  • holyroller Level 1 (0 points)
    Moved from a 2.53 core 2 duo bought (november '09) to a 2.4 i5 (July '10) and find it extremely slow indeed.

    Use a lot of imaging programmes, this is the first time I've ever seen a load bar when opening an image in PS4. The same images I was opening in 10.5 on a old shape MBP 2 years back.

    Very disappointed with this Mac.
  • Guga Oliveira Level 1 (0 points)
    I have bought a Core i5 Macbook Pro with 4GB and it appears to be very slow, slower than my iMac Core 2 Duo 2.4 with 2GB from 2 years ago. It is a brand new and I don't understand why it is too slow? Firefox is impossible to use the wait wheel appears a lot. Someone can help me?
  • digijoel Level 1 (0 points)
    This is BS Apple... I have the same speed problem, and I had to jump to this new MBP because the old one just DIED (MBP 3,1) just like that. I've checked Apple forums and it publicly recognized it as a manufacture error, however, they would charge me to fix it (gpu problem, had to replace mainboard, so... you get the idea about pricing).

    So I bought a new one, just this time the problem it's the speed! I thought i5 were fast as light... but I found they are much more slower than my previous C2D!!!
    Come on Apple... this is the second time in a row you disappoint me...
    I guess at the end of the day... all products out there are the same piece of crap, just yours is much more well branded...
  • gjshep Level 1 (0 points)
    Same issue.. How universal is this problem? My MPB Duo had 6G of RAM so I was willing to forgive the sluggish i5 with only 4G. But tonight I just upgraded to 8G and as soon as I booted it up and launched Safari I got the rainbow wheel. This thing is a dog. I want my Duo back.
  • Philip Robinson1 Level 1 (5 points)
    I have been having the same trouble with mine. 2.4 GHz i5 Macbook Pro, 4 GB RAM, bought in mid-May of this year.

    I've had several issues with sluggish response time and the dreaded spinning color wheel. I was reading something on another forum thread suggesting that the 5400 RPM HD could be the problem rather than the memory or the processor. Any ideas?

    I upgraded from a 2005 Powerbook G3 1.33 GHz, and the response time isn't much different -- sometimes it's slower on the i5. It's getting really annoying, but I'm not sure what to do with it. I'll probably take it to the Apple store over Christmas break if I don't figure out anything before then.
  • leroydouglas Level 6 (17,010 points)
    I don't know what to say to resolve your issue, but for a little balance I will add I have had zero problems you describe with my mid 2010 i5. Only added more ram because running Parallels5 and Windows7 it did then take all 4GB of Ram which I did not care for. Know it flies and nothing has slowed it down. I am hoping to get three years out of this MBP as opposed to my normal two years before upgrade is required.
  • marcosend Level 1 (0 points)
    I had the same problems, color wheel spinning, 20, 30 sec freeze...
    Just change the 500GB original Seagate Hard Drive for a HITACHI 7200RPM and problem solved.
  • bbx10 Level 1 (0 points)
    Wow I am having the same problem and I decided to do some research today after watching a customer using vmfusion on her core2duo macbook with no sluggishness hardly. I watched her switch between four different VMs, two using windows 7 with no problem.. and I barely can run 1 VM of windows 7 on this machine. My machine is an i5 core with 4 gigs of ram... what gives ????
  • thesetimes Level 1 (0 points)
    Hey guys, I found this thread via Google because it seems I'm struggling with the same exact problem. I upgraded to this computer coming from a C2D one, and according to Geekbench, this should outperform it by thousands of points. Yet...I find myself not noticing any particularly improved speed, and in some areas (like in Logic 9) it actually feels either the same (which it shouldn't) or even worse.

    Some say that the 10.6.5 update does resolve the '10 MBP memory issue, but at least I haven't come across any noticeable improvement.

    So...any luck finding a cure, others?

    So far - I hate to admit it, having spent that much money - but I have been pretty disappointed with this product.

    Also: note that I also initially had the 5400RPM hard drive in mine as well, and thought that would be the culprit, so I exchanged it to a faster 7200RPM one. I can say that even though it improved things slightly, the difference wasn't mind-blowing. 5400RPM hard drives are pretty ancient by today's standards, though.
Previous 1 2 3 4 Next