Previous 1 2 3 Next 32 Replies Latest reply: Aug 20, 2012 4:20 AM by Nevka Go to original post
  • Lu Digiovanni Level 1 (20 points)
    I tried the Scriptfile and it did not work the first time.
    I tried it again but instead of dragging and dropping the folder of files I wanted
    to convert, I selected all the files inside the folder and dragged them onto the scriptfile icon named "Convert to JPG and Embed sRGB" and it then DID WORK!
    Thanks for your fix
  • Gianmaria Level 1 (0 points)
    I too have dozens of photos, scanned from very ancient black and white negatives, that iPhoto doesn't recognize. They are good for photoshop, e-mailing, preview and reunion. I tried jpg 2000, I sent them to myself by e-mail, but nothing worked.
    Any idea?
  • Terence Devlin Level 10 (137,920 points)
    Yes. Give them an RGB profile and they'll import.


  • Gianmaria Level 1 (0 points)
    I did it without succes. I find a lot of posts in this blog about difficulties in importing photos with iPhoto 09 8.1.2. Should I wait next release?
    Thank you.
  • Terence Devlin Level 10 (137,920 points)
    What profile do they have?


  • Gianmaria Level 1 (0 points)
    Succes! Thank you Terence. I unchecked the box: "color" while saving my one hundred years old photos and they all went nicely into iPhoto. (I wonder why)
  • Ron chapin Level 1 (0 points)
    One key thing that F Starr mentioned in the very first post is that a new account was created. This should eliminate any issues with any existing library, since it is a new user, and a new library.

    If you try to import the stock images at ~/Library/Desktop Pictures and they do not import (they are RGB and on every Mac) then it is most likely the iPhoto application.
  • Terence Devlin Level 10 (137,920 points)
    then it is most likely the iPhoto application.

    In my experience is much more often the Library and not the app


  • Ron chapin Level 1 (0 points)
    Hmm, interesting...Even if you

    1) create a new Test User
    2) log in to new Test User
    3) Launch iPhoto which will give you a new Library with no images, no library baggage/corruption
    4) Import default known good content on every Mac (~/Library/Desktop Pictures)

    Would seem if you use a new test user and a new library and have issues, your problems would be much deeper...application, OS etc if you can't create a new user and a new library using only known good content.
  • Terence Devlin Level 10 (137,920 points)

    Apologies, you are right. I misread - or carelessly read - your post.


  • Ron chapin Level 1 (0 points)
    Hey no worries, I just try to help if I can, it's all good. Great to get different views on issues that are troubling people.
  • Lenny Pillay Level 1 (0 points)
    I had an experience similar to above. I used migration assistant to move my Old MacBook Pro over the new one. iPhoto (09) would see the events and thumbnails but would not show the larger images when trying to edit/ magnify.

    I called Apple support. Tried various iPhoto rebuilds and re-indexes. Did not work.

    Eventually : I realised that the software on the NEW (Spet 2010) MBP was actually 10.6.3.
    I simply upgraded to 10.6.4 and voila! The iPhoto 9 app worked well again!

    Two lessons learned :
    1. When using migration assistant for iPhoto : ensure that the same versions of Mac Software are on both computers.
    2. Always check your NEW computer out of the box and download the updates for the software.

    Hope this contributes.
  • Claire245 Level 1 (0 points)
    I too am having this problem - I have been importing jpgs to iphoto for years and for some reason now it has decided it doesn't support the jpg format. What is going on please?
  • sudirende Level 1 (0 points)
    I had the same problems and I got my photos into iPhoto by using Quicktime. It doesn't address the core issue, really, but it got me past the head banging on the wall frustration. I count on Quicktime as a last resort to open anything graphic that hangs up in other programs. In this case, I opened the files and then exported them as Movie to Picture (.pct) and all was fine.

    I read all the issues here with transferring tiffs to jpegs and tried importing the original tiffs - iPhoto would take them no problem so if you have tiffs, just use them. But since I had manipulated the images I was importing for a calendar, I didn't want to go back and redo all that work. I wanted to load in my modified images. Neither saving the files back as tiffs, nor copying an image and pasting it into a new Photoshop doc would work. Quicktime handled it for me.
  • Nevka Level 1 (0 points)

    I used to have no problems when importing photos from my Galaxy Nexus, but all of a sudden iPhoto decided not to recognize jpeg. A few days later I noticed the problems started after uninstalling Picasa. Reinstalled it and voilà! iPhoto recognizes jpeg again.


    Don't know what's the logic behind this, but worked for me. Hope this helps.


    Good luck!