Previous 1 2 Next 17 Replies Latest reply: Jan 4, 2015 2:51 AM by lazlototh
Katedu Level 1 (0 points)
I have been designing a couple of websites and logos, and having some very frustrating problems with colors. The colors displayed are frequently not the same as the colors I select in the color picker. This happens in two separate applications (Rapidweaver and Photoshop Elements 4), so I have no idea what is causing the problem. I thought they were two separate color pickers, but maybe they function on the same basis.

The color is correct in the little color picker box in Rapidweaver, but is translated wrong to the website preview. When I looked in the CSS that is generated, I found out that the wrong numbers are being put into the code. They are in general much more red than what I am picking (15-20 units different), which explains why a lot of my bluish and yellowish colors are looking dull. In Photoshop Elements 4, even web-safe colors aren't displayed correctly in the picker. Or to be precise, a few of them are correct but most of them are not, when I check with the DigitalColor Meter. The Mac fix-it guys tell me that my Digital Color Meter is reading correctly.

I spent $50 already having my video card tested, so the hardware is supposedly fine. The Mac fix-it guys don't know what's going on either. I ran Disc Utility and fixed whatever came up but it didn't help. Somebody suggested to me that it might be an OS X problem, which is interesting, because as far as I know, I don't have the problem when using Inkscape (or trying out Gimp) in X11. Then again, I haven't noticed the problem in Graphic Converter either, which is just in OS 10.5.6.

Has anybody seen anything like this before? What should I do?

MacBook Pro 4,1, Mac OS X (10.5.6)
  • Baby Boomer (USofA) Level 9 (57,115 points)
    A few suggestions.......

    "I ran Disc Utility and fixed whatever came up but it didn't help."

    Boot up from your install DVD and run *"Repair Disc"* from the Utility menu.
    If you have DiskWarrior or TechTool Pro *(not Deluxe)* run them _off the CD._


    System Preferences>Display>Display
    Check the Colors & Brightness settings.
    My Color setting is set to Millions which I believe is the default setting.

    Now click on the Color button.
    Check Display Profile
    Is Show profiles for this display only enabled or disabled?
    If necessary click on the Calibrate button & do the necessary.

    Now in the bottom right corner, click on the purple button w/the black ? mark in the middle. This will bring up the help window.

    Midway down, click on the Colorsync Utility link.

    The next window should be Profile First Aid.
    Read & follow the instructions/details of About Profile First Aid: & do the necessary to Verify & Repair.


    "Somebody suggested to me that it might be an OS X problem,"

    It's possible, you never know unless you inquire. If none of the above works, suggest that you cross-post over in the Mac OS X v10.5 Leopard forums.

  • Katedu Level 1 (0 points)
    Thanks, I didn't know about the ColorSync Utility and Profile First Aid. It didn't find anything wrong though.

    I should have been more specific; I did run Disc Utility from my install CD and actually fixed quite a few things (long overdue maintenance!). Problem stubbornly remains. I only have TechTool Deluxe, so I guess you're suggesting that that won't do the trick. Maybe I should buy a new DiskWarrior, as we only have an ancient one.

    As for preferences and calibrating the display, everything looks fine to me except that the Color Picker picks wrong colors. I think my computer is displaying correctly the wrong colors that it picks, since I confirmed in Rapidweaver that the actual data is wrong in the CSS. I don't understand why Photoshop Elements 4 doesn't show web-safe colors correctly though. But the problem isn't just that the colors LOOK wrong, the numbers ARE wrong, so I don't understand how trying to recalibrate would help. My color calibration is set on standard and I wouldn't have a clue how to "improve" it anyway.

    Is it considered okay to cross-post to another forum? I had a hard time picking which one to post in, since I don't know where the problem is. I mean, I think it clearly lies with the Color Picker, but that doesn't seem to be a thing that one can just download and replace. So I don't know if that means it's part of the OS, or what it is.
  • CMCSK Level 6 (10,640 points)
    Is it considered okay to cross-post to another forum?

  • Katedu Level 1 (0 points)

    I did read up on color calibration by the way, and I re-calibrated my screen. It didn't help with my main problem, but it's probably an improvement to color management in general.
  • Baby Boomer (USofA) Level 9 (57,115 points)
    "I only have TechTool Deluxe, so I guess you're suggesting that that won't do the trick."

    Deluxe is a light duty utility. Pro is heavy duty. Has a lot more options than Deluxe.

    "Maybe I should buy a new DiskWarrior, as we only have an ancient one."

    You must use the versions that are compatible w/your OS system & _keep the utilities updated_ to avoid damaging/harming/trashing your system.

  • BlahBlahBlahBlahBlahBlah Level 1 (0 points)
    I have been running into the same issue.

    When I use the built in color picker, the preview swatch has the correct color/code
    but actually painting appears with a slightly different code

    In graphic convertor, if I pick a color with the eyedropper then open the OSX color picker preview swatch, the color preview is wrong but actually painting appears with the right color.

    The Acorn graphics editor doesnt use the built-in color pickers and so it works without any problems.

    Its a confusing issue, because often the colours look very similar e.g. they go from CCCCCC to either C1C1C1 or D5D5D5
  • BlahBlahBlahBlahBlahBlah Level 1 (0 points)
    I also tried paintbrush

    That also uses the OSX color pickers but doesnt have the same issue, it's a cocoa app if that makes any difference?
  • Wardrop19 Level 1 (0 points)
    Sounds as though I'm not crazy and someone else is having this problem. I filed a bug report with Apple as well as posting on various forums and user groups. Check these and tell me if your problem is the same...
  • PeterBreis0807 Level 7 (34,040 points)

    Have you been sampling the colors from your screen using the little magnifing glass?

    In that case the swatches will have a little grey triangle in the top right corner.

    The grey corner indicates that the color was picked from the screen and is a warning that this in the *Device RGB Color Space*, ie +not in any particular color space+, and probably does not match the color space in the rest of your document.

    It is likely to appear quite different from one document to another and when transferred to another machine.

    You can give it a *Color Space* by clicking on the rainbow box next to the slider color mode menu in the *Slider Tab.*

  • ScottStack Level 1 (0 points)
    I've confirmed the color picker bug in 10.6.6. I filed a bug report.

    Copy of my report:
    Summary: The color picker dialog reports incorrect values on the RGB slider, using DigitalColor Meter as a reference. On the RGB sliders, the picker can fix itself if you use the spyglass on the test color patch.

    However, the "web safe colors" Color Palette also has problems. The color names do not match the values reported by DigitalColor Meter.

    This is reproducible on both my and my wife's mbp 5,5 13"

    Steps to Reproduce:

    a) for the RGB sliders:

    1) Quit TextEdit if open
    2) Open TextEdit
    3) menu, choose: Format->Fonts->Show Colors
    4) Using RGB sliders, pick Red=50, Blue=0, Green=0 (DO NOT TYPE, USE THE SLIDERS)
    5) open DigitalColor Meter
    6) chose RGB as Actual Value, 8-bit on Digital Color Meter.
    7) Hover over test patch on color picker dialog of textedit.

    b) for the "web safe colors" palette

    1) Quit TextEdit if open
    2) Open TextEdit
    3) menu, choose: Format->Fonts->Show Colors
    4) Using the Color Palettes, choose "web safe colors".
    5) open DigitalColor Meter
    6) chose RGB as Hex Value, 8-bit on DigitalColor Meter
    7) Hover over the selection patches on the color picker dialog of textedit.

    Expected Results:

    for a) the rgb sliders, DigitalColor Meter will report 71,7,8 (instead of 50,0,0)
    for b) looking at color "CCCCCC" DigitalColor Meter reports D4,D4,D4
    Actual Results:

    I am using osx 10.6.6 as is my wife, problem appears on both computers. I first noticed this with the color picker invoked by OmniOutliner Pro 3.9.5, but reproduced with the color picker invoked by TextEdit.

    I have color calibrated my screen with a huey pro, however switch back to the factory profile did not affect the "Expected Results:" shown above.
  • BlahBlahBlahBlahBlahBlah Level 1 (0 points)
    I get that same behaviour in 10.5.8

    Also I tried the new version 7.0 of Graphic Converter, it has the same issues as 6.4 Even if I type in the color #CCCCCC they both paint #C1C1C1
  • BlahBlahBlahBlahBlahBlah Level 1 (0 points)
    After much futzing around I traced this behaviour to the RCWeb color picker which is installed automatically by GraphicConverter (though you can turn it off in prefs) and probably a few other graphic programs too.

    Deleting that color picker and using either the Default Apple picker or the wafflesoft version below solved the problem for me.

    ^ The hex picker has an options button for "Don't generate Calibrated colors" you need to make sure this is NOT selected to avoid the behaviour where all the colors go slightly wrong.
  • Gil Dawson Level 1 (80 points)

    Didn't work for me.  I trashed the two files I found using that RCWeb name.  The numbers expressed by DigitalColor Meter and Apple's color picker are closer, but they still don't match exactly.


    I guess I'll put 'em back.



  • MrWatson Level 1 (0 points)

    Mac OSX 10.7.5 Same sh*t.

Previous 1 2 Next