6 Replies Latest reply: Jul 13, 2011 9:25 PM by William Donelson
NateKH Level 1 Level 1 (5 points)
Is there a way to disable the "Top Hit" function in Safari 5? Mine is constantly way off the mark for the pages i'm looking for.

MacBook, Mac OS X (10.6.3)
  • Carolyn Samit Level 10 Level 10 (100,375 points)
  • weileongtan Level 1 Level 1 (0 points)
    Hi,

    I'm sorry to report that that doesn't work for me. I also tweaked the command to reference Safari5 instead of 4 (so defaults read com.apple.safari has both DebugSafari4IncludeFancyURLCompletionList = 0;
    DebugSafari5IncludeFancyURLCompletionList = 0;
    ). No luck.

    Does anybody have a solution? This is driving me insane, and I'm actually starting to use Google Chrome more because of this issue.
  • NateKH Level 1 Level 1 (5 points)
    Still having trouble with this, I hate the function and want the old way back where it takes part of the actual URL and not pieces of the page title. ie: www.modmyi.com title bar says "Apple, iPhone & iPad News" and if I'm looking for www.apple.com by typing "ap(ple)" I get the modmyi.com title bar popping up in top hit.
  • MBSMBS Level 1 Level 1 (0 points)
    I too would really like to turn this feature off. The top hits are not sites that I want to visit, and they will still supersede bookmarked sites, sites in my history, etc. A place where Safari clearly fails as compared to Firefox of Chrome.
  • Klaus1 Level 8 Level 8 (46,960 points)
    According to the CNET forums, you can disable the Top Sites feature like this:

    To completely disable Top Sites, go to Safari > Preferences > General

    New windows open with: Top Sites
    Change it to something else. Obviously, you can do the same for New Tabs.

    (You'll also see Top Sites in the Show All Bookmarks window. Drag that up, don't stop when it first stops moving. It will be reduced to a thin bar.)

    Now delete the Image Cache. Choose Safari > Reset Safari... and select Remove All Webpage Preview Images. Click Reset. Now go to YourUserName/Library/Caches/com.apple.Safari and select the Webpage Previews folder. Press Cmd-I and click Locked. Now it won't accumulate a jpeg and png of every web page you visit.
  • William Donelson Level 4 Level 4 (2,495 points)

    Thanks, Klaus1.

     

    I really hated the privacy-invasion, CPU-loading and bandwidth-theft of Top Sites. Wake up Apple, make this easier to stop.