4 Replies Latest reply: Nov 25, 2010 2:51 PM by deemyboy
phxbusdriver Level 1 Level 1 (0 points)
I'm trying to install iTunes Ver9 on my laptop and I keep getting these errors during installation:

Error getting file security:
C:\ProgramData\Apple Computer\Installer Cache\AppleSoftwareUpdate\GetLastError 5

Error getting file security:
C:\ProgramData\Apple Computer\Installer Cache\QuickTime\GetLastError: 5

I ran MSCleanUpInstaller to remove any pieces left from each install, but I still get the above errors. I also continually get this error when I go to the Apple website:

The procedure entry point QTCF_CFUniCharGetUnicodePropertyDataForPlane could not be found in the dynamic link library QTCF.dll.

I dont know what has caused this. I thot it might be a registry error, so I did a restore, but that didnt fix it. It seems they started happening at the same time. No virus or malware/spyware found after several sweeps, so I'm stumped..

Any ideas?

IBM T60 Windows 7 MS Security Essentials, Malwarebytes.

IBM T60, Windows 7
  • mikeo01 Level 1 Level 1 (0 points)
    Any luck? I have the same exact error.

    I deleted Temp files and tried to uninstall quicktime but that errors out.

    So now my ipod is useless until I fix this or reformat
  • JeffVic Level 1 Level 1 (0 points)
    "Error getting file security:
    C:\ProgramData\Apple Computer\Installer Cache\AppleSoftwareUpdate\GetLastError 5"

    I checked the apple forum and didn't find anything, and then I came across a Microsoft forum and found the answer.
    You need to grant full admin control to this folder

    C:\ProgramData\Apple Computer\Installer Cache\QuickTime

    After installing the new quicktime, my player worked!
  • MrAtlasX Level 1 Level 1 (0 points)
    Delete the folder
    "C:\ProgramData\Apple Computer\Installer Cache\AppleSoftwareUpdate"
    Let the installer run, it just installed a new folder and went on its merry way
  • deemyboy Level 1 Level 1 (0 points)
    sorry folks - i can't be bothered with caps today!

    this is NOT a permissions issue!

    i am not smart or a geek or anything but just notice little things which can give clues to help fix things!

    anyway, i was trying to upgrade to itunes 10.1 and my pc / the itunes installer kept giving me the error :

    error getting file security:
    c:\programdata\apple\installer cache\apple software update (and then a series of numbers - mine were)\getlasterror: 5

    anyway if that's the the same as yours or similar then this is what i did!

    1. downloaded a fresh copy of itunes 10.1 as i thought i might have got a dud - same error!

    2. uninstalled itunes
    now i don't think that was necessary as it didn't solve the problem - same error!

    3. read a few forums and discovered that nobody (that i read about) had fixed the problem through permissions related issues
    (caps from now on because i’m using Word to be safe – how many times have YOU written something online and lost it!)
    4. saw some other posts talking about other installed Apple software that couldn’t be updated OR uninstalled!!! (Apple Software Update and QuickTime to name just a couple) so i had a look in the uninstall program utility via control panel and Apple Software Update was there.
    AND MAJOR CLUE it had the same version number ( as the error!!!
    So i tried to uninstall it alone and – whack! The same error!!!
    That made me think this baby is causing the grief – it has to go!
    But how?
    5. saw a few posts talking about a "clean-up" utility by Microsoft with links but the MS site said that the utility was no longer supported and there were no download links/buttons there.
    Link - http://support.microsoft.com/kb/290301
    It’s called MSICUU2.exe BTW.
    Now, I know that just because software isn’t officially supported, it DOESN’T mean you can’t get hold of it!
    6. so i just googled exactly that --> “MSICUU2.exe” and followed a link to MAJORGEEKS (i’ve heard of them so i thought they were a good bet – plus it usually takes a “major geek” to figure this stuff out!)
    Link - http://forums.majorgeeks.com/showthread.php?t=217811
    And whilst reading the post i saw the download link i was hoping for! (post #6 – by dr. moriarty)

    It just cleans up old installation files but the posts i read, coupled with the version number match, led me to try and get of this ANY which way!
    7. so i followed one of the links near the top of the post (below the flashing arrows saying DOWNLOAD LOCATIONS)
    8. when it finished downloading i ran it and was pleased to see the publisher was “Microsoft” and let it continue to install.
    9. once done i found it in my program menu under “Windows install clean up” (not a folder – in the list of icons) and ran it.
    10. one post i read said delete everything related to Apple but as i always try to do small steps first i just thought i’d get rid of the, seemingly, rogue Apple Software Update so that was the ONLY program i selected and then i clicked “REMOVE”!
    11. once i done i re-installed itunes, hoping that it would get the past the error point where it kept stopping (and rolling back all changes)....
    ....AND IT DID!!!!

    HOORAY!!! ETC.
    The NEW apple software update utility, installed during this itunes installation is now version number and i have a new itunes installation.
    12. IF it works for you then might i suggest you connect your iphone and if it doesn’t automatically make a back-up, right-click your iphone on lhs menu in itunes and select "back-up"

    It worked for me, hope it works for you.
    Sorry if this is too long for some of but most of this post is me waffling on too much like now,

    C ya!

    Message was edited by: deemyboy