Previous 1 2 3 4 Next 46 Replies Latest reply: Jul 15, 2010 8:44 AM by no1tmorrow
stooky Level 1 Level 1 (0 points)
hello

after installation of the latest 10.6.4 server and client update I suffer from a big problem!

what I have done:
- installation of OS X 10.6.4 on client and server via SWupdate
- reboot and permission repairing on client and server
all looked well updates seemed to have passed without any problems.

I started iCal on the client and noticed my caldav account was missing. in ical settings accounts no account listed.
when I tried to newly add the account I recieved an error, that the certificate for SSL did not match the server name. a look at the cert showed the wrong one, 'dw.lan'. so I verified in server-admin that the correct one is chosen, and indeed in server-admin ical settings I chosse
SSL - 8443 - 'server.dw.lan'.

reassigning the cert in ical server-admin, restarting the service, rebooting the mac mini server, nothing did the job. ical server seems to deliver the wrong cert, or ical client pulls the wrong one ... ???

as I am new to OS X server and did very well the last 10 days to setup my whole network, incl. DHCP - DNS - AFP - Adressbook - VPN - WEB ... everything just running fine and easy, it was so smooth ... and now this.

I haven't got a single clue where and how to continue debugging. what else did I do ... well actually nothing I can remember, than updateing client and server to 10.6.4

the worst thing is, that I run mobileme as well and it synced my calendars-accounts so on both clients the ical-account vanished. thanx god I have backups ... puhhh ... otherwise some calendars seemed to have vanished into nirvana?!

to visualize my settings I have uploaded some screenshots:
http://gallery.me.com/g.unger#100022

- 1st shows the certs, all are signed by selfsigned CA and worked propperly on 10.6.3
- 2nd shows the correct cert chosen in server-admin ical settings
- 3rd shows the ical client when adding the account the wrong cert is offered, and of cause the hostname does not match thats why it is marked insecure


any help would be highly appreciated ... thx a lot
g.

iMac 27" i5, first unibody MacBook 13", MacMini OSX Server, Mac OS X (10.6.3), acutally 10.6.4 which isn't yet available in select ;)
  • Murray Culligan Level 1 Level 1 (0 points)
    It appears to be more generalized that the SSL settings. I run a server without SSL and type in the server address (www.servername.com) then add the address to the SL Server calendar (/principals/wikis/calendarname/).

    At restart it actually picks up the calendar then the system seems to reset the calendar address back to /principals/_uids_/blahblah-blah-blah/.

    From then on I get the error message. If I reset the calendar address, it resets it at the next start.

    Weird.

    Murray
  • revlloy Level 1 Level 1 (0 points)
    ""At restart it actually picks up the calendar then the system seems to reset the calendar address back to /principals/_uids_/blahblah-blah-blah/.""


    Same thing is happening to me since the new upgrade to server 10.6.4...

    Message was edited by: revlloy

    Message was edited by: revlloy
  • stooky Level 1 Level 1 (0 points)
    some more infos

    tried the combo update on client and server w/o repairing permissons ... no changes

    I do have 3 certs as shown in the first pic on link in first post.
    server.dw.lan - the general cert for SSL and kerberos
    certificates.dw.lan and dw.lan for respective SSL domains on webserver

    and now the wiered thingy ...

    in server admin ical server settings I set the domain to dw.lan with cert dw.lan, then login on ical client works with domain dw.lan. revert server admin ical server settings to server.dw.lan with its apropriate cert and the account can then be changed manually from dw.lan to server.dw.lan and it works, even after server and client reboot and permission repairs.

    and now another way to get it running is to set up server admin ical server settings straight away to server.dw.lan with cert server.dw.lan (as ment to be). then add the account in ical on client. when the cert is considered wrong just say continue, this will ask for a password in my case (as all keychains are locked) to grant trustworth manually to the wrong cert. in this case instead of putting in the keychain password, I aborted the password input with e.g. ESC and ... surprise surprise, the correct account is created with appropriate SSL credentials for server.dw.lan and workz even after reboot and permisson repair, as first method does too.

    weirdodierdo ... really freaky behavior
    please somebody shade some light on us!
  • Murray Culligan Level 1 Level 1 (0 points)
    Did you do any changes to the iCal client at all or just the server?
  • stooky Level 1 Level 1 (0 points)
    ... actually I was still working, when I saw that 10.6.4 is out.
    so I just quit all apps on client, and installes the update via SWupdater, both on client and server.

    so NO i cannot remeber anything I had done on the client other than normal working. and the effect happens on both clients after update.

    rgds,
    g.
  • Elliot Hui Level 1 Level 1 (20 points)
    I'm seeing exactly the same behavior after upgrading to 10.6.4. on my client. The user calendar works fine. The group calendar works once, but then it resets the calendar address, as Murray noticed, after which iCal cannot find the calendar.
  • ericc56 Level 1 Level 1 (120 points)
    What is the /etc/caldavd/caldavd.plist showing for the SSL certificate keys both before and after the update; did the keys change during the update?

    Eric

    Message was edited by: ericc56
  • Elliot Hui Level 1 Level 1 (20 points)
    Eric, are you asking about the server or the client? I didn't do anything to the server, and it still serves up user and group calendars to iPhone and iPad clients just fine. (I don't have a 10.6.3 Mac client to try this with.) On my client, I can't seem to find the file that you are referring to.
  • ericc56 Level 1 Level 1 (120 points)
    The caldavd.plist file would be a server file. I'm trying to determine if anything related to the SSL certificate changed during the update. But it sounds like the problem may not be limited to SSL anyway.

    I didn't do anything to the server, and it still serves up user and group calendars to iPhone and iPad clients just fine.


    That would most likely indicate an iCal client problem.

    Eric
  • Murray Culligan Level 1 Level 1 (0 points)
    iCal was also updated in 10.6.4, no? Looks like they need another quick update.
  • Elliot Hui Level 1 Level 1 (20 points)
    After the 10.6.4 update, iCal is at version 4.0.3.
  • ericc56 Level 1 Level 1 (120 points)
    I just updated my client to 10.6.4, and my iCal is Version 4.0.3 (1388).

    It seems like there may be more than one issue going on in this thread.

    Eric
  • Daniel Lang Level 1 Level 1 (0 points)
    You can add me to the list.

    All 10.6.3 clients are working still well. Also all iOS devices.

    The Server is still on 10.6.3.

    Only the test client which I have updated to 10.6.4 makes that mentioned problem.

    So it seems to definitely a 10.6.4 Client Problem and has nothing to do with the server
  • ericc56 Level 1 Level 1 (120 points)
    Elliot - Just so I understand, are your user and group calendar accounts on a Calendar Server, and if so, what Mac OS X is the Server running?

    Update: I think Daniel Lang just gave me the info I was looking for. BTW: So far, I'm not seeing any of this behavior.

    Message was edited by: ericc56

    Message was edited by: ericc56
Previous 1 2 3 4 Next