7 Replies Latest reply: Dec 1, 2005 6:42 AM by b noir
RooZ Level 1 Level 1 (0 points)
Hi,
When I install iTunes it succesfully installs that but when it gets to QuickTime i always get some sort of error at the end (I think the error message is always different each time), I've had Error Code -3, Error Code -1073741819, and about 3 other different ones. But after it says that error it says the installation was succesful then it says 'Could not allocate thread local data.'
I've tried a few things in other treads but they didn't work so I'm clueless.

Thanks
Ben

Edit: The window name of the error is 'MW Win32 Runtime' if you where wondering.

Dell 8300, Windows XP Pro
  • b noir Level 9 Level 9 (72,020 points)
    hi Rooz!

    I've had Error Code -3, Error Code -1073741819, and about 3 other different ones.

    ... egads ...

    okay, let's try a "diagnostic" careful standalone QT 7.0.3 reinstall:

    http://discussions.apple.com/message.jspa?messageID=1211023#1211023

    what error messages do you get on that install?

    do you get a different error if you try it a second time?

    love, b
  • RooZ Level 1 Level 1 (0 points)
    Sorry, I'll have to wait until tomorrow, my internet's bugging up and keeps dropping out. Bad timing huh?
    Sorry for the wait.
  • Kubik_Juice Level 1 Level 1 (0 points)
    Me too. I bought an iPod nano and when I was trying install iTunes on my computer, it failed to install. It said, that I should download new iTunes, because it`s corrupted. It was from the original iTunes cd with my iPod and I don`t know what to do know now. iTunes is quite big to download.
  • RooZ Level 1 Level 1 (0 points)
    Hi, the first time I tried to install i got 'Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finsh as expected...'
    Then it rolled back the installation. Then I got 'Error -1603 Fatal error during installation' after it rolled back.
    The second time I tried, I got the same error as the first time.

    Thanks,
    Ben
  • b noir Level 9 Level 9 (72,020 points)
    hi RooZ!

    'Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finsh as expected...'

    a terrible thing to be happening to a fellow ANZAC ...

    okay, when i see these strange 1700-range errors showing up, i start worrying about people's Windows Installers on their PCs.

    head to Windows Update to make sure you're fully up-to-date in that regard. (we're trying in particular to ensure that you have a working copy of Windows Installer 3.1v2 on the PC.)

    to try to cover the other bases, then let's try the general advice on this document:

    http://docs.info.apple.com/article.html?artnum=93976

    ... and the InstallShield Tips and Pointers can be helpful with these strange ones, too:

    http://consumer.installshield.com/faq.asp#ts

    keep us posted.

    love, b
  • RooZ Level 1 Level 1 (0 points)
    Thanks b, it's working good now, sorry about the delay, I've been having net problems all week
    Thanks again =)
  • b noir Level 9 Level 9 (72,020 points)
    well done, Rooz!

    no worries about the delay. glad to hear you're up and running again.

    love, b