Previous 1 2 Next 28 Replies Latest reply: Apr 30, 2014 11:36 PM by JF Grissom Branched to a new discussion.
dpjax Level 1 (0 points)
I have an enterprise WPA2 PEAP MSCHAPv2 wireless network. It allows access via 802.1x authentication using Radius (MS IAS Server) with certificates. I can join the network, enter credentials (that I can see work) and get the certificate. The problem is that I don't get an IP address. I get a 169. APIPA address. I tried to use a static IP address and that doesn't work either. I have connected various laptops, iPhones even a Dell Streak to this wireless network without issue. My iPad won't get an IP at all. There are plenty of addresses in the pool.

The setup is a 3COM WX3008 wireless LAN controller and 9552 access points.

Any ideas? I went through the articles on wireless settings and none of them help at all. I guess my next step is to wipe the iPad.

Like I said... EVERYTHING else works, every other device we try is surfing just not the iPad.

iPad 32GB Wi-Fi, Other OS, OS 3.2 7B367 MB293LL
  • igmackenzie Level 4 (2,285 points)
    There have been many many threads and posts on this subject. Just do a search and you'll see.
    Some people find a solution and some don't.
    People will tell you to change your router if your iPad connects to any other wi-fi network.
  • dpjax Level 1 (0 points)
    I read through many of them. Many said to go from WEP to WPA. I'm already WPA. Some said change the router. That isn't an option.

    The iPad is the only device that hasn't worked perfectly. Its the iPad.
  • DrVenture Level 2 (180 points)
    Sounds like the 802.1X portion of the authentication is failing. When you select the network from the scan list, are you sure you are getting the cert and the cert is valid?

    Have you tried looking at the IAS system logs to see what it says about the EAP transaction?
  • igmackenzie Level 4 (2,285 points)
    dpjax wrote:
    The iPad is the only device that hasn't worked perfectly. Its the iPad.

    Maybe (and that has been said many times) but what I'm saying is that the standard response from the 'powers that be' here is that you need to change your router to be compatible with the iPad not the other way round. You've got an outdated router. It's not the fault of the iPad at all.
    Whether you like that response is another matter, of course!
  • dpjax Level 1 (0 points)
    I see what you are trying to say but in this case its just not true. There is a problem with the iPad. Moving away from the most secure wireless technology or changing my "router" isn't a reasonable solution. We are using a current production model enterprise wireless LAN controller with lightweight access points. Its running its latest code. Its not the Free After Rebate model from the local B&M.

    Again, when everything BUT the iPad works (iPod/iPhone/laptops of varying OS & vendor are all good) its not the routers fault. While downgrading my network may work it is not a reasonable solution to a problem with only the iPad.

    Of course I don't like hearing it. I am here to hopefully find someone else with the same issue or get some tips that lead to a solution so the next google searcher will land on a solution.
  • igmackenzie Level 4 (2,285 points)
    Don't get me wrong. I understand your problem and I hope you get a solution. However, there have been many people with the exact same problem and a solution has not been found.
    The answer has always been 'change your router'.
  • Lee Chalmers Level 1 (0 points)
    I have exactly the same problem. The iPad was working fine on this router for the last two weeks. Multiple other devices work fine on it. As it was working, I am certain its not a router problem, its an iPad problem. I cannot see what has changed, nothing new was added to the network in the middle of the night. The iPad is being allocated a 169 address rather than a 192 address, thus not looking outwards. I am going to try wiping the iPad and see what happens....
  • johnstump Level 1 (0 points)
    Did wiping the iPad work? I now have the same problem: device worked fine for months on the same router, then suddenly stopped acquiring IP address, router, DNS, etc.
  • dpjax Level 1 (0 points)
    I restored the iPad without backup, brung it right to the network in question and it still didn't work. It wasn't anything I installed on it thats for sure.


    Will 'connect' to network (WPA2 Enterprise AES CCMP MS Chap v2 802.1x Radius)
    Will not get an IP
    Release/renew doesn't work
    Adding a static IP doesn't work
    and most recently wiping the unit doesn't work

    It doesn't get to the VLAN associated with the SSID correctly. If it did, DHCP or a static IP would work.

    I am still stuck on this one.
  • Gerry01 Level 1 (0 points)
    Had the same problem. Solved it however by keep deleting the "169" network. Then add a known IP address, submask, etc. Seems like the OS always takes the last known wifi network from the stack ...
  • demon_mac Level 1 (0 points)
    I had the same problem with my new iPad. Bummer. "Buy a new router" is a pretty weak response IMO. Everything else works (Windows, my NAS, iPhones, Macs, etc.) except the iPad.

    I managed to get it working after manually "forgetting" the previously found SSID of my network and manually defining connection info using the Wi-fi Networks -> Choose a Network... -> Other... option

    Hope it lasts.
  • Apple Bud Level 1 (0 points)
    I am seeing something similar. I have a 3G ipad and a WiFi iPad, and one can join a network with no issue, and the other one cannot. I have reset all of the network settings and restarted, but I still see the same symptoms as above (I can connect as far as being challenged for authentication, then I get no IP address.

    What's more, until recently, both iPads worked fine on these networks.
  • jfang888 Level 1 (0 points)
    I think the iPad and iPhone cache some network settings locally, based on SSID, then screws up if things change (I had to change the default gateway)due to one of the ISPs going down.

    I had to rename the SSID on my WDS network. I kept the same pre-shared-key (password), then retyped the password onto all of iphones and ipads in the house. The systems now all work.

    It's a pain in the 'bottom', as I have about 5 other laptops, xbox, wii, wireless cameras, etc to type in a non-trivial password.

    - james
  • Steven Rix Level 1 (0 points)
    I am running into a similar problem with IPAD on DHCP server. From my understanding it is a cache problem inside IOS problem that has not been solved even on IOS 4.2.1
    And once you will find the IP adress and it's MAC ADDRESS, it's unable to be registered into DHCP.
Previous 1 2 Next