10 Replies Latest reply: Jul 28, 2010 11:19 PM by Matthew Angelatos
RyanMorano88 Level 1 Level 1 (0 points)
Every time I try and watch a flash video on Hulu or MTV or any other website and put it in full screen, it's extremely choppy and starts to lag behind the audio, but once I shrink it down to normal size that fits in the Safari window, it returns back to normal. Anyone else experience this problem, and does anyone know how to resolve it?

I'm running:
Safari 5
10.6.4
Flash 10.1 (I also tried the beta Flash Gala and still had the issues, which lead me to believe Safari 5 was the culprit)

Macbook Pro 2.53GHz Intel Core i5, Mac OS X (10.6.4)
  • Carolyn Samit Level 10 Level 10 (98,740 points)
    HI,



    Go to the Safari Menu Bar, click Safari/Preferences. Make note of all the preferences under each tab. Quit Safari. Now go to ~/Library/Preferences and move this file com.apple.safari.plist to the Desktop.

    Relaunch Safari and see if that makes a difference. If not, move the .plist file back to the Preferences folder. If Safari functions as it should on sites that stream Flash content, move that .plist file to the Trash.








    Carolyn
  • RyanMorano88 Level 1 Level 1 (0 points)
    I tried it and still continues to show very choppy playback. I just find it weird that it's only in fullscreen mode, and no other size mode.
  • TheOn3LeftBehind Level 1 Level 1 (15 points)
    I've been having a problem with Flash websites as well. I won't even use the flash video on the website and Safari freezes and it pops up with the freaking STUPID notice saying the flash plugin stopped working. Ugh. Apple needs to fix this, properly.
  • Omeyocan Level 1 Level 1 (0 points)
    Hi !

    I have the same problem with the full screen. Maybe the solution is to uninstall the current version of Flash and reinstall Safari 5.

    Just want to know if I reinstall Safari 5 ( with the old version of Flash ) without unistalling it can cause problems ???

    Thanks.
  • bootareen Level 1 Level 1 (10 points)
    I thought it was just me. I didn't attribute the lag to Safari though because I recently got a new Mac. It probably has to do with Safari since a Core i5 should not lag at all.
  • corgi75082 Level 1 Level 1 (45 points)
    I have Flash 10.1 also and in Firefox it runs like a champ...no slow scrolling or choppiness. In Safari 5 it definitely has problems.
  • Ryan3587 Level 1 Level 1 (35 points)
    Same issue here. 10.6.4 and Safari 5. Latest version of Flash, 10.1. I even tried that beta version. All the videos are slow to load, choppy, and audio doesn't keep up with video. I uninstalled Flash and installed 10.0.45.2. Everything works perfectly. The only difference is that it hogs more CPU, but at least it is smooth and runs hows its supposed to.

    Nice Adobe! You are right up there with Microsoft products! Web developers need to drop this Flash, it has more issues than Playboy Magazine!
  • kyledawg Level 1 Level 1 (0 points)
    The problem is with the automatic graphics switching technology used in the new MacBook Pros with the core i5 and i7 processors. Flash 10.1 utilizes GPU acceleration and the Intel HD graphics cannot handle it. Mac OS should automatically switch to NVIDIA graphics but it does not. Either downgrade, wait for Apple or Adobe to release an update to fix the issue, or turn off automatic graphics switching in system preferences.
  • Klaus1 Level 8 Level 8 (46,785 points)
    Update 10.6.4 included an out-of-date version of FlashPlayer. Try deleting it and installing the latest one from Adobe:

    The latest version of Adobe FlashPlayer can be obtained from here:

    http://www.adobe.com/shockwave/download/download.cgi?P1ProdVersion=ShockwaveFlash

    (You can check here: http://www.adobe.com/products/flash/about/ to see which version you should install for your Mac and OS.

    You should first uninstall any previous version of Flash Player, using the uninstaller from here (make sure you use the correct one!):

    http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14157

    and also that you follow the instructions closely, such as closing ALL applications first before installing. You must also carry out a permission repair after installing anything from Adobe.
  • Matthew Angelatos Level 1 Level 1 (0 points)
    Thanks for the suggestion - turning off "Automatic Graphics Switching" immediately rectified the unusual Safari performance lag.

    I was noting the problem on a new MBP i7 with 8GB RAM with a better Safari 5 browsing experience using an old Black 2GHz MB!