Previous 1 4 5 6 7 8 Next 108 Replies Latest reply: Nov 26, 2014 9:13 AM by sguzman99 Go to original post
  • D.R.C. Level 1 Level 1 (145 points)

    I've just completed the repair recipe posted by Garth, and further detailed by morph21,08,27,169,fix-time-machine-sparsebundle-nas-b ased-backup-errors.html/


    It successfully repaired the problem with my TM sparsebundle file.

    The fsck scan reported "invalid volume free block count", and then fixed it.

    Instead of using the tail command to monitor the progress of fsck, I ran Console and viewed /private/log/var/fsck_hfs.log


    MacBook Pro, Snow Leopard 10.6.8, TM backing up to raided drives on a Netgear ReadyNAS.

    The MBP is generally connected using WiFi (w/Airport Extreme 802.11N).


    TM is now running once again.

  • andrea.durzo Level 1 Level 1 (0 points)

    Hello guys!


    I'im writing from Italy so sorry for my bad english. I have the same problem with Time Machine and my iomega storage manager nas. In this year the problem appeared four times. I wanted to use the guide linked from D.R.C., but i'm not able to find the path of my disk.

    any advice?


    Thank you,



  • morph21 Level 1 Level 1 (10 points)



    Did you try to follow the steps in I posted a few replies before? Maybe that will help you. Please note that I the command in one of the lines is chflags, not chflag.



    Check it out, maybe it helps.

  • D.R.C. Level 1 Level 1 (145 points)


    It's a little tricky learning the complete path to the sparsebundle file on your Iomega NAS.  First you have to mount your NAS from the Finder. In my case, I use Finder/Connect to Server, and enter afp://  That's the IP address of my ReadyNAS server. Then I log in to the ReadyNAS using the credentials for its TimeMachine volume.  I have no experience with Iomega, but there will surely be an equivalent method to mount its TimeMachine volume.


    You'll get a Finder window listing the various sparsebundles that are stored on the Iomega. (there will be one TM sparsebundle for each of the Macs that are backing up to the Iomega).

    In my case, it's named MacBook-blah-blah-blah.sparsebundle


    Now open up a Terminal window and position it so that you can still see the Finder window containing the sparsebundle. Type "ls "  (without the quotes) as if you were doing to get a directory listing.

    Move the cursor over to the Finder window and drag the sparsebundle icon  into the Terminal window.  As if by magic, OSX will complete the ls command with the  pathname of the sparesbundle.


        [macbook] DRC% ls /Volumes/ReadyNAS/MacBook-blah-blah-blah.sparsebundle


    /Volumes/ReadyNas/...  is the path.

    If you want, you can hit Enter, and the Terminal window will list the contents of the sparsebundle.


    Now that you know the full path to the sparsebundle, you can proceed to follow the recipe from Garth et al.


    It's been nearly a month since I repaired my TM bundle, and everything has been working fine.





  • andrea.durzo Level 1 Level 1 (0 points)

    ehi! thank you very much for the quick reply. Tomorrow i will try with the guide and your advice.

    I will reply to you



  • andrea.durzo Level 1 Level 1 (0 points)



    i have two sparsebundle in the TimeMachine folder on my nas:


    1.  Macbook Pro di Andrea .sparsebundle (created 31 march 2012 and the last modify yesterday)

    2. Macbook-Pro-di-Andrea.. a lot of numbers ... sparsebundle (created 04 may 2012 and the last modify in the same day)


    which sparsebundle i have to repair?

  • D.R.C. Level 1 Level 1 (145 points)


    I've never seen multiple sparsebundles from a single machine stored on my NAS. I would guess that the one last modified yesterday is the one that TM is trying to use (and reported was defective).


    But before attempting the repair, you could try tricking TM to use the other one.  Turn TM off in the System Preferences. Rename the 31 march 2012 file to something else (XXMacbook Pro di Andrea) and then turn TM back on.  Click Select Disk... and choose your NAS. With luck, TM will locate the 04 May 2012 sparsebundle.  Tell TM to Back Up Now and see if you still get the error message that the TM volume is bad. If the TM backup completes successfully, go back to the Finder and check the last modify date on the second sparsebundle (the one with a lot of numbers) to confirm that it is now the active TM file.

  • andrea.durzo Level 1 Level 1 (0 points)

    I tried to use the guide with one of the sparsebundle (the last modified) and this is the output of the terminal after a lot of hours. It seems to be not finished because i can't give another command:


    MacBook-Pro-di-Andrea:~ root# hdiutil attach -nomount -noverify -noautofsck /Volumes/TimeMachine/MacBook\ Pro\ di\ Andrea\ .sparsebundle

    /dev/disk1                    GUID_partition_scheme          

    /dev/disk1s1                  EFI                            

    /dev/disk1s2                  Apple_HFS                      

    MacBook-Pro-di-Andrea:~ root# tail -f /var/log/fsck_hfs.log

    /dev/rdisk1s2: ** /dev/rdisk1s2 (NO WRITE)

    /dev/rdisk1s2:    Executing fsck_hfs (version diskdev_cmds-540.1~34).




    /dev/rdisk1s2: fsck_hfs run at Mon May 21 10:56:50 2012

    /dev/rdisk1s2: ** /dev/rdisk1s2

    /dev/rdisk1s2:    Executing fsck_hfs (version diskdev_cmds-540.1~34).

    ** Checking Journaled HFS Plus volume.

       The volume name is Time Machine

    ** Checking extents overflow file.

    ** Checking catalog file.

       Invalid node structure

    (4, 46698)

    /dev/rdisk1s2: ** Rebuilding catalog B-tree.

    ** Rechecking volume.

    ** Checking Journaled HFS Plus volume.

       Catalog file entry not found for extent

    (4, 0)

    /dev/rdisk1s2: ** The volume   could not be verified completely.

  • morph21 Level 1 Level 1 (10 points)

    That is bad... Usually fsck_hfs does restart itself over and over until the volume is clear.


    You can try to run FSCK on your own, or just dismount and then mount the image again (info also on that guide).


    If after mounting it again, fsck_hfs runs and can't fix the problem, then I'm afraid your backup image is lost. =/

  • andrea.durzo Level 1 Level 1 (0 points)

    mmmm, i think i will reset my iomega (again) and i'll do a new backup; but how can i avoid it? I would like to know if is a time machine problem or a iomega storage problem...

  • Paul Bailey3 Level 1 Level 1 (55 points)

    I had this problem approximately every other week for awhile. I use a laptop at home and at work and often times get new / updated big files, but rarely use my computer at home (where the NAS is). I think that what happened is that backups were not completing or fsck was not completing after a broken backup that required the volume to be repaired (so there were multiple breaks) and then the NAS backup would be marked as corrupt.


    I don't know if this is really what happened, but it was my conjecture. So... I changed my ways.


    (1) I turned off TM.

    (2) I backup "manually" (using TM "Back Up Now") menu item in the tray (near the wi-fi).

    (3) when a back up is running, I do not sleep the computer or otherwise let it break its connection to the NAS until the backup is complete.


    Since I did this, I have no problems with the NAS backup.


    I hope that helps.

  • andrea.durzo Level 1 Level 1 (0 points)

    I think i will try it.

    So, thank you very much for your replies guys. Unfortunately i didn't solve the problem, but you were great.

    And sorry again for my english.


    Greetings from Rome

  • EdHayes3 Level 1 Level 1 (0 points)

    I just got off the phone with Apple.  They were very nice with how they handled it, but they would not support me because I was not using an official Apple Time Capsule.  I'm using gigabit ethernet to connection to my Synology DS211J NAS, with Sleep disabled, MacOS 10.7.5. Backups continue to fail, and I continually have to create new ones.


    For users who are using an Apple Time Capsule, PLEASE call Apple (1-800-My-Apple, or directly to Antonio who I talked with at 1-877-416-4271 ext: 2002) so that they can find the solution to this problem. Thanks!

  • TopSteve Level 1 Level 1 (65 points)

    I cant look at the information in the link you give as I dont have icloud account and as I dont have lion I cant get one (I have tryed) can you please quote the artical?

    Pondini wrote:


    Doug Hirzel wrote:
    FYI: you're not alone. I'm also having the same problem weekly for the past several weeks. In my case, the backup is on a external drive connected via AirDisk.

    If you mean via an Airport Extreme, you need to know that's "iffy" and +*not supported by Apple.+* See: Using Time Machine with an Airport Extreme Air Disk (or use the link in *User Tips* at the top of this forum).
  • Simply Rob Level 1 Level 1 (0 points)

    Once again. This morning i unlocked the Macbook only to be greeted by (jet again) a Time Machine verification error. It is happening more often these last few weeks. I'm running OS X 10.8.4 with all the latest updates.


    I'm using two Time Machine drives, one directly attached USB 2.0, and a Lacie Cloudbox network drive. The verification error occurs on both devices. I know those devices are no 'Apple Devices' - not a Time Machine device, but seriously the thing is just a harddrive. I even enable local snapshots to see if that helped. It clearly didn't.


    It is happening so much now that I've lost faith in Time Machine as a viable backup solution. I've read about using all kinds of terminal command to repair the drive, but frankly i don't think that is an acceptable solution. I am currently investigating other backup software because this is bunk and not worthy of the name Apple.

Previous 1 4 5 6 7 8 Next