3 Replies Latest reply: Aug 17, 2010 12:56 AM by dalrmi
dalrmi Level 1 Level 1 (0 points)
Hi, last days I can't add artwork to some of my movies, I do the same as before (drag & drop the jpg image from google search directly on artwork box of my movie in iTunes).

I checked more and tried also to add the image file with Add button without success.

The artwork seem to be added correctly when I click OK button but when I reopen the movie (information) I can't see the artwork.

I don't know how to do to solve this problem, just for completion I do this in order to see the artworks on my AppleTV.

My hardware configuration: iMac 10.6.3 late 2009, iTunes 9.2 (61), AppleTV 3.02.

Thanks and best regards, Roberto.

iMac late '09 3.06 Ghz Intel Core 2 Duo 4GB 1067 MHz RAM, Mac OS X (10.6.3)
  • Jolly Giant Level 7 Level 7 (25,440 points)
    check if you have read & write permissions for your music folder. in finder, right-click on it and +get info+. unlock the little padlock (you may have to enter your admin password) and change the permission settings. next, click on the little gear-shaped icon and +apply to enclosed items+ like so

    Screen shot 2010-06-02 at 6.15.04 PM

    you may also give everyone read & write access.

    JGG

  • dalrmi Level 1 Level 1 (0 points)
    Thanks, I checked and my account has read&write permissions on music folder, however I don't use that folder to save my movies, I put them on an external hard disk drive (USB) and also in that folder my account is configured correctly as per permissions.

    I found out, I'm very happy, a workaround to this problem and I'd like to share it with other users: I used the METAX application to add an artwork to movie file and it worked! I can see the artwork into my iTunes AND on my AppleTV.

    This isn't the solution to iTunes problem however it's a workaround that works, I hope Apple will look to it and try to fix it in next iTunes releases.

    Thanks again for your quick reply, ROberto.
  • dalrmi Level 1 Level 1 (0 points)
    With the use of an external program, Metax, I solved my problem. Bye, Roberto.