4 Replies Latest reply: Jun 19, 2010 1:24 AM by Chassa_123
Chassa_123 Level 1 Level 1 (0 points)
I have an odd problem with my battery. My MacBook doesn't start up from the battery, but it does when it's in the socket. Once started up, I can go on stand-by, pull out the socket and get him out of sleep using the battery. So I can run my laptop using the battery once it's started up, although it doesn't work all the time. Mostly, there's an X over the battery icon in the top bar, it says there are no batteries available although I can use the battery. Sometimes it gives the percentage, totally random.

I tries some stuff I found on Google, but it didn't work. One of the things I tried was updating my battery to version 1.4.

I got my MacBook in July 2006 and bought a second battery in July 2007. I didn't use that one a lot untill a few months ago, when my first battery died.

I must say I spilled water over my MacBook a few weeks ago. But there was no problem after this spill. The battery worked just fine untill a few days ago.

What to do?

Macbook, Mac OS X (10.5.8)