Previous 1 2 Next 20 Replies Latest reply: Jan 13, 2011 8:35 AM by DanielGMac
hcoin Level 1 (0 points)
Bought the fancy Macbook pro in '07 from the campus bookstore, kid plugs it into the wired jack and uses the open-access campus wifi and all's well. Massive 'all risk' uber-we'll-make-it-right Apple warranty. They get a digit wrong in the serial number and deny the warranty. Get help from the campus store to prove we bought it and we send in lots of paperwork a second time and sure enough SW87305E6X92 now has a warranty. Great!

Next year she moves into new space, wifi only works on campus open-access network but wired port is available in the room so all's well, she can do her work.

Next year 6 students share a wifi router, WPA2-PSK (AES) Netgear. The two girls with macbook pros can't connect. All the M$ kids' laptops work. Campus store says 'buy the latest apple os'. We do. Run a ethernet wire out the window and down the hall to the router, all's well. Remove the wire, wifi on WPA2-PSK netgear-- only the Apple products still fail.

Call Applecare. Make the appointment. They go through all kinds of router changes and confirm a problem, have her take it to the authorized Apple repair place via campus. They upgrade software and firmware and return it. Same problem. She takes it back for really-for-sure-this-time repair. Same problem. We add a new wifi router with no security and she muddles through the rest of the year because it works with that.

She comes home, here we have a new Belkin router. WPA2-PSK (AES). Two M$ laptops, handheld wifi stuff all work. Not the Macbook pro. The OS reports the network and reports good reception but just fails the password. Same as it was out of the box from day 1. Same as it was after local and send-out apple care did their thing last year. Take it in to local (Iowa) Apple authorized service center. They have a QWest DSL and old WPA router and say it's all fine, come pick it up nothing more they can do, have we called Apple Care?

What a shaggy dog story. So, right now, unless somebody somewhere can figure out how to get Apple to change the wireless gizmo in this thing so it actually works the plan is to bring it home, take all the files off it, and with regret throw it away basically since we can't afford to send her off to school next year risking Apple produts with great support that leave her behind in her classes because they look great and work great except when not for us!

Help Please!

Macbook Pro, Mac OS X (10.6.4)
  • LilyLC Level 4 (2,660 points)
    Seems that the password step is the stickler. Since I do not see the steps of how you tried to setup the MBP to join any of the existing wifi networks… If you tried connecting by clicking the Airport icon in the Menu and then selecting Join Other Network, then try the following…

    1. Launch System Preferences and click the Network icon
    2. At the bottom of the Network window, click the button “Assist me…”
    3. In the next dialog box, click the button “Assistant”
    This will create a new location and guide you in setting access info to your specific wifi router. Follow the prompts…
    (You may want to name this setup Home and then have a different location name when setting up her access at school.)

    Once that is complete, back in the Network window, near the bottom of the left pane, click on the gear icon and select “Set Service Order…” Be sure that the Location is the one you just created. Then under Service Order: be sure that Airport is at the top of the list by dragging it there.

    Your daughter can follow the above setup steps at school. (Or there should be an IT Department, that can help her set it up as they may have specific VPN protocols.) When she is at home, she can just switch Locations from the Apple menu.

  • Khrus Level 1 (0 points)
    Hey LilyLC

    I had the same problem as the original poster trying to connect to a Netgear WNDR3700 and followed your instructions about creating a location and now the MacBook seems to remember the network info. Its strange because I've never had to do this before but then again I just got the Netgear; it replace an old Airport 1034.

    The MacBook was able to connect when I broadcasted SSID, but could not remember having connected to the Netgear even though the info was stored in a preferred profile and was at the top of the connection order list.

    Very strange that the original poster's multiple trips to support did not fix the problem.

    Thanks much
  • LilyLC Level 4 (2,660 points)
    You're very welcome, Khrus.

    Glad it worked for you and thanks for letting others know.
  • hcoin Level 1 (0 points)
    Hi All. Still no joy. New locations, etc. etc. didn't matter. A local Apple repair center speculates that the problem is the system can't separate multiple wireless stations and pcs in the same area, especially if one of them is a Wii. Something about some of the macbooks having a batch of iffy wireless chips.

    So we backed up everything to an online backup service and we are hoping the Davenport repair guy -- who appears to have a real clue -- will install some new part or make a change.
  • Baby Boomer (USofA) Level 9 (57,115 points)
    "So, right now, unless somebody somewhere can figure out how to get Apple to change the wireless gizmo in this thing so it actually works"

    If the +"Davenport repair guy"+ can't fix it, strongly suggest that you call Customer Relations - 1-800-767-2775.
    Report to them everything you stated in your original post. See what they can do for you.

    Good luck!

  • hcoin Level 1 (0 points)
    Here's hoping! The new local repair fellow said even though we'd sent the system in to for Apple authorized repair for this issue twice-- all that had been changed was something about a lid or case lid to help out some touch pad issue (we had a touchpad issue?) So here's hoping actually doing something with the wireless thingy for a change will make it work reliably! We upgraded to the latest OS in hopes but same old same old. Thanks for the thought about calling Apple and asking for help. We did that last time and when it came back it wasn't better! This local repair fellow is our last hurrah for this -- if no joy here then it's dumpster city and time to buy ... well I can't bring myself to say it..
  • CMCSK Level 6 (10,640 points)
    Thanks for the thought about calling Apple and asking for help. *We did that last time and when it came back it wasn't better!*

    Apple Customer Service is not tech support. It is a department that tries to make things right for Apple customers. They cut through all the red tape to keep its customers happy.
  • LilyLC Level 4 (2,660 points)
    hcoin wrote:
    We upgraded to the latest OS in hopes but same old same old.

    Well, you're not entirely alone. It may be the OS and you might consider perusing and posting in the Mac OS X v10.6 Snow Leopard section: Getting Online and Networking. Take note of the thread OS X 10.6.4 update killed my wifi.

    At one point you mentioned that wireless worked but without security. So, it would seem that the AirPort card works. Not knowing the settings of your Belkin router nor all the AirPort network settings make the issue difficult to solve remotely. It could be something simple that no one considers as the culprit. Hopefully, the local repair person can fix it, and afterwards, consider talking with the school's IT people as they should know the network of the entire school. There just might be a particular port on Macs that need to be opened.

    Good Luck.
  • hcoin Level 1 (0 points)
    Thanks for that! Well the maddening thing is that it always seems to detect all the various available wifi ports, all the time. The fellow in the shop saw it detect 7 different wifi routers in his business park. Once I even had the thing sitting on the bed with the wifi router in the same room. It always works with no security. We've tried it against a Belkin, a Netgear and a Dlink.

    After great pain and lots of fuss the only explanation we have that fits the facts is that something in the actual hardware that helps with WPA2 just fails when there is a presently unknown magic combination of other devices using wifi at the same time. Whether it is just enough other clients, or just other routers sharing the frequency, who knows. What I do know is that nobody in the dorm who owned variations on M$ boxen had any problem. And only the two Macbook Pro users in her dorm had to run wires out their windows and down the outside into the window below and along the floor and into the router.

    There must have been something almost but not quite right in some number of wireless chips used in Macbook Pros starting 3 years ago or so. But boy the pain and treatment we got, even with the uber-super-duper three year warranty has been, well you can see what's it's been.

    Maybe tomorrow the local Apple repair fellow will have good news for us. I can't believe he's the only one who thought to actually do something to the wireless card. Go figure!
  • hcoin Level 1 (0 points)
    Update: The Davenport Apple guy got the system early this week, ordered a wireless radio part and it's tested, installed and ready for pick up Thursday. That's what I'm talking about. No two week send-it-here-and-there adventures and it still doesn't work. He did what he could and now we'll go pick it up and see what's what. I'm optimistic for the first time!

    Update to follow!
  • Baby Boomer (USofA) Level 9 (57,115 points)
    Yes, please keep us all updated.

  • dodgeballs Level 1 (0 points)
    I'm anxiously awaiting your update!

    I have had the same problem your daughter has been having, and I'm leaning away from hardware and still thinking there is a glitch in some of the MBPs.

    My wi-fi works 100% on 99% of networks I join. But, I've found one in a hotel in FL and one at a campsite in CA that I just can NOT join. Both use WPA encryption. Both prompt for the password then report "connection timed out." It's not an incorrect password. My wife using our 7 year old IBM Thinkpad is on in 30 seconds, but my $2000 shiny Mac is useless.

    Let us know what happens!
  • hcoin Level 1 (0 points)
    Monday Update: Picked up the system, it was reported to have a new internal wireless card. The tech said there is some chance there is a problem with a cable (and if there is return it before the warranty runs out next month!!).

    We got it home and it did work with the wireless here, but we messed up the test because all the other wireless devices were off at the time other than the Macbook Pro. So, more testing in a few days. So far, so good though.

    One take away lesson: Don't accept any system back from tech support for this problem unless they actually do something with the wireless system! Two trips to Apple certified repair and two extended periods while the system was 'sent out' for 'warranty repair' for this problem and zippo in fact was actually done.

    In fact we only got serious service when we took it in for repair in a town that did NOT assume it was a college student's computer, NOT located next door to a college book store.
  • hcoin Level 1 (0 points)
    dodgeballs: Apparently there is something about WPA2 encryption that happens in the hardware of all this. And, there were some iffy chips or good chips with iffy firmware that just doesn't do WPA2 correctly under the right conditions. That's why you get full bars and good operations except when the encryption is active.

    Believe me we thought it was hardware and spent bezillion hours with phone tech support on the phone and bought the newest and best operating system upgrade and all that-- at it was all one colossal waste of time. Anyhow check out the latest firmware and OS downloads and if they don't help (like it didn't help with us) then go get a new wireless card put in. (Well, wait a week or two to see whether we really have the fix we think we do...)
Previous 1 2 Next