10 Replies Latest reply: Feb 12, 2012 10:10 AM by moresquitch
MrNase Level 1 (0 points)
Hey guys!

I have installed Safari Version 5.0 (6533.16) and the HTML 5 geolocation doesn't work.

I have re-installed Safari, used the Guest Account but none of the HTML 5 demos are able to detect my location.

My MacBook (same network) has the same issues.

What other things can interfere with this function?


P.S. All of those demos work fine on Firefox (same machine)

iMac 24'', Mac OS X (10.6.4)
  • Carolyn Samit Level 10 (103,365 points)
    HI,

    Open System Preferences / Security and select the General tab.

    Click the gold padlock icon bottom left in the pane to make any necessary changes. You will be prompted for your admin password.

    If necessary, make sure: Disable Location Services is not selected. Click: Reset Warnings.

    Relaunch Safari. See if that made a difference.







    Carolyn
  • MrNase Level 1 (0 points)
    Carolyn, thanks for your reply.

    However, it doesn't work.


    I have tested it with the following devices:
    iMac, Safari 5, OS X 10.6.4 (wired to the router)
    MacBook, Safari 5, OS X 10.6.4 (connected via Internet-Sharing)
    iPhone 3GS, 3.1.3 (connected via Internet-Sharing)


    iMac, doesn't work
    MacBook, doesn't work
    iPhone, does work. But I suppose it's using the cellular data.


    The strange thing is that both devices, iMac and MacBook, have the same problems.


    The website I am currently using is http://html5demos.com/geo

    When I disable the Location Services (they were enabled) the website shows 'failed' right from the start. With the Location Services enabled the website tries to find my location but after 5 seconds it shows 'failed'.

    Again: Firefox does it without any problems. On both machines.



    - Dominik

    Message was edited by: MrNase
  • MrNase Level 1 (0 points)
    I am sorry to bump this but I tried it with different browsers now.

    Webkit (latest Nightly): doesn't work. Same error as with Safari.

    Google Chrome: Works like a charm.


    Does anyone know what might cause the problems I currently have?

    Like I said: I also switched the computer with no success.
  • teryan2006 Level 1 (0 points)
    I had the same problem but I figured it out. I use wired ethernet for my network connection, so I turned off Airport on my iMac. Turns out Safari 5 is using CoreLocation to get geolocation data. And CoreLocation on Mac OS right now only works by using Wifi and SkyHook. I turned Airport back on and it worked like a charm.
  • Raymond Othenin-Girard Level 1 (0 points)
    Hi All,

    I use wireless and have exactly the same problem. Have tried to turn on and off Geo location, erased the warning messages, turned on and off the Wireless connection to no avail.
    Safari will fail in about 5 to 10 secs
    Chrome will remain stuck with the message Checking
    Firefox will succeed

    Anything else I can look at to make this work ?

    Thanks

    -R
  • progressnerd Level 1 (0 points)

    I posted a separate question about enabling geolocation on Safari 5 on Windows:

    https://discussions.apple.com/thread/3547900

  • RabidCow Level 1 (0 points)

    I recently had the same problem with Safari reporting the incorrect location on my MacBook Pro, but the correct location on my iMac (both connected to the same network).  After talking with Apple Care Support, clearing the PRAM seemed to fix the issue.  To clear the PRAM on my MacBook Pro running Lion, I shutdown my computer, then pressed and released the power button, and finally pressed and held the following keys: P, R, Option, and Command.  Continue holding all 4 keys until a second startup chime sounds, then release them.  That's what finally seemed to do the trick for me, perhaps it might work for you as well.

  • moresquitch Level 1 (0 points)

    I dropped the PRAM, but it did not solve the problem

    Anyone have any ideas?

  • moresquitch Level 1 (0 points)

    Oh, btw

    location stuck to the place from which I was connected to the Internet via 3G modem

  • moresquitch Level 1 (0 points)

    Well, the problem was accidentally solved

    I just connected to public wi-fi hotspot and location fixed at that point.