Previous 1 2 3 4 Next 110 Replies Latest reply: Mar 1, 2011 5:23 AM by joewiz Go to original post
  • indygwyn Level 1 Level 1 (0 points)
    Just another "me too" If you click "Download All Free Updates" a second time after the "...outdated" and error popups, it does work though.
  • mstrammd Level 1 Level 1 (0 points)
    I spoke with Apple this morning about this issue. Here is the solution: You need to uninstall iTunes then download it from Apple's web site and reinstall it. It is not sufficient to drag the app to the trash. You need to follow the procedure outlined in this link to remove iTunes. NOTE: you do not have to trash the .plst files that contain your settings. When you read the directions there is a set of instructions to remove the iTunes program and in the last paragraph there are additional instructions for removing other associated files that YOU DO NOT NEED TO REMOVE. Those are your saved settings for iTunes that you want to keep.

    I followed that procedure and it fixed the issue
    Here is the link to the instructions:

    Good luck!
  • KC85 Level 1 Level 1 (0 points)
    @mstrammd - This seems to have fixed the issue! Thank you!
  • mstrammd Level 1 Level 1 (0 points)
    Well...not so fast. I thought the problem was solved, but unfortunately it has reared its ugly head on my iMac again this morning. It seemed to be fine on both my MBP and iMac machines yesterday after reinstalling iTunes. I'll be calling Apple Care again this afternoon.
  • Armedia Level 1 Level 1 (45 points)
    Nope, deleting and reinstalling iTunes did not fix anything.

    - aj
  • KC85 Level 1 Level 1 (0 points)
    ****. Well, yesterday it did a single app update for me just fine (I always click the "Download All Updates" button anyway. Next time I have multiple updates, I'll see if it continues to work. Thanks for the (seemingly temporary) fix.
  • jfdf5 Level 1 Level 1 (0 points)
    I reinstalled iTunes (but didn't remove any of the plists etc from my home folder).
    The next check for updates in apps worked properly when I hit update all, a single app required updating, and updated fine.
    However the update check after that...sadly the issue was back.

    Does anyone know what info each of the following pref files within the home folder specifically holds?
    ie *
    Also the files in /By Host/ folder?

    I would prefer not to axe my playlists and various sundry handy personalizations.
    I am time machined, so its not totally critical, just curious if taking action on any of these files resolves the problem.
  • KC85 Level 1 Level 1 (0 points)
    Sadly the same thing just happened to me today. The single app update worked perfectly last night. The two app update this evening just brought back the "Outdated" error. Oh well, at least it's only a minor annoyance...a couple more clicks of the mouse never hurt anybody.
  • mstrammd Level 1 Level 1 (0 points)
    I was able to update a single app on my MBP today without the issue, but I am skeptical that the problem is fixed on that machine. I called Apple Care today and the gentleman I spoke with is logging the issue with his superior and forwarding it to the engineers. He offered no solution, but he told me that these things are frequently addressed in a subsequent update that he thought might not be too far away.
  • Daniel Ray1 Level 1 Level 1 (5 points)
    I believe I have found an answer for this issue. It's not ideal, as it may involv losing some of your apps.

    The issue is caused by apps you own which are no longer available through the iTunes store. The solution is to delete those which are no longer available.

    Finding the ones which are no longer available is a tedious task. You will need to switch the view for your apps to list view in iTunes (while apps is highlighted in your library, click the list button which is the left one in the row of three view buttons at the top right). Then you highlight each individual app one at a time and click the link to the itunes store (the little arrow in a circle that appears when you highlight an app). If the link brings you to the application page in the store, it is still available. If it goes somewhere else or doesn't load the store at all, it is no longer available.

    I found 9 of my apps were not available anymore (AirTower, BombBlocks, Comcast TV Listings, MoPhoTo, Pikey, Tangram Puzzle Pro: Holiday Edition, TrafficJam, Triangles, Vortex).

    Once I deleted them (cmd delete, and move files to trash) and then restarted iTunes, I have not had this error occur again.

    Although Apple still needs to fix this issue so that we can keep the apps even though they're no longer available, this appears to be the temporary fix. Hopefully these apps aren't ones you care much about, and you're okay deleting them.
  • KC85 Level 1 Level 1 (0 points)
    This seems like a plausible solution, so I tried to test it. In the 9 apps you listed, I only had one of those, Tangram Puzzle Pro, so I decided to start with that one. I clicked the arrow (the one that leads you to the App Store) and the app actually came up. Are you sure TPP is no longer available? Here's a link to the page I got linked to:

    For full disclosure, I downloaded this app a long time ago when it was free. I have no clue if it affects anything now that it is $0.99, but I thought the more information we have to try to solve this, the better.
  • Rangeshooter Level 1 Level 1 (0 points)
    Well, that's some good troubleshooting--and it totally makes sense. Keep us posted. I'll have to try that fix when I have time to go through the 100 or so apps I have--ugh. My luck, by the time I find the culprit, Apple will have a fix.
  • Bobufarr Level 1 Level 1 (10 points)
    Nice work @Daniel Ray1!

    I had a few apps that no longer existed as well. Now that they're gone, the problem has disappeared.

  • indygwyn Level 1 Level 1 (0 points)
    I concur here too, the fix is apps that have been removed from the app store but you still have them. I just went through mine, down to 560 from like 585. At least 1 of them I still used, ah well.
  • JRobelen Level 1 Level 1 (0 points)
    Thanks for this catch. It makes it a little easier to search for dead apps if you sort by Purchase Date or Date Modified in List View. I also think it would be helpful for people who are pursuing this fix to list the dead apps they have found. Thus:

    Poll Tracker '08 by SLATE (Chimp Software)
    Vote Report (Popvox LLC)
    Obama '08 (Obama for America)
    open source reddit (Joseph Pintozzi)
    2009 Presidential Inauguration (PointAbout Inc.)
    NY Traffic Cam (3rd Dimension, Inc.)
    Satellite - Reddit for the iPhone (3Cube Technologies)
    Sparrow (Click On Tyler)
    Flusso Canalizzatore (Dimitri Giani)
    TinEye Music (Idée Inc.)
    iKendu (Free) (Apprageous)
    AirMe (AirMe, Inc.)
    Truphone 3.0 (with Skype calling) (Truphone)
    Searchme (Searchme, Inc.)
    Squared (Josh Hogan)
    Public Radio Tuner (American Public Media)
    Hot Popcorn Movies (Boctor Design)
    OSCRemote (nr37)
    Tweetie (atebits)
    VoiceCentral (Riverturn, Inc.)
    Swine Flu Tracker Map (IntuApps)
    Epic Pet Wars - Unlock Phale Whale + 10 Respect Points (Miraphonic) At Bat ( <= *NEWER VERSIONS HAVE YEAR IN TITLE*
    FlyCast Mobile Broadcast Network (FlyCast) (uLocate Communications)
    WordPress (Automattic, Inc.) <= *OLDER VERSION*
    FML 2.0 - Everyday Life Stories (enormego)

    ...and these are after checking only about 1/3 of the apps I have. They all have last modified dates before 1 January 2010, so I think the dead rate will drop off with the next bunch I check.
Previous 1 2 3 4 Next