7 Replies Latest reply: Jul 21, 2010 7:10 PM by Deano888
MMPP Level 1 Level 1 (0 points)
Wife uninstalled Iphoto. Tried to reinstall off application disc from macbook purchase from dialog box says not permitted. Any ideas?

Macbook, Mac OS X (10.6.4)
  • Kappy Level 10 Level 10 (251,210 points)
    iPhoto is part of iLife. You can reinstall it directly from the iLife installer which should be on the original installer discs that came with the computer unless you purchased it separately.
  • MMPP Level 1 Level 1 (0 points)
    Tried to do so, but dialog box says not permitted.
  • Kappy Level 10 Level 10 (251,210 points)
    I don't believe I've ever run into that unless you are trying to install an old version of iLife that's no longer compatible.

    Do you have a backup of your system that was made before iPhoto was removed?
  • MMPP Level 1 Level 1 (0 points)
    Thanks, disc is only a couple years old with Ilife being updated several times. We will go ahead and use the Time Machine backup.
  • Kappy Level 10 Level 10 (251,210 points)
    In addition to the iPhoto application there is one other file that must be restored. It's /System/Library/PrivateFrameworks/iLifeSlideshow.framework. Locate it in your backup and restore to the same location: /System/Library/PrivateFrameworks/
  • MMPP Level 1 Level 1 (0 points)
    10-4, everything is back and functional. Warm thanks for the expert help.
  • Deano888 Level 1 Level 1 (0 points)
    Please help. I have done a complete refresh. I dont have ilife anywhere and have tried lots of things to find it. I know when I first had the computer it came with ilife. I have my original restore disk with leopard on and my purchased snow leopard disc. I tried this fix as stated above but I dont have the "PrivateFrameworks" folder either in my time machine backups or the new install. I am really stuck.

    I didnt want to reinstall my computer from the backup because it has been running so badly hence the fresh install.

    Thank you for your help.

    Regards, Dean