Previous 1 2 3 4 5 6 Next 78 Replies Latest reply: Sep 3, 2010 4:51 AM by Banak Go to original post
  • osamayy Level 1 Level 1 (0 points)
    I've an error no# 3014 when I trying update to iOS 4.0
    I tried to restart computer, I tried from windows and MAC the same problem.

    any body have solution?
  • Cluster1 Level 1 Level 1 (0 points)
    Hopefully this may help everyone having the same problem. I updated my iPhone 3G from OS 3.1.3 to OS 4 last night. The updated OS was downloaded first then the initial backup took about 45 minutes then the new software was installed. iTunes then attempted to restore from the backup and resulted in error -34 as mentioned in a few posts here just before completion.

    It appears the the update to OS 4 is a bit more involved than previous upgrades as it seems to reset the phone to factory settings, wipes it then installs the new OS and performs a restore from the backup created.

    After the error I got the same message as others on this forum that I either had to set the phone up as if it were a new one or restore from backup, cancel or delete backup. I did a second restore only to get the same error. So on the next attempt I deleted the backup and the phone then seemed to connect to iTunes ok and sync. However when I unplugged the phone I strangely had all my apps and mail account settings, contacts calendar events etc, but no media, i.e. music, videos or photos. I also noticed that my key lock password protection had been disabled and I had to re-enable it. I must add that I was not too concerned about losing my contacts or calendars as I have a mobile me account and they are all on my work and home machines and therefore even if I had had to set the phone up from scratch I could have synced them all back again.

    On performing my first sync iTunes then added all of the photos and podcasts checked for syncing back on to the phone, however it did it as though it was the first time it had performed this sync. I have my music managed manually so had to manually add all my music back on, which to be honest has forced me to think about what music I actually want to listen to.

    In summary I think that iPhone OS 4 is a major upgrade to the phone, which appears to wipe it and then reinstall everything, but there seems to be a bit of a glitch for some in the restore bit of the process. From reading some other discussions it appears that Windows uses are having similar problems.

    I hope this helps, my iPhone is now working fine again and although the 3G does not benefit from a lot of the nice new features the new mail app and application folders is great, it was a bit of a pain and took quite a while to sort out and putting all my media back on took almost as long as the update process itself, but it seems to be a worthwhile upgrade from what I have seen so far.
  • deadlift Level 1 Level 1 (0 points)
    I've had the same problem with error code -34 and forced a factory reset, with similar results. iOS4 is now running and all my contacts, apps, messages, etc., are there but iTunes won't sync any music (I'm syncing playlists only). The error message I get is "iTunes cannot find the file". It also thinks that the phone is already synced with another library (it isn't) forcing me to start each sync fresh. Any thoughts?
  • RUQRU Level 1 Level 1 (5 points)
    So, is it the general consensus to wait until Apple releases a ".01" update to the updater before going forward? I don't want to spend hours trying to fix a botched update.

    Message was edited by: RUQRU
  • Mitchell Sefton Level 1 Level 1 (25 points)
    Update downloaded in 20 minutes no problem. Stuck on backup now for over 2 hours - only tiny sliver of blue showing in progress bar. Nightmare. What now? Wait for a couple of days? C'mon Apple, you can do better than this nonsense.
  • HenkLubberding Level 1 Level 1 (0 points)
    Same issues. At the end only lost about 50 photos, which is a real shame, but my main issue now is:

    The thing won't sync my media! Everything else works, but as soon as it starts syncing (ie) music, iTunes says it can't find the file.

    I thought Apple tests those things at least a g'zillion times.

    Any thoughts?
  • Duncan McGregor Level 1 Level 1 (0 points)
    OK, so I've spent a whole morning getting a working phone, but here's what I found.

    The backup before the upgrade - the one that took for-king-ever, failed to actually backup some files. In particular the SMS and call history databases, plus at least a couple of photos, who knows what else...

    Luckily I had a backup from Saturday and used Time Machine to fetch it from ~/Library/Application Support/MobileSync/Backup. Restoring this backup and letting iTunes reinstall all the apps was successful. If you try this you'll want to back up the Backup directory before you restore from Time Machine so that you can go back again if this doesn't work.

    Duncan McGregor
  • AnthonyJones Level 1 Level 1 (0 points)
    A friend of mine downloaded this OS4 update, and connected his iPhone 3G to iTunes to update - he now gets the message that his iPhone is corrupt, and no longer recognised. iTunes is also corrupt. He called Apple, and their response was they are aware this update is affecting some older model phones. When asked how quickly this will be corrected, they wouldn't comment, except to simply keep looking out for more updates!! I get the feeling this is yet another update rushed out that wasn't fully checked (a bit like the whole Apple TV issue a few years back). I uploaded the software as well, but no way am I connecting my phone. Come on Apple, we thought better of you than this.
  • Rachelkbarnett Level 1 Level 1 (0 points)
    OMG me too - at least I know it's not me.

    I don't know how to back out of iOS 4 - can someone help me at least get back to the previous version?

    Stupid -34 error - no probs with the native iPhone apps, including iCal data (if only it showed tasks...) but would be really nice to have some sort of media available!
  • KrystalM Level 1 Level 1 (0 points)
    I hope there's a fix soon. When I upgraded to 4.0, I still had my apps and mail settings but I lost my sms and call history, notes, contacts and calendar.

    I tried restoring – even from several versions I had backed up from Time Machine and it didn't work. I also tried syncing again as people suggested but I still don't have my data. My contacts, calendar and notes can be restored from MobileMe but I really don't want to lose my call/sms history! I've restored my iPhone 4 times now with no luck

    (I'm using a 3G with Leopard 10.6.4)
  • lawred2 Level 1 Level 1 (0 points)
    I'm getting error #3014 as well
  • Coulter11 Level 1 Level 1 (0 points)
    I dont even know what the deal is anymore, I have restored. And tried over and over again restoring to factory settings than to a restore that iTunes has saved and the process just hangs up in the final restore rebooting all over again.

    All 3G users, have you ever jailbroken your iPhone before??

    Mine was at one point 2 years ago, i am thinking this may have something to do with it.

    But for now I have lost all my contacts, SMS, photos, media... Which i want back!!!

    Go to **** apple for borking my phone

    I have tried many hack fixes reccommended on this website from people in the same boat as me but nothing is working. No one from Apple is commenting.

    Worst of all I have no Time Machine backups to get to an early restore b4 this craptastical update.

    Super sadface!
  • Alan Musgrave Level 1 Level 1 (5 points)
    Okay .. Update took a long time to sort out, but I've finally got it installed with all my apps and music. Download of the update took forever and I was hung in restore as many above have noted. I received error messages 402653077 initially then 402653091. I did a DFU restore and after a couple of tries everything restored escept my contacts. All my apps are working and music and I'm running OS4. Trick I think is to do the DFU reinstall and stick with it. If it doesn't work, try again. Mine worked.
  • slugsoo1 Level 1 Level 1 (0 points)
    hello mate had same problem !! couldn't turn off even hard turn off !!! got mine working fine now !!!i tried loads of **** off this site !! don't know why this worked !! took sim out of phone , then held the home button and on/off button for over 15 sec !! turned off phone !! put sim back in ! then said i had too connect too itunes and then the long thing of restore and update . then restore from back up took about 2 hours altogether . hope this helps
  • vtblom Level 1 Level 1 (0 points)
    Pretty much the same here, Updated iTunes, did a full back up yesterday, started the OS4 update this morning, it went through the full backup for several hours, then the phone restarted and windows is looking for a Apple Mobile device (Recovery mode) driver. Phone is currently bricked any help would be appreciated