Skip navigation
This discussion is archived

iPhone apps not transferring

5680 Views 6 Replies Latest reply: Jun 23, 2010 4:37 AM by immaterialgirl RSS
baker10 Calculating status...
Currently Being Moderated
Jun 21, 2010 12:23 PM
When I sync my iPhone 3GS to my computer, this message appears:

Some of the purchased items on the iPhone "(name)'s iPhone" could not be transferred to your iTunes library because you are not authorized for them on this computer.

I have tried authorizing my computer (with the message that my computer is already authorized) and going to File > Transfer purchases from iPhone and syncing my iPhone and computer but nothing seems to be able to transfer some of my apps from my iPhone to my Library.

I do not have the latest update installed to my iPhone because a message comes up saying that some of my purchases are not transferred to my library and should be before the new software is installed.

Any help or suggestions would be greatly appreciated!!!
PC, Windows Vista
  • ozuluo Calculating status...
    Currently Being Moderated
    Jun 21, 2010 1:38 PM (in response to baker10)
    i have the same exact problem with my ipod touch. please help!
    ipod touch, Windows XP
  • immaterialgirl Calculating status...
    Currently Being Moderated
    Jun 21, 2010 8:56 PM (in response to baker10)
    me three...

    Imac Intel Core, Mac OS X (10.5.8), iPhone 3G
  • mareebee83 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 22, 2010 3:26 AM (in response to baker10)
    okay this is getting seriously annoying... loads of threads about this but no answers! Com'n Apple!
  • myxiplx Calculating status...
    Currently Being Moderated
    Jun 23, 2010 1:49 AM (in response to baker10)
    I have the same problem, out of around 100 apps, 18 of them will not transfer to a new computer, which is a real pain since I want to upgrade to iOS 4.

    I only have a single iTunes account, and all the apps were downloaded directly on the iPhone. There really shouldn't be any difference between the ones that have synced and these.

    So far, the steps I have taken are:
    - Plug iPhone into laptop
    - Right-click phone and choose 'transfer purchases'
    - Most apps transfer fine, but 18 fail with the above error
    - Go to Store menu, click Authorise computer
    (iTunes reports that it is already authorised, but confusingly reports that I've authorised 3 of 5, and I've only got two computers, and have only ever used iTunes on those two)
    - Try to transfer again, get same error.
    - Go to Store menu, click De-Authorise, and then Authorise

    And so far that's it. I can't find any other recommended solutions to this, these 18 apps will not transfer, and I'm a bit concerned that I will loose them after the iOS4 upgrade.

    Does anybody have any other ideas?
    iPhone 3GS, Windows 7
  • dimon1408 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jun 23, 2010 2:41 AM (in response to myxiplx)
    I'm no expert, but just a simple suggestion...
    The error message you get is usually because there are some apps/songs etc in the iTunes library that are not purchased with the account that you've authorised the computer for - say, you get most of the apps from a@example.com, but if you transfer (ie because you've connected some other iPhone) apps from b@example.com, they will be stored in the Library (for me that's happened), but will not be transferred to your phone.
    My suggestions:
    1. On the iPhone, go to Settings -> Store and log into your account, or the 'other' account. The transfer may work then.
    2. You could try to reinstall iTunes, easy to do that on the PC, and delete all of its settings, and then log into your account.
    Make sure to remember whether you've used someone else's apps, as if you have, then you'll need that person's account to get the apps on the phone. Other problems may be - the hard drive is full, or the process might have quite simply timed out. I get the same problem sometimes but after some tries it usually ends up working. If you really have to, you can try using someone else's computer to authorise it (don't forget to deauthorise) and transfer the apps on there, and then on the USB memory stick - they should be saved in <user>/Music/iTunes/Mobile Applications - the .ipa files are them. But I've unfortunately got no actual solution.
    Mac Pro (8-core version), Mac OS X (10.5.6), WinVista x64 boot camped...
  • immaterialgirl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 23, 2010 4:37 AM (in response to baker10)
    I tried all the things mentioned in this discussion last night without any success, but today I finally got it to update without the error message!

    Here's what I did (not sure which are relevant so I'll include it all):
    1. At work today I dereauthorized my iTunes on my office computer and signed out before leaving.
    2. I started updating some of my apps via wireless, but it was taking too long and I got impatient so I only got it half done...
    3. When I got home I plugged it in and tried the update again and got the same error message
    4. Then I tried File > Transfer purchases from iPhone one last time...
    5. Then I tried to update and it did it! (but it took nearly 3 hours to update!)

    Hope this helps somebody...
    Imac Intel Core, Mac OS X (10.5.8), iPhone 3G

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.