Previous 1 2 3 4 Next 139 Replies Latest reply: Dec 6, 2013 3:33 AM by sgauntlett Go to original post
  • macpalmos Level 1 Level 1 (0 points)
    I have this problem too...

    brand new iPhone 4 and all my contacts birthdays are messed up... nice one Apple, and I see this bug has been around for quite some time now.
  • iainbeeston Level 1 Level 1 (0 points)
    I get this too. Since upgrading to iOS 4 on my 3GS all of the DOB's have been brought forward by around 21 days
  • iainbeeston Level 1 Level 1 (0 points)
    Actually my problem might be different to the above... (Didn't read it well enough)
  • kiwikid32 Level 1 Level 1 (0 points)
    I own an original iPhone 2G and have had this Contact Birthday field problem with my birthdays since 2007.
    We are now up to iOS 3.1.3 (and iOS 4.0 for devices that support it) and the problem has still not been addressed or gone away.
    Stink as bro...

    I've spoken to MobileMe chat help and iPhone tech support many, many times.
    Neither can help me but both agree it is a miscommunication between the iPhone and me.com.

    I've tried iphones restores and even setting up test Mobileme accounts with support reps. I can replicate the problem every time. Create/edit a contact on iPhone, sync, me.com birthday field appears one day late. Everytime.

    It makes no difference if:
    1. You turn Time Zone Support on or off (on the iphone, ipad, mac or me.com)
    2. You set iPhone or iPad Date and Time to Automatic or not.

    BUT I HAVE DISCOVERED THIS...

    If you set your iPhone Date and Time Timezone City manually to either US or UK places and manually correct the date and time to according to where you actually are, the problem will go away.
    The only downside to this method is that your iphone World Clock will think you are living in the specified city and therefore show you the wrong time for any other world clocks you set up.

    For example, I live in Auckland, NZ and have the iPhone Date and Time manually set accordingly.
    But my Timezone city is London, England.

    I think this problem is probably created because of the way MobileMe calculates southern hemisphere timezones.
  • jcbigears Level 1 Level 1 (0 points)
    Hi there.
    This may be a problem specific to New Zealand. I can enter birthdays fine on my Mac in address book, and they appear correctly in iCal. They are also syncing correctly with MobileMe. However, on my iPhone, in contacts, all the birthdays are out by a day! If I try and change the date on my iPhone, just like others have seen, the date automatically goes back to the incorrect one. Oddly, the birthdays appear on the correct date in my iPhone calendar too. What's going on Apple? And yes, my time zones, etc have all been set correctly to Auckland, New Zealand.
    John
  • SENIA_M Level 1 Level 1 (0 points)
    I have this problem only that my contacts show the correct date it's my calendar that is one day later. I deleted the date from the contact information and saved it. Then I went back and reentered it. It seemed to work but have not checked the birthdays in my calender in a few days. Maybe this works for some.
  • andrew.in.Boston Level 1 Level 1 (0 points)
    I don't think this problem is necessarily specific to New Zealand. I'm using this on the East Coast of the U.S. and also have the same problem where previously entered birthdays are showing up one day ahead. I use Exchange to sync my calendar and contacts.
  • robomoki1 Level 1 Level 1 (0 points)
    I am having the same problem and it is really making me mad!!!!! I am in California and my dates are one day past the birthday. I have only had this problem since the 4.0 upgrade...Way to go apple....I was thinking of switching all systems in my household....I used to think you guys had it together, but I have had more problems with you than any other phone or computer for that matter!!!
  • necimal Level 1 Level 1 (0 points)
    I have this problem too. I am from New Zealand, and have my contacts syncronised with Gmail (it is set up as an exchange account). It has definitely only started happening since the upgrade to iOS 4.

    Most of the people in the thread seem to be from NZ, and only have the problem since OS4. Unfortunately it seems to fall on deaf ears. Does anyone from Apple actually read these forums?
  • hyan99 Level 1 Level 1 (0 points)
    I don't know if the problem is isolated to birth date. I have my iPod touch 2nd gen upgraded to iOS4. Now my calendar date seems always show one day ahead. Even if I changed it back, if will get updated again, unless I turn off Wifi.

    I have the region format set to "USA" but time zone set in "Shanghai" since this is where I am. Not sure if this has anything to do with it. Never had the problem in the previous OS, which is 2.2.1
  • shlea Level 1 Level 1 (0 points)
    This is obviously not only a NZ problem.

    I sorted this out in the following way:

    1. I deleted the Exchange (mail/contacts/calendar) from my iPhone
    2. I manually edited all birthdays in my outlook calendar on my PC
    3. Then I created the Exchange account on my iPhone again, and sync'ed all mail, contacts and calendar from my PC to my iPhone

    That sorted out all the dates on my iPhone. For the future I will not enter new birthdays on my iPhone, but rather do it on my PC and then sync to my iPhone. Of course this is a crap solution as the beauty of a handheld device is to enter things there and then, and not having to wait until I'm back at my computer. But at least it will not mess up my dates.
  • mart11 Level 1 Level 1 (0 points)
    Yes i have had this problem since geting my first iphone 2g, all addrress dates are correct on outlook but when they sync over to my iphone they are a day late. Its absolutly stupid only solution i found was manually changing them on my iphone, once i do this they stay corrent and are still correct in outlook.

    Since updating to OS4 they have all returned back to a day late, althought not all of them, the ones that have been created originally on the iphone and synced back to outlook are still correct. Need to find a better solution then updating them manually as i refuse to go though and update them again if this is not going to get fixed! Dont suppose theres a way of simply downloading to a file from outlook and then uploading directly into itunes is there?

    Regards
    Mart
  • macpalmos Level 1 Level 1 (0 points)
    All fine now, I have returned my iPhone4 because of its signal loss fault and am UPgrading to a Samsung Galaxy S tomorrow...
  • cgerke Level 1 Level 1 (0 points)
    I get this problem too and I am in Sydney, Australia. All my contacts birthdays are pushed exactly 1 week earlier than what they should be every time my iPhone syncs. I am using gmail exchange sync. This only started happening when I updated my 3GS to ios4. I seriously doubt Apple care about anyone outside of North America.
  • Arbil Level 1 Level 1 (0 points)
    same here, but only seems to be AFTER OS4 update
    I first thought it was caused by the SmartSync app that I had awful trouble with, but now I have found this forum, it looks like the same issue.

    iPhone 3GS/iOS4
    Time zone is auto (I'm in Melbourne Australia)

    If I set the birthday/anniversary in Google all seems to sync OK to iPhone
    If I then edit ANYTHING for the contact in iPhone (eg the address), that is when it buggers up the birthday and brings it a day earlier. Make another edit in iPhone and dates are yet another day earlier. It just keeps bringing all dates forward a day everytime I make any changes in the iPhone.

    Now all my contacts are stuffed
Previous 1 2 3 4 Next