Skip navigation
This discussion is archived

Uninstalling Apple Mobile Device Support

7751 Views 3 Replies Latest reply: Jun 22, 2010 11:32 AM by thomas einstein RSS
mmatel Calculating status...
Currently Being Moderated
Jun 21, 2010 9:37 PM
I downloaded I-tunes 9.2 and now I am getting an error message that says I need to uninstall I-tunes and Apple Mobile Device Support. I am able to uninstall I-tunes no problem, but I keep getting a fatal error message when I try to unistall AMDS. Please help!

I tried using control panel to do it.

Thanks in advance!
Cmpaq, Windows Vista
  • Tubeblaster Calculating status...
    Currently Being Moderated
    Jun 22, 2010 4:10 AM (in response to mmatel)
    I'm having the same problem and have tried all the fixes I can find except editing the registry. Here are a couple of links that I've worked through.

    http://discussions.apple.com/thread.jspa?threadID=2464409

    http://discussions.apple.com/thread.jspa?threadID=2469029

    http://support.apple.com/kb/HT1923

    I've tried all of the uninstall steps recommended by Apple in the link directly above but like you, uninstall won't take out the AMDS. I've tried uninstalling it with CCleaner too, to no avail.

    We definitely need some help on this.
    Dell XPS 410, Windows Vista
  • Tubeblaster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 22, 2010 7:30 AM (in response to Tubeblaster)
    Well, I finally got AMDS uninstalled. I tried all of the steps from Apple at:

    http://support.apple.com/kb/HT1923

    As others have reported, everything went fine until trying to use Control Panel to uninstall AMDS. I got just so far and then rolled back.

    The next thing I tried was CCleaner, using the defaults, I let it clean up the temp files and broken items in the registry.

    I highlighted AMDS and then used the Uninstall button on the top left of CCleaner in the Tools section. It didn't work. However, I right clicked on AMDS in this same window and selected Run Uninstaller. It worked. Hooray.

    Then I followed the rest of the Apple instructions removing Bonjour and Apple Application Support. In the Verify part of the instructions it said to reboot, so I did.

    Following along, I got to steps 8 and 9 and tried to delete the Common Files/Apple folder, but it wouldn't let me. Looking inside the folder, I could see the AMDS folder with a bunch of files in it. How odd, since it had been deleted. I checked Services and indeed, AMDS was running. Weird.

    I stopped the AMDS service. Went back to CCleaner, tried the Uninstall button in the upper left corner. That didn't work. Once again, I right clicked AMDS in this same window and selected Run Uninstaller. It worked (again). This time I verified the service was gone (it was) and that Control Panel showed AMDS didn't exist to uninstall (it was gone). I thought this might be my chance to delete the Common Files/Apple folder and it worked!

    I finished checking the remaining remove instructions from Apple. I rebooted and checked services and control panel and AMDS was gone.

    I ran the iTunes installer directly from the Apple website and it worked properly. I connected my iPhone and after the driver installed, it hooked up with iTunes with no problem.

    I was able to backup the iPhone and then install the new operating system. All is well.

    Wayne

    Message was edited by: Tubeblaster
    Dell XPS 410, Windows Vista
  • thomas einstein Calculating status...
    Currently Being Moderated
    Jun 22, 2010 11:32 AM (in response to mmatel)
    had same problem, and followed all directions, including right click on cc clean for removal. Would remove on cc clean remove menu, but not on control panel remove program menu. I erased all the directories as per apple instructions, then went back, and still couldn't remove apple mobility. I don't know why, but instead of remove program I picked repair. After repair, I redid remove/uninstall, and it actually worked. I reinstalled itunes 9.02, and then it failed to update. So I rebooted, started itunes, reconnected iphone via usb, and then option to update to iphone 0s4 came up, and is now downloading and installing.
    hp pavilion dv7, Windows 7, also running mac osx

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.