13 Replies Latest reply: Aug 12, 2010 9:04 PM by mm66
Jeffrey Osterman Level 1 Level 1 (30 points)
I recently upgraded my iPod Touch (3rd Generation) to iOS 4. I an effort to enable the hardware encryption functionality of the device, I followed Apple's instructions to backup the iPod, erase it to factory settings (using the "Restore" button on the status pane of the iPod section of iTunes and attempt to restore from the backup I just made. Unfortunately, the restore now fails 100% of the time with the error "iTunes could not restore the iPod [iPod name] because an error occurred." There are no error numbers listed.

Any assistance anyone can provide would be much appreciated. A decent chunk of data that was local to my device now seems to be missing.

iMac, Mac OS X (10.6.4)
  • keredg Level 1 Level 1 (0 points)
    This is not going to help any, but I sympathise. I have just done almost exactly the same thing and have completly killed my ipod touch. Basically Itunes will not recognise my Ipod as a valid Ipod and will therfor not reinstall the software. Also Itunes 9.2 refuses to install..

    Sounds like we both ahve a similar problem..
  • didley doo Level 1 Level 1 (0 points)
    I have done the same.Installed new itunes because having trouble with itouch music skiping randomly, then installed the dreded ios4 (of death) Now receive new message Itouch could not update with an error code 37. now Itouch will not respond. hope I have not got an expensive Ibrick Its only 7 days old. Can anyone help Please.
  • Jeffrey Osterman Level 1 Level 1 (30 points)
    For what it's worth, I recently noticed that the Console application kicks out the following error message when trying to restore:

    AppleMobileBackup[2020:903] ERROR: Restore message response: 102 rename error: No such file or directory (2) at path "/var/mobile/Library/SMS/sms.db.restored" (com.apple.MobileBackup.ErrorDomain/102)
    AppleMobileBackup[2020:903] WARNING: No MobileSync error code defined for error code: 102
  • leedas Level 1 Level 1 (0 points)
    I tried to update to ios4 and the process didn't complete. Tried to restore on several occasions but kept coming up with "error 37" and my ipod wouldn't respond at all - just a blank screen. Eventually, after trying a few things, I disabled my firewall (ZoneAlarm) and everything worked fine. Might be worth a try or maybe a coincidence? Hope this helps.
  • scoobiesnacks Level 1 Level 1 (0 points)
    If you've lost data try this:
    http://discussions.apple.com/thread.jspa?threadID=2473251&tstart=0

    If the backup itunes took at the time of updating is corrupted, ie causing various errors on restore, just move it out of the c/users/<yourname>appdata/roaming/applecomputer/mobilesync/backups folder (suggest you keep this old backup somewhere else just in case) then try the method I've posted in the link above to find a "hidden" backup folder that your OS - if you're lucky- has shadow copied.
  • didley doo Level 1 Level 1 (0 points)
    Hey thanks for the response in my times of need. Tried the disabling zone-alarm firewall trick witch I have installed to no avail. I should have explained that when I plug itouch in to usb I get the message that this usb device is not recognized. It does not display in windows explorer or itunes, pressed home and sleep buttons for 10 secs you just get the annoying Bing bong sound when a usb is not connected correctly so i tried on another windows laptop with another cable exactly the same. So I can not get access to anything to upgrade or change. But on the bright side I phoned apple support this morning and they are willing to take it in for s service or exchange, so now just to wait and see what becomes. by the way when the error occurred it gave me some info in spx format file witch I can not open anyone any ideas how to open it. Many thanks once again.
  • fisc3577 Level 1 Level 1 (0 points)
    The EXACT same thing happened to me. I upgraded to iOS 4 on Tuesday, then a couple days later tried to sync. Got a sync error. Tried again. new sync error about required file not found. tried to do a restore. restore error. Now the touch won't turn on and several windows machines just say they can't recognize the usb device. I'm going to see the genius bar on Saturday. Hopefully they can give me some guidance.

    Message was edited by: fisc3577
  • didley doo Level 1 Level 1 (0 points)
    Well I packed up the i-touch and they arranged collection and taken it away on a stretcher for open heart surgery (24 hrs after phone call to Apple). Apple said either a repair or new unit. So now its on its way from Spain to the Netherlands. Fingers crossed they will take good care of it.
  • didley doo Level 1 Level 1 (0 points)
    Forgot to say have you tried connecting to a Mac. the guys from apple asked me if I had. Worth a try if you know a Mac owner.
  • davesp Level 1 Level 1 (5 points)
    For the record, I see the exact same error on my Console when attempting to restore from a backup I had just made prior to clicking Restore (also as part of the process of enabling hardware encryption on my iPod Touch 3G).
  • didley doo Level 1 Level 1 (0 points)
    Well Apple gave me a newIitouch with version 3.1.3 software and I think it will stay like that until just before the 90 day gaurentee runs out. I am little scared of os4 but there are lots of people who have good experience with it. Hope every body gets the problems sorted. But 10/10 for apple service they were very efficient.
  • mm66 Level 1 Level 1 (0 points)
    I had this exact problem, just as described by the original poster. I went to the Apple store, but the Genius Bar was totally unable to help. I am glad I went, however, in that they did have a possible explanation, which was as alarming as it was unexpected: the backup files are probably corrupt (in my case, perhaps by an (unwanted) simultaneous iOS upgrade to 4.02?). Apple had no solution, but the only choice I can see is restoring a previous, good version of the backup image to your computer, and then trying the restore again. Hopefully you have Time Machine or something similar--for once in my life, I am prepared. The files in question are located in different places on Mac and PC. See:

    http://forums.macnn.com/103/ipod-iphone-and-ipad/355013/iphone-backup-file-locat ion/)

    Restore the entire folder, just to be safe. iTunes now accepts the backup and seems to be working normally. It has reset, and the full restore is in process. I won't know for a few hours if my all app data is intact, so I'll have to report back.

    PS: Do to some panicky monkeying around earlier in the day, I also had to restore earlier versions of these 3 files to make it work, as iTunes was no longer recognizing the old image files as belonging to my iPod. I'm not sure which one is truly responsible for the confusion.

    1) iTunes Library.itl
    2) iTunes Library Extras.itdb
    3) sentinel
  • mm66 Level 1 Level 1 (0 points)
    Yes, this worked perfectly. Although I'm very disillusioned to know that from now on, I need to make a copy of a good backup image before accepting any OS update! What's the point of having a backup, when you need to backup the backup?!