Previous 1 2 3 4 Next 46 Replies Latest reply: Jan 23, 2014 5:01 PM by garuda1969 Go to original post
  • StayCK Level 1 Level 1 (0 points)
    Absolutely the same problem as mentioned above. All set in iTunes, synched, and all are in the phone, but do not show up in iBooks app.

    Too bad. I was excited about trying this as it seemed so simple and convenient. Perhaps it is a 3G problem as was mentioned in earlier posts. I hope this gets resolved at some near point.

    By the way, I waited in a line of 1000 at the Apple Store beginning at 5AM today for the new phone. No iPhone 4 for me yet. Apple ran out. Good luck friends!
  • 73landau Level 1 Level 1 (0 points)
    I am having the same problem. I downloaded 6 books. They appear to install with the blue bar filling up. The bar then turns black. When I try to open the book, nothing happens. If I close ibooks and reopen it the recent purchases show up and then dissapear never to return. After I sync my phone, they are in itunes but are "greyed out". Leaving iBooks open for several minutes hasn't forced them to appear From this discussion thread, it seems to be a 3G bug that may not be resolved quickly. 6 months of contract left till I can fix it with a new iPhone HD

    Message was edited by: 73landau
  • fjfjfjfjfjfjdksllair Level 2 Level 2 (320 points)
    Came across this thread, which may help some people. Apparently if you jailbreak this is an issue. You'll probably have to restore as new and then try if you want it to work.

    http://xsellize.com/topic/70698-ibooks-broken-after-jailbreak/
  • EJulien Level 1 Level 1 (0 points)
    I ended up deleting the app on my phone and on my iTunes account and then downloaded it again. Everything showed up and now it works.
  • filjedi Level 1 Level 1 (0 points)
    Same here, though my issue is more peculiar. I reinstalled iBooks after deleting it from iTunes & downloading it again. Regular iBooks & PDFs do appear, but PDFs from iTunes U don't. They appear in the "Books" tab of iTunes, but aren't synced to the iPad or iPhone 3GS on iOS 4. Strange really..
  • Bryan Chapman Level 1 Level 1 (0 points)
    Fixed for me

    <Edited by Host>
  • J. Chiu Level 1 Level 1 (0 points)
    Hi guys,

    Try these steps, before you go to the bed:
    01.) Plug your iDevices into charger. Set Auto-Lock time to unlimited.
    02.) Remove your iBooks app and download it again.
    03.) Make sure you have synced books(epub or PDF) into your iDevices. If not, sync them.
    04.) Open iBooks app, do not lock iDevices' screen, and back to sleep.

    I finally got my books shown on iBooks overnight. There might be some syncing or loading issue in the iBooks itself.
  • Steve Curtis1 Level 1 Level 1 (40 points)
    It's not just a problem with the 3G. I've got a 3GS running OS4, with iBooks 1.1. When I open iBooks I get the shelf or list view, but without the Books|PDFs button. The header has an Edit button on the left, "iBooks" in the middle, and a Store button on the right.

    When connected to iTunes, the 3GS shows up and the Books category shows up under the 3GS. When I click on Books, I see (greyed out, as usual), the PDFs that I have loaded into iTunes. The PDFs are on the 3GS, but the app is not display the controls properly, very much as though it has not been updated to 1.1.

    I have deleted the app from the 3GS and iTunes, deleted the PDF files I had imported, re-downloaded the app and synced the 3GS, added the PDFs and synced again, etc., but the app is not working properly.
  • robomatik Level 1 Level 1 (0 points)
    Everyone who has the sam problem. If you cannot see the Books/PDFs TAB it is because FIRSt you have to download a book from the iBook store. Then they will show up and all working fine. No speed issues.
  • Tom Borgstrom Level 1 Level 1 (80 points)
    I have a similar problem with my iPhone 4.

    IBooks worked fine until I tried to open a PDF from Safari. Now I don't see any books or PDFs in iBook-just a black screen where the books should be. Selecting PDF or Books doesn't make a difference. The iBook Store still works though...
  • Greystash Level 1 Level 1 (0 points)
    i fixed this on my ipod,, no books would show up at first but i left ibooks running for about 20 seconds (showing no books on the shelves) and then i got a sync message and the books appeared
  • rePad Level 1 Level 1 (0 points)
    Please change Media Kind to Book one by one, but not as a whole.
  • Cadre Level 2 Level 2 (170 points)
    Alright, figured out the issue. iBooks is just really slow on the 3G. It takes upwards of a minute for the PDF books to show up.
  • ruaraidh91 Level 1 Level 1 (0 points)
    JUST SLOW?! Seems like it.

    I had synced a large PDF (384 MB) to my iPhone 3G and according to iTunes the space was taken up on the phone however when I opened iBooks on the iPhone the Books/PDF tab was not there. I left it sitting open for a few minutes until I looked again and it had appeared and I could open the PDF.

    Interesting to note that I exited the app, left it for a bit then opened it again and the Book/PDF tab was there straight away. Don't know if it would still be there if the phone was restarted or not..
  • Scott Griswold Level 1 Level 1 (5 points)
    That's precisely the problem. Same happens on the iPad if you load a lot of PDFs and they are large. I put 20 PDFs on that were around 60MB each. Took a minute or 2 for them to show up.