9 Replies Latest reply: Jun 24, 2010 1:28 PM by ha109700
ha109700 Level 1 Level 1 (60 points)
So I decided to update my iPod touch 64gb to iOS4, but I'm having a few technical difficulties. iTunes updated, my library updated, then iOS4 downloaded.

After 2.5 hrs I got to this;
'The ipod touch could not be updated. An unknown error occurred (21)'

Nothing was happening so I restarted my iPod..... now I get this;
'iTunes has detected an iPod in recovery mode. You must restore this iPod before it can be used with iTunes'

I click OK and then Restore;

'Verifying iPod restore with Apple...'
'Preparing iPod for restore...'

and then finally;
'The ipod touch could not be updated. An unknown error occurred (21)'

I can't get my ipod to do anything (except weigh down some paper). It shows the screen that wants to connect to iTunes. So I'm stuck in an endless cycle, and not really too sure what to do....

My ipod doesn't work, legally I can not see any way to roll it back to iOS3. I can not install the backup I made before the update. W-T-F is the point in iTunes backing up my touch every time I sync? The one time I need my backup I can not use it.

I use my ipod A LOT, so this better get fixed SOON!!! I sold my ipod classic to pay for my, now defunct, ipod touch... what a bad idea!!

I expect better quality from Apple. This is rubbish programming from a company who charge over-market-prices.

Windows XP Pro, iPod touch 64gb
  • developerguy1187 Level 1 Level 1 (30 points)
    ha109700,

    I understand your frustration. What we are unaware of, in order to assist you, is what generation of iPod Touch it is. iOS4 covers only certain generations. It is the same with iPhone. If you update any iPhone older than iPhone 3G, it will cause many malfunctions in your phone. Here are the qualifications in order to run iOS4...

    - iPod Touch (2nd Generation)
    - - Late 2008

    -iPod Touch (3rd Generation)
    - - Must be 32GB or 64GB...

    I believe your problem probably lies within the generation of the iPod. If it was purchased before the 2nd Generation, your iPod is incompatible with iOS4. If you meet this qualifications and you still have errors... I recommend that you reboot your iPod. That should restore your iPod to its original factory settings. If the problems persist, contact apple's technical support line.

    -Hope this Helps!

    Message was edited by: developerguy1187
  • ha109700 Level 1 Level 1 (60 points)
    Hi, I have the 64gb 3rd Gen touch; model A1318.

    I managed to find 'iPod3,13.1.3_7E18Restore.ipsw' tucked away on my computer (282MB)

    I tried using DFU mode to restore this file, but got the same error.

    Same error when manually selecting 'iPod3,14.0_8A293Restore.ipsw'

    Is it possible that the problem is with new iTunes & XP combination, and not the iOS4 update?

    Message was edited by: ha109700
  • Smalls1652 Level 1 Level 1 (0 points)
  • ha109700 Level 1 Level 1 (60 points)
    Err... No he didn't. He answered a question about the iPhone 3G. The link you posted was asking why a certain feature of iOS4 was not on the 3G. So I can assume that the person successfully updated to 4.0

    I have the 64gb ipod touch, these only come as 3rd gen and are equal in spec to 3GS. I can not get 4.0 to load at all!

    Ipod 3rd Gen support all elements of iOS4 according to the official keynote and everything I have read since (except obviously video and call related stuff)

    Further to this, nothing I have read today explains why I can not go up to 4.0 or back to 3.1.3

    Bad news when you consider this thing cost almost £300
  • Smalls1652 Level 1 Level 1 (0 points)
    Wait, how did that get here? Baleeted and moved to the other thread
  • jbaweja Level 1 Level 1 (0 points)
    I had the same problem since morning. Used a tool called irecovery and it brought back the previous state.

    Have a look at the following article

    http://www.ihackintosh.com/2009/07/irecovery-iphone-recovery-mode-loop-restart/
  • JT53 Level 1 Level 1 (0 points)
    developerguy1187,

    I'm in Australia. Bought iPod Touch 8GB only 2 months ago. Last night PC popped up a message inviting me to upgrade to iOS4 as it was avaialble. Download took about 8 minutes, I touched nothing on keyboard. When finished there were 2 outcomes - first, iTunes (v.9 I think) doesn't even recognise iPod Touch even though still connected via USB. Secondly, the Touch has pic of USB cable pointing to iTunes logo which I took to be a silent instruction to connect up - but I'd never disconnected it in the first place!

    So does this mean I have a 2nd gen unit since it's only 8GB? And now that the only thing I can get on the iPod Touch screen is that pic, how exactly am I meant to restore/recover or whatever? Keeping in mind that iTunes doesn't see the Touch any more. I'm locked out.

    I build (non-Apple) PC's, repair them, fix HDD's, and so on. I've never owned an iPod anything. Is this experience indicative of what I can expect? There were no messages on my PC screen warning me that I couldn't/shouldn't do the upgrade either. Hopeless!
  • ha109700 Level 1 Level 1 (60 points)
    I haven't tried it but this seems to be a possible solution to the 21 error:

    http://discussions.apple.com/thread.jspa?messageID=11722869

    will try when I get home and report back
  • ha109700 Level 1 Level 1 (60 points)
    After reading most of the posts that are related to my problem, I has finally got there.

    If your having the same issue as me, then go to;

    C:\Documents and Settings\USER\Application Data\Apple Computer\iTunes\iPod Software Updates

    Delete all the files that are 'ipsw' filetype.

    When you click RESTORE in iTunes you have to download another 4.0 update file.

    That seemed to do the trick for me