Previous 1 2 3 Next 100 Replies Latest reply: Aug 13, 2014 8:28 AM by Dambay
El Barto Level 1 (10 points)
Hi - I was wondering if anyone has experienced this or knows how to fix it...

I was adding a .jpg image (600x600) to one of my songs by dragging and dropping it from my desktop to the little artwork viewer in iTunes (version 9.1.1) and my computer (MacBook Pro) froze for a few seconds whilst it was adding it. When the computer stopped its freezing, the artwork was completely black. I double-clicked on the song to play it and it no longer plays. All of my other songs are ok so I closed iTunes and restarted my computer but the song still doesn't play. (iTunes "plays" it but it won't go past 0:00 even though the play button turns into a pause button).

I "revealed" the song in Finder and it won't even play using QuickTime. The bitrate, size, etc are all in the "Get Info" window and are correct but the file is "dead".

Should I asume the song can never be fixed and delete it? (I have a backup) - but I'm concerned this could happen again.

Update: The song plays on my iPod touch with no sound and the cover is transparent in CoverFlow mode.

Mac OS X (10.6.3)
  • Limnos Level 8 (46,035 points)
    Sounds like the file was corrupted and replace from the backup. Never heard of that happening before on many years on the forums.
  • mustaphou Level 1 (85 points)
    This has happened to me. I added artwork to a song and the song will no longer play. It just skips to the next song. If I go to the artwork tab in 'Get Info' a little black box appears than can't be deleted.
  • Sharon Stead Level 2 (210 points)
    Where'd you get the artwork? Maybe the .jpg itself was corrupted from the source where you got it from and that caused the issue?

  • mustaphou Level 1 (85 points)
    I get all of my artwork from There was no problem when I replaced the corrupted file with the backup and tried re-adding the artwork. Just a bit of a pain to go through that each time a file gets corrupted. I've held off on adding more artwork and see if it's something with iTunes that got fixed in iTunes 10.
  • iloveperth Level 1 (0 points)
    This just happened to me too! This afternoon I downloaded itunes 10, and proceeded to rip a 2 cd set (192 kbps AAC). Then I went searching for the album's artwork on Google, copied it, selected all the files at once (about 50) with Command-I, and pasted in the artwork. I wound up getting a black box, and when I tried to play them, iTunes skipped through all the tracks in a matter of seconds. All corrupted! I tried to play them in a finder window, but got nothing, yet the file sizes stayed the same!

    This is really weird. I just spent an hour searching the net for information, and this was the only thread I found. Was the artwork I copied too large (it was a 700x700 image)? I updated the artwork on my other albums—with smaller images—and everything is working just fine, so perhaps you can only use 500x500 images and below.

    By any chance, playing the file, I didn't let loose some sort of malware, did I?
  • mustaphou Level 1 (85 points)
    Just confirming that I'm still having this problem in iTunes 10. All of my artwork is 600x600 or smaller PNGs.

    I believe iTunes 9.2 changed the way artwork is handled. My guess is this is a result of that. I've tried deleting my iTunes library and artwork files and reimporting all my songs fresh but that hasn't helped.
  • iloveperth Level 1 (0 points)
    Still happening to me as well. I noticed it only affects the AAC/m4a files and not MP3. It's strange though—I added the artwork to an entire album (Using the Command-I function), and only 1 song was corrupted. It's rather hit and miss, and very, very strange.

    Its been driving me crazy, so I called up AppleCare, hoping someone would give me an answer. The guy I spoke to had never heard of this problem, proceeded to keep me on hold for 25 minutes to find out, and then "conveniently" disconnected me. Rude. Now I check all my m4a files after adding artwork, delete the ones that are corrupted due to doing so, and try again.
  • sharxfan Level 1 (0 points)
    I'm having the same problem as well. Pasted artwork turns to a black square and the song file is corrupted and unplayable. It seems to have something to do with pasting artwork while a song is selected or already playing in iTunes. I'm currently running iTunes 10.0.1 but I was experiencing this problem in earlier versions as well.

    Today when it happened I was pasting artwork from a file already in my library (using the control-click copy and paste method) so I don't think it has anything to do with the artwork itself. It happens when pasting directly onto the artwork box in list view or from the "Get Info" panel.
  • Randall Pinkston Level 1 (0 points)
    This has happened to me several times. I have an external drive hooked up to my Airport, and that's where all of my music resides. Every now and then, when I'm adding artwork to multiple songs, the connection between the hard drive and my Airport will break. (Not the Wifi connection--I can still get online, but I will not be able to open up the hard drive through the Finder, and iTunes will no longer be able to find it.)

    This happens infrequently enough that it's not a big deal, I just unplug and replug in the Airport and then everything is OK. The problem is that whatever song was in the middle of having the artwork transferred when the connection broke is then corrupted. I can't play it, and the artwork is black. When I try to change the artwork, it won't let me.

    I can locate the corrupted file in the Finder and play it back, but the first half of the file is often full of empty space and hisses. Any ideas?

    I don't know if this is relevant, but I've discovered that iTunes cannot find my music folder even when the hard drive connection is good unless I manually open up the music folder in the Finder first. I have to click on the name of my network in the sidebar and navigate to the music folder before opening iTunes, otherwise it doesn't believe that the hard drive is actually connected.
  • Thomas Renwick Level 1 (0 points)
    I'm having the same problem here, certain songs get corrupted in the first few seconds when adding the artwork.
    But in my case i`m using windows 7 x64. Sorry for posting this here, but it is the only topic i found in the forums

    Message was edited by: Thomas Renwick
  • El Barto Level 1 (10 points)
    Thank you all for your replies! This problem continued into iTunes 10.0 but as of 10.1 it has happened to me (yet)!

    I obviously picked a bad time to completely reorganise my iTunes library and corrupted at least 100 songs, some I had purchased from the store and didn't have copies of (I do backup but I edit the song as soon as its downloaded). Thankfully, Apple let me download the songs again but didn't know why it was happening.

    As mentioned above, it's hit and miss - I doubt it's a problem with the images because once you import the song again and drag the same image onto it it's ok!

    I'll let you know if it happens in future versions of iTunes and if I find out what's causing it.
  • -Bill Level 1 (0 points)
    This just started for me with iTunes 10.2.1. I rip an album, all songs play fine. I add artwork and 2-3 songs go bad. Toss it all, rip again, add different artwork, and 2-3 different songs go bad. I've only tried Apple Lossless so far, but regardless, this is the first time I have seen this. All of the albums I ripped today had this problem. This is happening on a MacBook Pro 15" core 2 duo. It is not happening with my 17" core 2 duo or my 17" quad core. All 3 have Snow 10.6.7.
  • nikokoren Level 1 (0 points)
    same thing happes to me too!

    just that im adding a cover to my movies and not artwork to albums.. but its basically the same thing! ayny fix yet?
  • Traveller84 Level 1 (0 points)
    I've been having the same problem! It does not happen to a lot of files, but it is still pretty worrisome. At first I thought it was a glitch with just really small AAC files, but I just discovered 3 ALAC files which suffered the same fate. I'm eventually hoping to head to the Genius bar to see if anyone can figure out what is happening.

    In the meantime, I would note that there is one other (older) discussion which seems to be pointing to the same problem. As far as I can tell, this goes back as far as summer 2010. See here:

    I've also posted a query on MacRumors, but got no reply.
Previous 1 2 3 Next