6 Replies Latest reply: Jun 26, 2010 12:26 PM by Old Toad
Shree-1 Level 1 Level 1 (0 points)
Hello!
I have the iWeb version3.0.1, the latest.

I published my web pages, with alterations, several times before my last attempt at republishing brought up the message:

Can't create file "header2.jpg." The disk may be damaged or full or you may have not sufficient access privileges.

It seems that the full stop after "jpg" is the offending culprit.

If so, how do I get rid of that?

I did not create this file myself. I just used the iWeb as instructed in the programme.

Suggestions will be welcome. Thanks. Kind regards.

Mac OS X (10.6)
  • Roddy Level 6 Level 6 (17,265 points)
    Publish your site to a local folder and launch it in the browser by double clicking the index.html file.
    If there is a problem with this, or you can't publish locally, have a look at this page under "Fix Iweb"....

    http://www.iwebformusicians.com/WebMusic/iWebTips.html

    "I may receive some form of compensation, financial or otherwise, from my recommendation or link."
  • Shree-1 Level 1 Level 1 (0 points)
    Hello Roddy,
    Many thanks for your interest in my difficulty, and for your suggestions.

    I am pleased to say that my problem has been solved!

    In the end, my switching off the computer, and restarting did it!

    Thank you again,

    My site, with the hyperlinks in place, in case you have the time to glance at it is, www.macrofacts.org

    With kind regards, Shree-1
  • healewis Level 1 Level 1 (0 points)
    Hi, sorry to jump in to an ongoing issue but, I just tried doing what you suggested and removing my com.apple.iWeb.plist as stated in the fix iweb section of the site you linked too. When I did, it removed all of my sites and now i have lost everything.

    My problem, after i find a way to re establish my sites and get them back on iWeb, is that I recently upgraded to snow leopard from tiger, I bought the bundle box set and upgraded iweb too I published my site to a server, checked it and everything was fine. I made some changes, published again and the changes have not taken effect. I've tried to empty cash, several times as you do in these circumstances, I've even tried to reset safari but no changes have been applied. I have saved the changes to a folder, used cyberduck and filezilla to upload the files to my server but to no avail. Any one got any ideas please,
    thanks again
    paul
  • Roddy Level 6 Level 6 (17,265 points)
    Deleting the iWeb .plist doesn't effect your domain file.
    Go to Home Folder/Library/Application Support/iWeb to see if you have one and double click it to launch it in iWeb.
    Its more likely that the Domain file got lost in the upgrade.
    When you published to a local folder, did you test this version in the browser by double clicking the index.html file?
  • healewis Level 1 Level 1 (0 points)
    Hi roddy, thanks for the reply. I can only explain what happened on my computer after moving the file to trash, I opened iWeb and it was as if it was being opened for the first time? There was nothing in the sites folder and a window popped up asking me to choose a design for my new site.

    (back tracking a little now) After installing The new software I had worked on my sites and was successful in publishing them to an ftp server. It was when I began to make changes that the sites would publish but when I viewed them the changes had not taken effect. I had exhausted all of the options I could find within support and came across your post and tried that. Since my post and your response to that, I have solved the issue I think?? I opened trash and dragged it back to t's original place I then opened iWeb again and my sites had returned! I repeated the publish to folder option and downloaded a newer version of cyberduck. I then uploaded the files I had changed and all was as it should have been in the first place. Due to the many options I went through, I can not say with accuracy what solved my publishing issue. I have not and will not try to publish to a server again as I think there are issues there and I like the control of publishing to a folder in my HD then deciding which files to upload from there as I have outside scripts etc like flash that need changes occasionally.

    Thanks again Roddy, I was not criticising your help, just questioning why what happened, happened and making a note for others reading the support forum to be aware of other peoples experiences.

    Cheers

    Paul
  • Old Toad Level 10 Level 10 (123,650 points)
    If you do not have your domain file in the default location, your User/Library/Application Support/iWeb folder, deleting the iWeb preference file will cause iWeb to look for it there and, not finding it, create a new, empty domain file. To relink iWeb to your domain location double click on the domain file to open it in iWeb. From then on iWeb will remember where it is.

    OT