Previous 1 2 3 4 Next 358 Replies Latest reply: Jul 12, 2014 2:50 AM by cepmanom Go to original post
  • zaphoda Level 1 (0 points)
    I had the same problem, and dagdagdag123's solution worked for me. I had to click a link to a specific app in the store (a generic AppStore link still gave the error). After that, all was fine.

    Thanks, dagdagdag123, for posting the solution that helped me.
  • Spanktheuser Level 1 (0 points)
    One possible solution is to adjust your screen brightness. I had a similar problem to the original poster. In my case, the issue was resolved by changing the screen brightness in Settings > Brightness and Wallpaper. I had been reading at night, and had selected the dimmest possible screen. Turns out there is a known networking issue that is somehow related to screen brightness. I'd suggest disabling auto-adjust, setting brightness to somewhere in the middle of the range, and trying again. It just might work.
  • Holycrapitsjeff Level 1 (0 points)
    Same problem here. I've adjusted brightness settings, opened ports, signed out, hard reset, soft reset, and nothing has worked. Restrictions are off, and I've got a good connection, since I'm writing this from my iPad, any new suggestions, anyone?
  • zaphoda Level 1 (0 points)
    Did you try dagdagdag123's solution? It worked for me. Here's a simple way to do it:

    Go here: http://www.apple.com/ipad/apps-for-ipad/

    Scroll down to see the featured apps, and click one of the "visit" links, such as "visit Real Racing HD on the app store."

    With any luck, this will take you to the app store. If you're doing this on an iPod, you'll get a message saying the app is only available on the iPad. However, at that point you should be able to click one of the App Store icons at the bottom of your screen.

    I hope this will work for you.
  • Holycrapitsjeff Level 1 (0 points)
    No sir, no luck. My iPad hates me I guess. Maybe I'll just restore it. Sigh...
    Thanks for yalls suggestions though.
  • Tadpole48 Level 1 (0 points)
    What worked for me...

    On the iPad select Settings, Store, SIGN OUT.
    Then signed back in again (email and password)
  • devastat Level 1 (0 points)
    What worked for me was to go to settings and sign out as well, but instead of signing in in the settings, go to app store application instead, click on the app you could not download and then choose 'sign in with existing apple id' and type down your name and password there.
  • Holycrapitsjeff Level 1 (0 points)
    Thanks for those two suggestions, however I assure you I have signed in and out a myriad of ways, still with no success. It's starting to anger me, and leaving me to question the appeal of only being able to obtain apps from a single "trusted" source.
  • devastat Level 1 (0 points)
    There a lots of other things you can try.. if you search the forum you'll find many suggestions that might help you..
  • Bebb2 Level 1 (0 points)
    I had exactly the same problem until a few mins ago,and the problem started when I got iOS 4 and game center, and because I hadn't confirmed the registration my iPad refused to connect to iTunes, so confirm your registration and all your problems will be solved. (hopefully)
  • jamievandyck15 Level 1 (0 points)
    I'm having the same problem. I was downloading fine on Sunday, now Monday it doesnt work. I know that I'm connected to the internet I can browse itunes,and apps store but when I try to purchase an app or download an update i get a box that says "cannot connect to itunes store". I've tried every suggestion listed and nothing works...any other suggestion other then wiping it out and starting over?
  • jamievandyck15 Level 1 (0 points)
    Update- I can connect from i iPad to purchase new music or apps, but cannot connect to download update for kindle app!?
  • Klimrod Level 1 (0 points)
    I use an iPad 3G. Never had any problem accessing the iTunes store through the app.

    Suddenly, it doesn't work and I keep getting the "cannot connect to iTunes store".

    Last app I have installed, on the day before the problem started, was the hungry birds free app.

    Tried all the above mentioned solutions without any results.

    However, through my iPhone and MacBookPro - no problem accessing the iTunes store.
  • Klimrod Level 1 (0 points)
    Solved the problem with the "restore" function in iTunes. Worked OK without any negative side effect.
  • Cooljames555 Level 1 (0 points)
    This solution worked for me perfectly. Thanks for the suggestion.
Previous 1 2 3 4 Next