Previous 1 12 13 14 15 16 Next 358 Replies Latest reply: Jul 12, 2014 2:50 AM by cepmanom Go to original post
  • frixxs Level 1 Level 1 (0 points)

    I tried several things here, but what worked was signing out of my Apple ID on the iPad 2. Settings/iTunes & App Stores/touch Apple ID: and tap Sign Out.  I then signed back in and all worked perfectly well!

  • MrCDavies Level 1 Level 1 (0 points)

    This worked instantly for me, it was miraculous!  Thank you, I had been trying to sort the problem for two hours before searching here for a solution.  Regards, Chris, Wales, UK.

  • Dominik Ras Level 1 Level 1 (0 points)

    Glad to see more and more confirmations that the 8.8.8.8 trick works. I think we all owe Mrs Iris a nice cold beer (or any other refreshing beverage of choice)

  • captel Level 1 Level 1 (0 points)

    I managed to reconnect to the APP store by rebooting the ipad. Hold both buttons for a few seconds,Then restart as normal.

  • MARSZILLA Level 1 Level 1 (0 points)

    <Edited by Host>

  • Dominik Ras Level 1 Level 1 (0 points)

    Marszilla, I second your comment about the date change routine - tried it and it didn't seem to do anything for me - but jailbreaking seems to be that other extreme in the spectrum of tips and tricks. I'm not so sure if that should be a common recommendation. That 8.8.8.8 trick should help.

  • Cdstancu Level 1 Level 1 (0 points)

    I can also confirm that rebooting worked. Tried first disconnecting and reconnecting to AppStore to no avail

  • nmyers Level 1 Level 1 (0 points)

    This is extremely disappointing. Yet another Apple products problem. Anyway..

     

    Cannot connect to iTunes Store to download purchased items. Restart, reset, blah blah blah..

     

    Apple isn't listening anyway.

  • cwbrandt2 Level 1 Level 1 (0 points)

    yomacau, thank you for your suggestion:

     

    1- Go to settings and logout from your store account

    2- Go back to APP Store and try to download whatever you wanted to download , it will ask you to login with your existing ID , do so with your password and it should work.Your download will start right away.

     

    Basically what you doing is to authenticate right before the download starts.

     

    I tried everything else mentioned and spent a great deal of time with other suggestions found via google, all were useless. There must be something about authenticating right before download that did the trick.

     

    ************************

    oops, I replied too soon. It worked for the single download that I was trying as a test. WHen I tried to "update all" it failed again. But I just singed out one more time and went to the store to try again.  this time it asked me for password and is now working again.

     

    Message was edited by: cwbrandt2

  • lebrits Level 1 Level 1 (0 points)

    I am also having the problem of "Cannot connect to iTunes Store". 

     

    I would contact Apple support about this, but I am not sure I can face the legendary arrogant and unhelpful response fron the iTunes team (yes, I have been subjected to this on so many occasions that I am willing to state this publicly).

     

    On my iPad2 when I click the STORE button in Newsstand I get the error "Cannot connect to iTunes Store".  However, everything works just fine when I click STORE in iBooks, or go to Newsstand in App Store, or go to any option in iTunes, or click STORE when I am in the Music app: These all work fine and give me access to the iTunes Store.  So, it is only from within Newsstand that I find this annoying error.

     

    I have checked my AppleID and password, I have hard rebooted my iPad, and have checked that Restrictions are OFF - they have never been on, ever. Doing all of these makes no difference to the Newsstand STORE access problem.

     

    Basically, the responses I can see in these 14 pages of people reporting the 'cannot connect' problem over the past 2½ years clearly shows that Apple does not have a clue how to resolve this, or is completely disinterested.  This is a disgrace from a company that spends $M per year trying to convince the world that its software is fully joined up and that its service is first rate.  Sorry, but the evidence here suggests that in this situation neither is true.

     

    Apple - get it fixed!

  • jkf943 Level 1 Level 1 (0 points)

    I struggled with this for hours. I had changed my Apple ID and couldn't sign back into the store or icloud--verification failed. I finally turned off WiFi and it connected. ta da. not sure what was up with that.

  • NiNi2cute041400 Level 1 Level 1 (0 points)

    I had no problem getting into and signing in but everytime i go to the app store and try to download a app it says cannot connect to I tunes Store

  • angelofromwesterly Level 1 Level 1 (0 points)

    I have the same problem... I hooked up a new cisco velet router and I can not connect to iTunes to download upgrades but I can connect to the internet...I have mixed WPA2/WPA mode..  Also instagram will not load but all othe apps load with no problem. Any help would be great!

    Thanks

  • dialabrew Level 1 Level 1 (0 points)

    Thanks so much!  I did what you suggested, and it's working perfectly now!  THANKS again! 

  • Marc470 Level 1 Level 1 (0 points)

    Let me caution anyone who uses the date change routine now that I have spent time wiping and restoring my iPad.  I am on an Exchange server and have notifications far into the future.  When I advanced my system date by a year, the iPad was overwhelmed with notifications.  I couldn't turn my WiFi off (or do much of anything else) so had to walk away from the building (semi-rural setting so didn't walk too far) to disable WiFi but could never recover.  However, the iPad did function pretty normally when connected to iTunes on my PC so I was able to backup (don't forget your documents - I have lots in GoodReader), wipe, recover, restore.

     

    Hope this gets a permanent fix soon.

Previous 1 12 13 14 15 16 Next