14 Replies Latest reply: Feb 16, 2012 12:03 AM by Osama425
MadDog31 Level 1 Level 1 (0 points)
Good evening.

I'm on the phone w/ Apple (on hold while they ponder my situation). I do not have the FaceTime toggle switch in Settings > Phone. I've restored with a backup, I've restored as a new iPhone, I've reset network settings, I've reset all settings, I've done airplane mode, you name it...I've done it.

This being said, over the last two days I've had 3G/EDGE data issues with AT&T here in the Bronx (with both my 3GS and iP4). Could this for some reason be an issue in terms of letting the network know what phone I have, etc? This is really stumping me. Apple told me that a small text is sent out when a phone is activated to sync it with the network...my texting, calls, and wifi surfing are fine, but any time I try to access the Internet over EDGE or 3G, I hang.

Could this be causing a problem b/c the network doesn't know that I can dump a call to WiFi when a FaceTime connection is established?

iPhone 4, iOS 4
  • mav2k10 Level 1 Level 1 (0 points)
    I got it to work only by doing a full restore and setting phone up as NEW. If I restored from my 3g backup sync, I get all my nice folders (that took me an hour + to organize) but NO Facetime toggle under +Settings --> Phone+.
    So, there seems to be a file overwriting the original setting to allow Facetime to work in the restore....now to see if anyone can track that down or come up with a better way to fix this.

    I am in the middle of one other option: Doing a NEW backup of the iPhone 4 first, then doing a new Restore from the main screen (to clean it up) and lastly restoring that newly created backup when it asks you to set up as NEW or from Backup. Will post results shortly
  • mav2k10 Level 1 Level 1 (0 points)
    UPDATE:

    I did the factory Restore , then resorted the iPhone4 Backup I did right before the Factory restore. End Result the same. No Toggle. and No FaceTime, even after reboot.



    Its looking like setting up as a new phone may be the fastest way to get this back as of this writing.

    Message was edited by: mav2k10
  • Bucksdelux Level 1 Level 1 (0 points)
    I'm betting you're backup was of a jailbroken 3G/3GS. If you search the internet you'll see that the ios4 update has caused problems for people updating from jailbreak phones. There has been no 3G or MMS working. The same thing happened to me. Once I set up my phone as new under restore I got the facetime icon.
  • MadDog31 Level 1 Level 1 (0 points)
    I got it to work, and here's how:

    After getting the call escalated, we worked through some things. Turns out when doing a restore in iTunes, you let it do its thing and when it comes up to the point where you can set it up as a new iPhone or from a previous backup, you disconnect the iPhone without selecting any of those options (it should be activated at that point). Bingo.

    It was the backup causing a problem (from a non-jailbroken iOS 4.0 3GS). So now I gotta restore stuff by hand, but I'm fine with that as I wanted to do that in the first place!

    Hope this helps.

    Ian
  • mav2k10 Level 1 Level 1 (0 points)
    Yes... That does work...there is a file in the backup thats overwriting carrier settings im thinking.

    STILL - the restore and set up as NEW does work...just sad to see all that wasted Folder effort for the 200+ apps I have to redo....maybe can get them down to 100 now.

    btw: iMovie for iPhone 4 just released. Just bought and now to try out...
  • SteelerDan Level 1 Level 1 (10 points)
    cant find imovie
  • mav2k10 Level 1 Level 1 (0 points)
    search in iTunes for iMovie and it will show. I was not able to find it last night on the phone, but may be there today
  • b00ger Level 1 Level 1 (0 points)
    Same issue. Restore from 3GS w/ iOS4 killed FaceTime. Annoying since now I have to download iOS4 for iPhone4 to reset to factory. Going to have my wife try restoring from her first gen iphone since it seems like its iOS4 backups that are causing the issue. We'll see.
  • b00ger Level 1 Level 1 (0 points)
    As it turns out, I think you just need to go into Settings->Phone and turn FaceTime back on. Too bad I already did the restore.
  • DaleOwen Level 1 Level 1 (0 points)
    b00ger, there's a good chance you didn't have the FaceTime option there to actually switch on before you restored anyway. There are lots of people having the exact same problem as you. But hey, starting from fresh can't be too bad!
  • TBray2 Level 1 Level 1 (0 points)
    HELP!!!

    I am going to attempt to do the "pullout" but I want to know if I will lose my contacts, photos, etc...need help fast!
  • leem0401 Level 1 Level 1 (0 points)
    I've recently acquired an iPhone 4. My brother also got it with me.
    My brother was able to use FaceTime with his friends. He started the phone new because this was his first iPhone. However, I had an iPhone 3GS previous to this one. When I transfered all my contacts and data, everything seemed fine until when my brother tried to FaceTime me. When I went to contacts, there was no FaceTime icon. So I searched that there is a toggle to turn FaceTime on and off but when I went to settings, then phone, the FaceTime toggle under My Number does not exist. I came across this topic which everyone is seem to having the same problems as me.

    Does anyone have other solutions than pulling it out? I would try it but I'd rather have a completely safe method.
  • wtoddm Level 1 Level 1 (0 points)

    I have a very similar issue. FaceTime is acknowledged in my Restrictions and options, but there is no "app" for Facetime like on my iPod Touch or Mac. The option to FaceTime someone from the Contacts menu is there. I suppose it just seems very counterintuitive, and that's just not the Apple way. I'm in South Korea, by the way.

  • Osama425 Level 1 Level 1 (0 points)

    Hi all, excuse my french but is any one of you guys is an apple rep. Or a professional ios software trouble shooter...

    If apple does not support there devices (as in) give correct info to customers to activate such menus in a reasonable way not restoring/resetting and all these stp:d long process hoping that it will work and when it does you lose all your downloaded software or you need to re-sync and all that hassle.... Excuse me! have you ever had a problem in a pc one day and never had an explanation for it anywhere but a simple restart resolved the problem..... This relates to that... Orelse there was something OFFICIAL said about how to bring back the original menu. Why im i writing this ... My poor brother will need to restore to get the menu on his 4s coz he lost it when upgraded from iphone4.... I personally think upgrading between phone has many bugs but are better kept under the rug and not talked about. Thx for reading.

    Peace to all.