Previous 1 2 Next 15 Replies Latest reply: Sep 19, 2010 4:57 PM by matts84
bp_dp Level 1 (0 points)
Yeah I know there are a bunch of these through out the interwebs but nothing seems to solve my problem. Here is my story.

I was running 10.5 on my mac pro. maybe about 4-5 months ago. one day I was unable to connect to google and any google site - youtube, blogger, gmail, even yahoo etc... I searched around and tried a bunch of things I found on forums, nothing seemed to work. So my solution was to just upgrade to 10.6 which I had been meaning to do anyway. problem solved.

I ran 10.6 for about 3 months till it happened again. so again I searched around and this time changing my DNS from my ISP's server (Comcast) to openDNS seemed to work. Everything was fine using the openDNS servers till about 2 weeks ago when it happened again. this time I can connect to google.com, just not youtube, gmail, googlemaps etc... I tried changing the DNS back to the ISP's then back to openDNS, nothing. I bought a brand new router (Airport extreme) Nothing. the weird thing if I go to one of those free proxy sites and type in an address that I can't access - it loads without issue. So I'm wondering if for some reason my IP is being blocked, is there anyway to find that out?

Mac Pro, Mac OS X (10.6.4)
  • bp_dp Level 1 (0 points)
    Sorry now that I'm thinking about it, it can't be a blocked IP because I have a macbook pro also in this network and I've never had a problem with it. but any other ideas I'd love to hear them. thanks!
  • rack0 tack0 Level 4 (2,595 points)
    Have you any 3rd party firewall running, or software for parental controls on the Mac Pro?
  • andyBall_uk Level 7 (20,490 points)
    Can't access them from more than one browser... or just Safari ?

    If the latter, I'd try a new user account & if that behaves, remove all relevant cookies via Safari-Preferences-Security-Show Cookies
  • bp_dp Level 1 (0 points)
    Thanks for the replies. But sorry not firewalls / parental settings, I am running a network monitor "little snitch" but that is disabled.

    I added a new user account and I get the same results. I've tried safari, fireFox, and opera.

    By the way to make this issue even stranger today for some reason I can load google maps. but the controls in the upper left never load (zoom and pan). if I type in a location it stalls out. I still can't load youtube and a few other sites like blogger. I also have ubuntu running in a VM I get the same results.

    'bout ready to throw this thing out the window.
  • rack0 tack0 Level 4 (2,595 points)
    Have you checked the DNS configuration. Have a look at this post by William it explains how DNS works in Snow Leopard. http://discussions.apple.com/thread.jspa?threadID=2227251
    Also you could use the 'scutil --dns' command in terminal, that would inform you just what DNS servers your machine is using, you may get a surprise.
    I would also check the hosts file in /etc/ my has the following entries. I would not expect this to be much different to most systems unless yours has been altered.

    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting. Do not change this entry.
    ##
    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost
  • William Kucharski Level 6 (14,985 points)
    I suspect, but do not know, that your ISP's name service may be returning IPv6 addresses for the Google sites but something at your ISP isn't handling them properly.

    Have you tried shutting off IPv6 in your Network preferences pane?
  • bp_dp Level 1 (0 points)
    Thanks again for more replies.

    the output for sctil --dns looks fine to me. the ip's for openDNS are listed under resolver #1 and comcast (my ISP) for the domain and search domain.

    my host file is exactly the same as yours.

    William I have tried that. and just tried it again without any luck.

    Some good news though. google maps, google images and blogger are working again. still can't access youtube and yahoo though. very strange. seems like it's fixing itself little by little.
  • prontosystems Level 1 (40 points)
    Hi,

    your problem maybe sounds like a broken path MTU discovery on the route to the involved target servers.

    http://support.apple.com/kb/HT2532

    HTH Tom
  • bp_dp Level 1 (0 points)
    That's interesting, I've never knew that. I lowered the value and it didn't solve my problem, but good to know. Thanks.

    I ran the disk utility last night and it reported some errors. I need to get a hold of my install disk (which is always a challenge to find) to repair. I doubt it has anything to do with my issue but I think I should repair before trying anything else just so I'm at square one. I'll let you guys know how it goes.

    Thanks again.
  • bp_dp Level 1 (0 points)
    okay so I repaired the disk and permissions and it didn't resolve my problem. Also the day after I posted that google maps was working again it went out again. One thing I also forgot to mention is that mail can only seem to access my comcast account and none of my three other (work, gmail, and another personal) email accounts work they have the gray triangles next to them. playing around a little more I also can't connect to ichat (AIM Account) but I can access the aim website: http://www.aim.com/ go figure.
  • andyBall_uk Level 7 (20,490 points)
    Hi

    you've never had any firewall/filtering software, and un-installed it?
    if2k, for example ?
  • bp_dp Level 1 (0 points)
    the only thing I have installed is little snitch which I have disabled since the issue came up. I guess I could uninstall in completely.

    I brought the machine into the office today and it behaves the same here, so it's not the network or the isp.

    I'm wondering is there anyway to have multiple host files? /etc/hosts looks okay but could there be another one in a different directory that is also being used? if so how can I find out where these other files might live?
  • rack0 tack0 Level 4 (2,595 points)
    I don't know of any other host file, but maybe someone else does.
    I have just checked my ipfw daemon and the output is this:-

    sudo ipfw show
    33300 0 0 deny log icmp from any to me in icmptypes 8
    65535 31579 17508253 allow ip from any to any

    This shows that incoming ping is denied( I presume from the setting in the firewall preferences pane) but all others are allowed, this must be default, I have not set anything in ipfw. The SL application firewall is enabled, but will not be shown here.

    You could check this firewall setup.

    You could also try and trash the application firewall plist

    Have you checked the console logs? Anything show in those.

    After that for me it would be a matter of using network analyser software to figure out what the Mac is sending and receiving on its network port.
  • andyBall_uk Level 7 (20,490 points)
    Find any File - http://apps.tempel.org/FindAnyFile/

    will speedily locate anything by name, not content though. It can search invisibles & also run as root if required. Easyfind - http://www.devon-technologies.com/products/freeware/ is slower, but allows content searches.

    Your issue is rather like (same servers) one I saw with if2k - the reason I felt I should double-check that you had never used such software, even on 10.5.x

    I don't suppose you've a Resolvers folder in /etc/ ? - probably not, but it's a thought.
    Finder will show you, just use Finder-Go-Go to Folder & enter /etc/

    does a ping to the affected domains work ?
Previous 1 2 Next