Previous 1 8 9 10 11 12 13 Next 185 Replies Latest reply: Sep 8, 2015 2:47 AM by minijoni Go to original post
  • tncrna Level 1 (0 points)

    "No Sender"  messages I've had are dated 12/31/69. three total today, when I clicked on the first one to delete it, another one came, then when I clicked on that one, after clicking on the "edit" button, another one came in a few minutes.

     

    Your reply worked: went to the "sent" messages box, and back to the "inbox", and it cleared the 3 emails I had.

    Interesting that the message has no content, and no sender.

  • Book Guy Level 1 (0 points)

    I cleared my history and my cache in my iphone settings and that cleared up the problem for me.

  • barbara1940 Level 1 (0 points)

    I am getting the same thing every day.   They seem to disappear on their own.

  • disneybride Level 1 (0 points)

    OK, this has happened to me and in the past going to "Sent Items" or something else worked. Not this time. Found this answer in another forum.  Hold down the power button and the home button at the same time. Wait for the phone to shut down. Restart and the emails will be restored. Worked like a charm!

  • deggie Level 9 (52,729 points)

    That is called a Reset. It is mentioned several times in this thread. You are responding to a post that is 6 months old and has 10 pages, did you read them all?

  • ctvogel Level 1 (0 points)

    Simplest solution is to turn email account off, select Done, and then turn it back on again.  All such messages will disappear.

  • Lark.Landon Level 1 (35 points)

    How to get rid of the ghost e-mails.

     

    Click the Home button to suspend the Mail application and return to the Home screen.

    Double-click the Home button to view recently used apps.

    Select the Mail app by tapping and holding the Mail icon until the red minus appears.

    Tap the red minus to quit Mail. This also removes Mail from recently used apps.

    Double-click the Home button to return to the Home screen.

    Reopen Mail.

  • mouse7123 Level 1 (0 points)

    I had this problem and i fixed it by resetting the iPhone by holding down Home button and Power button.

  • sumic Level 1 (0 points)

    I have no idea how to step back to the root folder in an email, but just opening my sent box got rid of the no sender/no message entries.  Wonder how long it will last.

  • AnotherAppleFan Level 1 (0 points)

    This worked for me!

  • Cannimar Level 1 (0 points)

    Thank you very much. I tried your metod and it worked. I have to see if it comes again. many messages dated 01/01/1970. no sender and no content. Can't delete also. Apple needs to sort it.

    iphone 4 iOS4

  • thinker109 Level 1 (0 points)

    The easiest way of doing this, is just quit your mail application, once you go back to it all those bogus emails will be gone.

  • intentionMan Level 1 (0 points)

    Interesting buggy stuff.  In my case it was only on my iPad and only in the "all inboxes" mailbox.  In none of the individual inboxes did it show.  By selectively turning off one mail source or another I discovered that these messages were all related to Apple (iCloud) and none of the other servers (Gmail etc.).  This problem did not show up on my iphone (4) and did not exist on my iMac nor in iCloud webmail.

     

    I see that the issue has existed for a long time for some of you, although I've only experienced it recently and have had al these devices for over a year.  Previously I had tried the switching switching off of apple mail and that only resolved it for a brief time.  As new mail came in the old messages would return and new ones as well.  I was able to relate them to existing messages in my iCloud mailbox, since I could view the phone and ipad at the same time.  Each "this message has no content" item in the All Messages box had a corresponding visible regular mail in the iCloud box.

     

    I believe it has something to do with mail downloads being interupted and background flags being set incorrectly, at least in my case because the iPad only works on wifi and I know that interupted downloads had occured.  I also know that it takes some time for the various devices to all sync up so my being in a hurry may have complicated the issue.

     

    Reading your posts I decided to turn off Apple mail for a few hours and that seems to have done the trick.

     

    Thanks everyone.

  • MrBobert Level 1 (0 points)

    The issue you're experiencing is because your device is trying to access a Message that has already been retrieved by another client, and a copy was not saved to the server. This happens with POP accounts, sometimes by default, but can be changed within the settings of the client.

     

    Please review this article to help you modify the settings in your respective email clients:

     

    http://support.apple.com/kb/HT3228

  • intentionMan Level 1 (0 points)

    Thank you.

     

    All my devices have been set ( also just checked to be sure ) long ago, to leave messages on the server for a week so I don't think this was the issue.

     

    I had thought that iCloud was an IMAP and not a POP server.  My quick search on the web seems to suggest that this is true, so I don't think POP was the issue either.

     

    Thanks for the offering