Previous 1 5 6 7 8 9 Next 183 Replies Latest reply: Apr 6, 2015 3:59 AM by NewBartleby Go to original post
  • netguru10 Level 1 Level 1 (0 points)
    "Scott,

    For my iPhone4, the issue was solved by setting up the iphone4 all over again as a "new iphone" and not from the backup of the old phone. I successfully replicated the issue in my second iphone4 (no sender email objects dated 12/31/1969 or 12/31/00) and then solved it by setting up the phone as a new iphone. None of these 'no sender' emails have appeared since I did that a month ago.

    hope that helps.
    "

    So, if you set your phone as a new phone, how do you get all the backup data back? It will be a nightmare to manually enter all the data for all apps all over again.
  • DeveloperProgramer Level 1 Level 1 (10 points)
    No Sender Name
    No Message
    Yes you carn't delete it!!!!
    Very poor show for such an expensive phone!
    Is Apple trying to help Microsoft?
    Get it fixed now!!!!
  • Kembond Level 1 Level 1 (0 points)
    I'm having the same issue. (No Sender) and (No Subject) at least 10 times a day. They are not spam as I'm able to see them correctly on my computer at work. I have 4 different accounts and it is only happening on one, an exchange account. I've done a restore and no go. Going to try deleting the account and re-enter and see what happens. If that does not work I guess I'll try setting it up as a new phone, which will suck!

    I have had every iphone, this was the one I was most excited about. They really dropped the ball this time around. I think they were hearing too many footsteps, eg Android, Windows 7. They got a little scared.

    Come on Apple.

    Antenna
    Sensor
    Bluetooth
    email

    Whats next?
  • Jan r Level 1 Level 1 (0 points)
    I am also experiencing this problem. I figured out I can solve it temporarily (until it happens again and I have to repeat a short procedure). I go to settings, and then to mail settings. I switch arrange mails by thread on or off. Then I go to my inbox and everything is ok again. I then switch the "arrange by thread" back to what I had before. Changing and changing some of the other settings also worked.

    Hope this helps someone until it's properly fixed. Im running os 4.1.

    Good luck,
    Jan
  • Archon Fung Level 1 Level 1 (5 points)
    I have this problem as well. I think that the mail application goes into a kind of funk occasionally which has at least two symptoms.

    (1) the (no subject) (no sender) no content messages that people have noticed.

    (2) new mail doesn't load the 2 line message previews - I only get the subject and sender on new incoming messages. You can see this if you go to a mailbox which has messages not in the iPhone's cache (say Sent messages) - my iPhone will load uncached messages - it will get the subject and sender but not the message previews.

    Some people have suggested turning threading on-and-off in order to fix the problem. On my phone, that will get rid of (1) but not (2). The easiest way to fix (1) and (2) is to force-quite the mail application on the phone and then re-launch mail. To force-quite, go to the home screen, double-click the home button to bring up the application dock, hold your finger on the Mail app icon until the red X appears, tap the Mail icon.

    Its annoying, but works every time. I have to do this about once per day, whenever I see (1) or (2).

    I'm running iOS 4.01 on an iPhone 4. Mail server is IMAP.

    Hoping 4.1 will fix this, and that it will be released soon.

    Message was edited by: Archon Fung
  • vichar4u Level 1 Level 1 (5 points)
    Hi,

    This no sender no subject issue stooped after I changed two settings.
    settings> account name > archive messages - OFF
    settings> Fetch new data > OFF

    I know, I know - logic is defied but it worked! Bingo and all the useless mail disappeared from my iphone!

    I am using gmail on iphone.

    cheers and I will hope this works for you...
  • Longwoodguy Level 1 Level 1 (0 points)
    I have the same problem with my iphone4. Does ANYONE FROM APPLE ANSWER OUR QUESTIONS? I don't see any help being offered....
  • helenek7 Level 1 Level 1 (0 points)
    thank you SOOO much for your help. this was driving me crazy and I ended up having 7 1969 emails! you saved me a trip to the apple store!
  • basilbug Level 1 Level 1 (0 points)
    That fixed it!!! Thank you so much! How easy!
  • sypark Level 2 Level 2 (355 points)
    Yes, it works, but only temporarily.
  • jaysie Level 1 Level 1 (0 points)
    I just go 30 (No Sender) (No Subject) messages. What's going on?
  • MojoNano Level 1 Level 1 (0 points)
    I fixed my wife's iPhone 4 "zombie message" problem by going to settings, Mail, accounts, selected gmail, tapped gmail off, then tapped it on. All the no sender messages disappeared and no new ones have appeared in two days.
  • Jeff Kash Level 1 Level 1 (60 points)
    I read a fix for this from Apple today.


    http://support.apple.com/kb/TS3426
  • Scott Dye Level 2 Level 2 (175 points)

    http://support.apple.com/kb/TS3426
    rohit-pa wrote:
    Scott,

    For my iPhone4, the issue was solved by setting up the iphone4 all over again as a "new iphone" and not from the backup of the old phone. I successfully replicated the issue in my second iphone4 (no sender email objects dated 12/31/1969 or 12/31/00) and then solved it by setting up the phone as a new iphone. None of these 'no sender' emails have appeared since I did that a month ago.

    hope that helps.


    I might try something like this - I have downloaded a slew of apps since getting it. However, this is my first iPhone, so it was never "migrated" in the first place - it was originally set up as a "new" phone.


    Jeff Kash wrote:
    I read a fix for this from Apple today.

    At least they've owned up to it being an issue, but as others have said, this appears to be one of the (several) temporary work-arounds, not a fix. What was that Steve Jobs said about "if you have to open a task manager..."?
  • John Springer Level 1 Level 1 (70 points)
    That worked for me as well. I went to settings>mail>[my imap account] and turned Mail to OFF, then turned it back on again. I'm running 4.0.1, and I just started getting these today. Hope this fix works. Havent installed 4.0.2 yet.
Previous 1 5 6 7 8 9 Next